SIMPROJ USER MANUAL

Installation

Creation Tool

Adjustment Tool

Inspector Window

Projector properties

Projection surface

Projector move

Projector orient

Statistics

Projection image

Viewing from the projector perspective

Groups

Exporting to CSV

View Tabs

Snapshots

Layer Management


Installation

The SimProj plugin works with Sketchup 8 up to Sketchup 2017, for both Mac and Windows.

Installation for Sketchup 2017

As simProj is not available in the Warehouse, in order to allow Sketchup to install simProj, make sure your loading policy is set to ‘Unrestricted’.

Then open up the extension manager from the Window, click on the Install extension button, and browse for the simPro rbz file.

Installation for Sketchup 8 to 2016

To install the plugin, go to the Sketchup Preferences, go into the Extensions section, and click on the Install Extension button.

Then browse for the SimProj .rbz file that you downloaded. Sketchup will ask you to restart Sketchup in order to use the plugin.


Creation Tool

First, check that the SimProj Toolbar is activated by going to the View menu, Toolbars, and make sure SimProj is checked.

The projector creation tool can be activated by clicking the first icon in the SimProj toolbar, or going to the Plugins -> Simproj menu.

A projector is created by choosing two points, for the projector location and the target where it will aim at.

The two points can be created by simply left clicking on the projector location, then dragging to choose the target location. Releasing the left button will then create the projector.

Don't worry if you can’t position the projector exactly where you want right away. SimProj offers a special Adjustment Tool allowing a better and easier control over the projector placement.

Note that when the projector is aligned with a world axis, its color will change to the world’s axis color. It’s an easy way to make sure your projector is aligned properly.

You can cancel the creation by hitting the Escape key.

Once the projector is created, SimProj will automatically send you back to the select tool. So if you want to create additional projectors, you will have to select the projector Creation tool again.

Adjustment Tool

The tool can be activated by either:

- Right clicking on a projector box, and then choosing Adjust Projector

- Selecting a projector (left click on either its box, projection cone, or target), and clicking on the Projector Adjustment Tool in the toolbar.

Once the tool is activated, you can switch between three control modes accessible in the right click context menu.

Each mode has its own benefits depending on what you want to achieve. Note that for very fine position tuning, you may also use the Inspector Window to type in the exact increments you want in placement and orientation.

Let’s see how each mode works:

Move: translates both the projector and its target along their relative axes. You will usually need this to roughly position the projector in the world right after its creation.

Adjust Projector: rotates the projector around its target, or dolly towards/away from it. The target will remain fixed. Use this mode to control the projector orientation.

Adjust Target: controls the viewing direction of the projector by orbiting the target around it. The projector position will remain fixed.

In each mode, the controls are the same:

- Hover the mouse over the axis you want to move along, it will be highlighted in yellow

- Left click and drag along the axis to position the projector, and release to confirm

Note that the circular orbits will display yellow dots and four crosses when highlighted. Each dot are separated by exactly one degree, and the crosses represent cardinal positions in the world.

If you position the projector or target on a cross, your projector view direction should be aligned with either the x,y or z world axis.


Inspector Window

The inspector window is a floating window that can be displayed by either clicking the inspector icon in the toolbar or by going in the Plugins -> Simproj -> Show Inspector menu.

The inspector window will allow you to tweak the projector specification, so you can get good illumination result, and achieve the surface projection coverage you want. The first upper left section contains information on the projector properties:

Projector properties

Projector Name (first input field): name of the projector.

Throw Ratio: defined as the distance (D), measured from lens to screen, that a projector is placed from the screen, divided by the width (W) of the image that it will project (D/W). It is usually part of a projector specification. The smaller it is, the more ‘wide’ the projector lens is.

Aspect Ratio: 16/9, 4/3, 16/10, or 1.89:1 (2K)

Horizontal Resolution: width of the image in pixels.

Lumens: power of the projector, in ANSI lumens.

Horizontal/Vertical Shift: this allows the image to be off-axis from the projector axis. This feature is usually available only on mid to high-end projectors.

Roll: allows to put the projector in landscape or portrait mode.

W/H/D : width/height and depth of the projector in inches.

Lens/Target XYZ Pos: absolute position in foot of the projector lens, and its target

Projection surface

Once the projector is properly placed, it will automatically compute a projection grid on surrounding objects, and update it whenever you move the projector. However if you want to manually force an update you can use the Update Projection Grid button.

Simproj will launch a ray every 100 pixels, so every square inside the grid represents 100x100 pixels.


Projector move

This section of the inspector window is used for moving the projector and its target. It is the equivalent of using the adjustment tool in move mode, but allows better precision.

Move / Dupl(icate): controls if pressing the surrounding buttons will either move, or duplicate the current projector with the desired transformation. Using the duplicate mode is a really efficient way of creating an array of projectors.

Out / In : moves or duplicates the projector towards or away from its target. Target is fixed.

Left / Right / Up / Down : moves or duplicates the projector and its target along its left/right relative axis. Directions are defined relative to the projector viewing direction.

Move by: defines the exact distance the projector will be move or duplicated in the desired direction. You can choose between inches, feet, or meters. Change the value in the input field to have the precision you need.

Projector orient

This section of the inspector window is used for precisely controlling the projector orientation.

Proj. / Tgt: controls if pressing the surrounding buttons will either affect the projector or its target.

Up / Down / Left / Right: Rotates the target/projector around its relative axes.

Orbit by: defines the angle of rotation in degrees

Statistics

Once you have defined a projection surface with the project on selection button , simProj will compute some statistics.

Dpi: average number of pixels per inch on the projection surface. Imagine you put your thumb on the projection screen and count the number of pixels along it.

Luminance: the theoretical average image brightness. The luminance depends on multiple factors, mainly the distance between the projector and the screen, and the projector brightness. On the right part, simproj will tell you if the luminance is ok for viewing in a dark or low light room. If it is LOW, you will need to either boost the projector brightness, or move it closer to the screen. We assume a surface gain of 1.

Note: Simproj will give you the theoretical luminance, do not take it for exact science. In practice, it will depend on the surface properties, the actual projector brightness (usually less than the specs), and the optics of the projector. Allow a +/- 15% variation to be safe.

Throw Dist(ance): distance between the projector and its target.

Projection image

Once you have defined a projection surface, you can decide to project an actual image instead of the default grid.

To do this, check the Image checkbox, and then browse for your image by pressing the Choose Image... button.

You can control the opacity of the image by entering values in the Alpha input field. This is useful if you want to overlap multiple projections.

Viewing from the projector perspective

Simproj allows you to view from the projector’s perspective. To do that, just press the View From Projector button.

There will be an animation that will put you inside the projector lens. This tool is useful to make sure nothing will get in the way of the projection and cause shadows.

Note that simProj does not allow to simulate shadows, though it may in the future.


Groups

To show the projector groups dialog, press on the projector group icon in the toolbar.

It will display the projector group dialog:

To create or delete a group, just press the + or - buttons.

To rename a group, modify the name in the upper right text field.

To add a projector in a group, select then in the left panel, and then click on the >> button

To remove a projector from a group, select it in the right panel, and click the << button

The advantages of using group are:

- Easily select a group of projector: all groups will be available for selection in the inspector, like shown in the picture below. When selecting a group, the inspector will only show the properties that are the same among all projector, and display empty fields whenever the values are different for at least one projector.

- Manipulate multiple projectors at once: this includes projector placement, and properties. For example, typing 2000 in the lumen field will apply the value to all the projectors inside the group. Pressing the Left button will also move each projector on its left (always relatively to their viewing directions).

Note that it is also possible to select multiple projectors by Ctrl+Click them, editing values in the inspector will also apply them to all the selected projectors.

Exporting to CSV

Simproj can export all the projectors information into the CSV format, so you can easily use it in third party applications. To export, just go to the Plugin -> SimProj -> Export to CSV menu.

The image shows what it would look like when imported into a google spreadsheet.


View Tabs

To use this feature, just go to the Plugin -> Simproj -> Create / Update Tabs

Simproj will create views for each projector in separate tabs. When clicking a tab, it will transport the user into the corresponding projector’s eyes. Note that If you move the projectors after having created the views, you will have to update them to match the new positions by calling the command again.

It will also create “Scenes”, which you can then use to create animations for a presentation.

Snapshots

When using this feature, simProj will save an image from each projector’s perspective. For complex projects, this is a really visual way of specifying projector placement to another person.

To save those snapshots, go to the Plugins -> Simproj -> Save Snapshots menu.

Once the snapshots are ready, it will prompt a window telling you where to find the files.

Layer Management

Simproj creates all its objects into three layers. This allows to easily hide or show the projectors/cones/grids, and isolate them from the rest of your components.

Simproj_proj: contains the projectors and their targets

Simproj_grids: the projection grids (created using the project on selection button)

Simproj_cones: the projection cones