
COMPLIANCE SOP 
 
 

Access Table  
 
The below table helps to enable/ disable a certain page for any role functionality under compliance 
and understand what all properties are required for each page. 
 
Path:   MIS Admin > Manage Roles > Change Role Functionalities > Select Role > Enable/ Disable 
according to the table 
 

Compliance Modules View Access Edit Access 

Manage Vendor vendor_view vendor_view, vendor_edit 

Manage Vehicle Type cab_view cab_view 

Manage Vehicle cab_view cab_view, cab_add, cab_Edit, 
cab_Manage 

Manage Driver driver_view driver_view, driver_edit, 
driver_add, driver_details_edit 

Manage Compliance compliance_view manage_compliance_data 

Approval Dashboard Raise SE Ticket Raise SE Ticket 

 
Under Manage Vehicle/ Driver please validate what type of access the requestor wants : 
 

 Access Type Manage Vehicle Manage Driver 

View Only cab_view driver_view 

Add Cab_view, cab_add Driver_view, driver_add 

Details Edit Cab_view, cab_Edit, cab_Manage Driver_view, driver_edit, 
driver_details_edit 

Compliance Edit Cab_view, compliance_view, 
manage_compliance_data 

Driver_view, compliance_view, 
manage_compliance_data 

 
 

➔​Common Issues and causes 
◆​ If someone is raising concern they are not able to access any page or edit 

access then the access can be given by raising support ticket Only support 

 



 

team can provide/modify the access to above mentioned modules or any roles, 
Customer cannot provide or edit access to any role for above modules 

 
 
NOTE: Roles for which these pages are by default disabled: Security Supervisor, Senior billing 
auditor. 
 

MANAGE VENDORS  
Page Direction : Settings > Manage Vendors 
Vendor addition is required to add the vehicle and driver in the ETS, All the vehicles and drivers are 
associated with the vendor. Vendor is the party who provides vehicle are drivers for commuting. 
 
➔​Vendor Creation 

STEP 1 : Click on “New Vendor” 

 
STEP 2 : Fill out all mandatory fields like Vendor ID, Vendor Name, POC, Email ID and         
                Save It.                
Note: Vendor ID has limit of 5 Characters 
          Vendor Name does not allow special characters like hyphen (-) 
Vendor name cannot be duplicated 

 



 

 
 

➔​Vendor Update & Deactivation 

1: To edit or update the vendor ID click on “3 dots” icon and select “Edit” > Make the 
necessary changes > Save it 

 
2: To deactivate the vendor > Click on Deactivate > Give confirmation > Done - please note 
that while deactivating the vendor, all the vehicles and drivers association with that vendor 
should be removed, else the system will not allow to deactivate the vendor. 
 

➔​Common Issues and causes 

The debug steps/ potential resolution are provided under each issue: 
 
◆​ Manage Vendor page not available/ access request. 

●​ Raise SE Ticket 
◆​ Unable to create a new vendor/ error message. 

●​ Vendor might already available in inactive vendors 
●​ Vendor ID might be more than 5 characters 

 



 

●​ Vendor Name might contain some non-supported special characters 
 

 

MANAGE VEHICLE TYPES 
 
Page Direction : Settings > Manage Vehicle Type 
Vehicle type is defined to know what kind of vehicles we are using for commuting. It has the 
information like fuel type, seating capacity, usage type, so that based on which we can create a 
contract and in future which helps in billing the trips done by that vehicle. 
 
➔​Vehicle Type Creation 

STEP 1 : Click on “New Vehicle Type” 

 
 
 

STEP 2 : Fill out all mandatory : More attention on details like -  Usage Type & Fuel Type 

 

 



 

NOTE: These Vehicle types are associated with contracts which come under ‘Billing’. While creating 
a new vehicle we link contacts with vehicles and the information given in vehicle types is fetched via 
contracts. 
 
➔​Common Issues and causes 

The debug steps/ potential resolution are provided under each issue: 
 
 

◆​ Incorrect Fuel Type reflecting in compliance vehicle report. 
●​ Guide the client that the linked vehicle type of the vehicle is associated with 

the reflecting fuel type, so check in the manage vehicle type whether the 
vehicle type of mentioned vehicle is associated to correct fuel type or not. 

 

MANAGE VEHICLES 
Page Direction : Settings > Manage Vehicle 
Vehicle creation is required to assign the trip for commuting, and also it has all the information of the 
vehicles, which will further help us to find how many active/inactive vehicles present in the system 
and also help in planning the commute. Manage vehicle page has all the information of vehicle such 
as Vehicle ID, vehicle registration number, vendor with which vehicle is associated, office for which 
vehicle is taking the trips, contract and vehicle type, also the driver associated with the vehicle. 
 
➔​Vehicle Creation   

There are three ways of creating a vehicle in the system: 
 

1.​ Add Vehicle  
Add vehicle is used in case when a single or a few cabs are needed to be created.  

 



 

 
●​ BASIC INFO TAB: Fill all the mandatory fields like Vendor, Vehicle ID & Registration No. 
●​ IMEI number will only be associated with only 1 vehicle, If IMEI number is already associated with 

other vehicles then it will not show in the dropdown until you remove the IMEI number from other 
vehicle. 

●​ Vehicle ID has to be unique, any duplicate vehicle ID is not permitted 
●​ Device IMEI: Select the Driver Mobile device IMEI number 

 



 

 
●​ CONTRACT Tab: Link the contract and it will fetch the vehicle type details from the contract itself. 
●​ Start Time: It is the hour of the day from which you want to activate the vehicle (Schedule Activation) 
●​ Working Time: Time duration between start duty and end duty for a day. 

 
●​ Driver TAB: Search driver name or license number and system will fetch the mobile number from 

driver profile 
●​ Garage Name & Geocode: Both are free text fields that can be entered manually. 

 
Finally, add a comment and save the created vehicle. 

 
2.​ Add Virtual Cab  

 
Virtual Cabs are used in the cases where a vehicle is needed on immediate or urgent 
basis but none is available hence creating a temporary vehicle to perform the trip. 
 

●​ Click on the drop down beside “Add Vehicle” and select “Add Virtual Vehicle ” 

 



 

●​ Fill up all the details which appear on the screen like vendor , Vendor ID, Contract, 
Reg No, etc. and save the vehicle. 

●​ The vehicle will reflect under “Active Vehicles” with an [V] differentiator. 

HOW TO USE A VIRTUAL CAB ?? 
 

●​ On the Routing page, assign the vehicle as we normally assign any other vehicle. While selecting 
virtual cab a new pop up will reflect asking for driver details and registration no. 

 



 

 
 
NOTE: As this is a temporary vehicle, it can be used with any driver or any registration number. 

 
3.​ Bulk Upload Vehicle 

Bulk Upload is the feature which allows the user to create vehicles in bulk by using a 
.CSV template. 
 

●​ Click on the drop down beside “Add Vehicle” and select “Bulk Upload ” 

●​ Download the template from the pop-up reflected. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

●​ Below is the screenshot of the template : Fill the details accordingly and the vendor, contract 
& driver needs to be associated should already exist in the system. 

●​ We can only use bulk upload to create a vehicle not to update the existing vehicles. 

 



 

●​ On the portal again click on upload file > Choose File > Upload. 
 

 
NOTE: Vehicle Compliance Document upload is covered later in this document to avoid any confusion. 

 
➔​Vehicle Deactivation 

HOW TO DEACTIVATE A VEHICLE ?? 
 

●​ Go to Manage Vehicle > Search the required cab > edit (Pencil Icon) 

●​ Under Basic info click on change status and select the date to schedule from which date the 
vehicle will be inactive. 

●​ NOTE : Remove the device IMEI and make it none so that if that driver needs to be used with 
another vehicle we can link the device to another vehicle. 

 



 

●​ Add a comment on DRIVER TAB and save it. 
●​ NOTE: Upon Deactivation, the linked driver will automatically be removed from the vehicle if 

that driver is associated with another vehicle, If the driver is only associated with 
 

➔​Vehicle History 
●​ Go to Manage Vehicle > Search the required cab > edit (Pencil Icon) > History 

➔​Common Issues and causes 

The debug steps/ potential resolution are provided under each issue: 
 

◆​ Unable to add the vehicle. 
●​ If the add vehicle option is not available then it is an access issue, reach out to 

the support team to get access. 
●​ If the issue is while saving after adding the vehicle details, then check if all the 

mandatory fields are added in correct format, If all are added and still not 
getting add option or getting any error it might be some technical issue. 

◆​ Unable to deactivate the vehicle. 

 



 

●​ The vehicle might be associated with an incomplete trip, Or IMEI number is 
not removed, If there is no active trip and IMEI number is also disassociated 
still there is error, it might be some technical issue. 

◆​ Unable to activate the vehicle for the past date. 
●​ The vehicle cannot be activated for a date on which the associated contract 

was not created. The vehicle can only be activated for the link contract 
activation date and after. 

◆​ Unable to unassign the driver from the vehicle while deactivating the vehicle. 
●​ Driver field in vehicle profile can not be left empty, and a dummy driver needs 

to be assigned if only the vehicle needs to be deactivated. 
◆​ Error in bulk vehicle upload. 

●​ Check the file they are trying to upload, is it aligned with the template. 
●​ Try downloading the fresh template and upload the data with it. 
●​ Check all the mandatory fields are added. 
●​ Check the format of all the fields in the template. 

◆​ Unable to change the vendor of the vehicle. 
●​ Vendor of a vehicle cannot be changed due to billing concerns. We have to 

create a new vehicle under the new vendor. 
◆​ Unable to link driver IMEI device in vehicle. 

●​ The device might be linked with another inactive/ active vehicle. 
●​ The device will not show up if it is not configured in the system. 
●​ Driver would have not installed the app and logged in with the licence number 

registered in the ETS. 
●​ Check the licence number used to login to driver app by driver. 

 

MANAGE DRIVERS 
Page Direction : Settings > Manage Drivers 
 
PAGE OVERVIEW 

 

 



 

➔​Driver Creation   

There are two ways of creating a driver in the system: 
 

1.​  New Driver 
 

Select the “New Driver” option on the upper right corner of the Manage Drivers page. New Driver is 
used in case when a single or a few drivers are needed to be created. 
 

 
 

●​ PERSONAL DETAILS TAB: Fill out all mandatory fields like driver name, mobile number, gender, 
current city, vendor. 

●​ Select the Offices for which the driver will operate. 
 

 

 



 

 
 

●​ DOCUMENTS TAB : Enter the Driving Licence Number, Expiry Date, DL document and Induction 
details like date, document. We can create the driver only by filling these details, rest all documents 
and info are part of driver compliance. 
 
DRIVER COMPLIANCE UPLOAD 

 
NOTE : Unlike vehicle, the driver compliance document and info can be uploaded while creating the 
driver itself.  
 

●​ DOCUMENTS TAB : Under the document tab all the compliance details and documents can be 
uploaded as mentioned in the screenshot below 

 



 

●​ There are three steps that are required to successfully upload the driver compliance information for 
each field. 

1.​ Upload the document 
2.​ Update the expiry date 
3.​ Mark the status - Success/ Pending/ Failed 

 
Save the driver once all details are uploaded. 
 
 

2.​  Bulk Upload Driver 
   
Bulk Upload is the feature which allows the user to create vehicles in bulk by using a .CSV template 
 

●​ Click on “Bulk Upload” option on the upper right corner of manage drivers page and download the 
.CSV template. 

●​ The template contains all the personal information and the compliance detail fields to upload for the 
driver including the status of all compliance details - Success/ Pending/ Failed. 

●​ After filling all details: Select Bulk Upload > Choose File > Select the file > Upload. 
 

Note: To upload the compliance documents, you’ll have to edit the driver profile one by one and upload the 
documents.  

 
➔​Driver Deactivation  

NOTE : To deactivate a driver, first we have to ensure that the associated cab is also inactive OR no 
cab is associated with the driver else it will throw the below error. 

 



 

 
HOW TO DEACTIVATE A DRIVER ?? 
 
 

●​ Go to Manage Drivers > Search the required driver > Action > Deactivate 

●​ Give the desired comment of deactivation and confirm. The driver will reflect under inactive drivers. 

 
 
 
 
 

➔​Driver Blacklisting  

Note : Only inactive drivers can be blacklisted so we have two ways to blacklist 
1.​ While deactivating the driver : Check the “Blacklist Driver” box and give the desired comment. 

 

 



 

2.​ After deactivation : Go to inactive drivers > Action button > Blacklist 

 
 

●​ Give the valid reason for blacklisting and confirm. 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
NOTE: Once a driver is blacklisted only “Site Administrator” has the right to whitelist 
 

➔​Common Issues and causes 

The debug steps/ potential resolution are provided under each issue: 
 

◆​ Unable to save/update driver details/ Page going blank after saving. 
●​ If the driver is associated with an inactive vehicle the details cannot be edited. 

The client will need to activate the vehicle and again deactivate the unlink the 
driver and then the driver can be edited. 

●​ If the driver itself is deactivated, ask the client to activate first. 
◆​ Unable to deactivate the driver. 

●​ If the associated vehicle is active the driver can not be deactivated. Please 
guide the client to unlink the associated vehicle first then deactivate the driver 

◆​ Unable to upload driver compliance documents. 
●​ Check if the property “Driver_details_edit” and “Manage_compliance_data” 

properties are enabled for the role. 

 



 

 
◆​ Unable to delete the driver documents. 

●​ This is a document extension issue which requires data fix every time such an 
issue comes up so reach out to support team and share the document and 
driver details which need to be deleted from backend 

◆​ Unable to upload induction document/ Induction document upload option 
missing. 

●​ The induction document option is dependent on the property 
“driver_details_edit” please check if it is enabled for the given role. If not, 
create TS. 

◆​ Error in driver bulk upload/ File not getting uploaded. 
●​ Ask for the error screenshot from client, if given, check for which driver the 

error is reflecting, possible reasons are: 
○​ Driver already exists in the system 
○​ The file uploaded is not as per the supported  template. 
○​ The file uploaded is not a .CSV extension file. 

 

MANAGE COMPLIANCE 
Page Direction : Settings > Manage Vehicle > Manage Compliance 
 
PAGE OVERVIEW 

 
1.​ Vehicle Pending Compliance Information: Under this tab all the vehicles whose compliance 

information is yet not updated will reflect. 
2.​ Active Vehicle with Compliance Information: All the Active vehicles in the system whose 

compliance information is updated will reflect here and will show the compliance status of the vehicle. 
3.​ Inactive Vehicles: All the inactive vehicles and their compliance information will reflect under this tab. 

 



 

4.​ Approval Dashboard: Link to approval dashboard where the compliance information that has been 
updated will be approved by the approving authority (transport team generally). 

5.​ Bulk Data Upload: Option to update the compliance details (Not Documents) of the vehicles in bulk.  
6.​ Vehicle Audit: Shows the compliance history of vehicles 
7.​ EHS Audit: Shows the EHS history of the vehicles. 

 
COMPLIANCE PROCESS OVERVIEW 
 
The Compliance process includes the steps from induction of a vehicle to making the vehicle compliant in 
status. 
 
STEP 1: Once the vehicle is inducted it will reflect under the “Vehicle Pending for compliance tab”, upload the   
compliance details and documents of the vehicle. 
STEP 2: Verify the details and documents & approve them from the approval dashboard. 
STEP 3: Pass the EHS of the vehicle from the EHS dashboard (Further explained in document). 
STEP 4: The associated driver should also be compliant in order to perform trips in that vehicle. 
 
NOTE: These compliance details, documents and EHS expires based on the set compliance configurations 
and make the vehicle Non-Compliant in status. 
 
 

➔​Vehicle Compliance Upload 

There are two ways of uploading the compliance details of the vehicle in the system but for the documents we 
will have to edit one by one for each vehicle: 

 
1.​ One By One Compliance Upload: To upload the compliance details and documents, click on the 

“Action” button under the “Vehicles pending for compliance tab” 

 
All Compliance Details: 
 

 



 

All Compliance Documents: 
 
 
 
 
 
 
 

 
 
 
 
 

2. Compliance Bulk Data Upload:   
 
 STEP 1: On the Compliance page click on the top right corner option “Bulk Upload” and download 
the template. 

 

 
STEP 2: Fill up the details for the already existing vehicles in the system and upload the file in “Bulk 
Data Upload” section 

 



 

 
 
 
 
 
 
 
 
TO DOWNLOAD THE COMPLIANCE REPORT 
 
In the active and inactive compliance tab you’ll find the download option to fetch the compliance 
report. You can select the xls to download in excel format or CSV to download in CSV format .We 
can download both drivers and vehicle compliance report in respective tabs. 
 
 
 
 
 

 

 

 

➔​Driver Compliance Upload 

Click on the link above to upload the driver compliance details and documents. 
 
 

➔​Approval Dashboard 

 
Page Direction : Settings > Manage Vehicle/ Manage Drivers > Manage Compliance> Approval 
Dashboard 

 

http://format.we


 

 
The Approval Dashboard is the page where all the compliance uploaded details/documents for 
vehicles and drivers are verified and approved. 
 
STEP 1: Search the driver/ vehicle for which the document/ detail needs to be approved. 

 
 
STEP2: Click on the field which is pending for approval (Highlighted in yellow) for example 
insurance. Verify the date and document and click - Approve/ Reject and submit. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
NOTE: To check the approval history - click on the top right corner option of the page “View Approval 
Audit” search for the vehicle/driver by using the registration number or license number. 
 

 



 

 
 
 
 
➔​COMPLIANCE CONFIGURATIONS 

Page Direction : Site Administrator > Compliance Configuration >  Compliance Configuration & 
Alerts > Compliance Configuration Tab 
 

🚦 Compliance Configuration Rules – 
Vehicle Non-Compliance 

Vehicles are marked Non-Compliant if any of the following rules are triggered. 

 

1. Document Expiry Rules 
For each document type, vehicles can be marked Non-Compliant under 3 conditions: 

●​ Expiry Date Rule → Vehicle is marked non-compliant a set number of days before expiry 
date.​
 

●​ No Expiry Date Rule → If expiry date is missing.​
 

●​ No Document Rule → If the document is not uploaded.​
 

Document-Specific Rules: 

●​ Insurance → Vehicle non-compliant if insurance document is missing, expired, or near 
expiry.​
 

 



 

●​ Road Tax → Vehicle non-compliant if road tax proof is missing, expired, or near expiry.​
 

●​ Pollution Certificate → Vehicle non-compliant if certificate is missing, expired, or near 
expiry.​
 

●​ Commercial Permit → Vehicle non-compliant if permit is missing, expired, or near expiry.​
 

●​ Fitness Certificate → Vehicle non-compliant if certificate is missing, expired, or near expiry.​
 

●​ Vehicle Service → Vehicle non-compliant if last service record is missing or overdue.​
 

●​ Fixed Device (GPS/IMEI) → Vehicle non-compliant if required tracking device is missing or 
not configured.​
 

 

2. Vehicle Age Rule 
●​ Non-Compliant if Age Crosses → Vehicle will be marked non-compliant when it crosses the 

configured Years/Months limit.​
 

○​ Example: If set to 8 years, vehicles older than 8 years are non-compliant.​
 

 

3. Exemptions 
●​ Exempt Road Tax for Cab Type → Selected cab categories can skip Road Tax compliance.​

 
●​ Exempt Pollution Checks for e-Vehicles → Electric vehicles do not require a pollution 

certificate.​
 

●​ Exempt Permit Check for e-Vehicles → Electric vehicles can bypass commercial permit 
requirements.​
 

 

4. Approval Rules 

 



 

●​ Vehicle Non-Compliant if Approval Status is Pending/Failed​
 

○​ Pending → Vehicle cannot be marked compliant until documents are reviewed.​
 

○​ Failed → Vehicle fails compliance if approval is rejected.​
 

●​ Auto-Fail Rule → Approval status automatically changes from Pending → Failed if left 
unapproved beyond the set number of Hours.​
 

 

5. Vehicle Age Calculation Rule 
●​ Calculate Age from Manufacturing Date → Compliance system calculates vehicle age 

based on manufacturing date instead of registration date.​
 

 

6. Permit Type Rule 
●​ Enable Permit Type → Activates additional permit-based compliance checks (e.g., 

city/state-specific permits).​
 

 

7. EHS Rules 
●​ Vehicle Non-Compliant if EHS Status is Failed/Expired​

 
○​ Failed → EHS checklist not passed.​

 
○​ Expired → EHS approval validity has lapsed.​

 
●​ Automatic Expiry → EHS status automatically expires after configured hours (default: 168 

hours = 7 days).​
 

●​ Display Audit Category Wise → EHS audit report is grouped by categories (e.g., Safety, 
Environment, Mechanical). 

 

 



 

 
 

 

 
 
 
 
 
 
 
 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
RULES FOR NON-COMPLIANCE  - DRIVERS 
 

👤 Compliance Configuration Rules – Driver 
Non-Compliance 

 



 

Drivers are marked Non-Compliant if any of the following rules are triggered. 

 

1. Document Expiry Rules 
For each driver compliance document, the system checks: 

●​ Expiry Date Rule → Mark driver non-compliant a set number of days before expiry date.​
 

●​ No Expiry Date Rule → Mark driver non-compliant if expiry date is missing.​
 

●​ No Document Rule → Mark driver non-compliant if the document is not uploaded.​
 

Document-Specific Rules: 

●​ License → Non-compliant if missing, expired, or near expiry.​
 

●​ Badge → Non-compliant if badge is missing or expired.​
 

●​ Background Verification → Non-compliant if background check status is not valid.​
 

●​ Police Verification → Non-compliant if missing, expired, or not verified.​
 

●​ Medical Verification → Non-compliant if no certificate or expired.​
 

●​ Training Verification → Non-compliant if training proof missing or expired.​
 

●​ Eye Test Verification → Non-compliant if eye test not updated or expired.​
 

●​ Vaccination Status → Non-compliant if not vaccinated or missing proof.​
 

 

2. Status Threshold Rules 
●​ Background Check Status → Mark non-compliant if pending/failed/in progress (Which is 

selected)​
 

●​ Police Verification Status → Mark non-compliant if pending/failed/in progress (Which is 
selected)​
 

 



 

●​ Medical Verification Status → Mark non-compliant if pending/failed/in progress (Which is 
selected) 

●​ Training Verification Status → Mark non-compliant if pending/failed/in progress (Which is 
selected)​
 

●​ Vaccination Status → Mark non-compliant if pending for configured days..​
 

 

3. Age Rules 
●​ Driver Age Above → If driver exceeds configured age limit, mark as non-compliant.​

 
●​ Minimum Allowed Age → Default is 18 years. Driver age cannot be added below 18 years​

 

 

4. Profile Requirements 
●​ Enable Driver Father Name (If enabled) → Driver profile must include father’s name if 

enabled.​
 

●​ Profile Image Rule(If enabled) → If no profile image uploaded, driver is non-compliant.​
 

 

5. Approval Rules 
●​ Driver Non-Compliant if Compliance Approval is Pending/Failed (Whichever enabled)​

 
○​ Pending → Until documents are approved.​

 
○​ Failed → If explicitly rejected.​

 
●​ Auto-Fail Rule → If approval remains pending for more than configured Hours, status 

changes to Failed automatically.​
 

●​ Enable Approval Flow for Non-Mandatory Documents → Even optional docs can follow 
approval flow if enabled.​
 

 



 

 

6. Exemptions & Configurations 
●​ Opt-in to Share Blacklisted Driver Information (If enabled)→ Share blacklisted driver 

details across BUID.​
 

●​ Disable Non-Compliant Check for Police Verification(If enabled) → Skip police 
verification for compliance check.​
 

●​ Disable Non-Compliant Check for Background Verification(If enabled) → Skip 
background verification for compliance check.​
 

●​ Allow Trip Allocation on Partial Verification (If enabled)→ Drivers can still be assigned to 
trips even if one between the PVC or BGV is valid. 

 
 

 
 
 
 
 
 

 



 

 

 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
Additional field option is introduced to add required fields according to customers needs in vehicle 
compliance, so that they can upload the documents other than the default once. 
 
 
 
 
 
 
 

 



 

 
 
 
 
 
 
 
 

🚨 Compliance Alert Rules – Vehicle 
Approaching Non-Compliance 
A vehicle is marked as “Approaching Non-Compliance” when an alert is raised according to the 
following configurations. 

In the below descriptions Alerts is nothing but an email notification will be sent when the conditions 
are met and also status will be marked approaching non compliant. 

Path : Site Administrator > Compliance Configuration >  Compliance Configuration & Alerts > Alert 
Configuration > Vehicle section 

 

1. Document Expiry Alerts 
For each compliance document mentioned below, Status will be changed to approaching non 
compliant and email alerts can be sent a specified number of days before expiry: 

●​ Insurance 
●​ Road Tax  
●​ Pollution Certificate 
●​ Commercial Permit  
●​ Fitness Certificate 
●​ Vehicle Service 
●​ Fixed Device​

 

 

2. Vehicle Age Alerts 

 



 

●​ Email Alert if Vehicle Age Crosses Limit​
 

○​ Configurable by Years and Months.​
 

●​ KM Threshold by Vehicle Type​
 

○​ Warning Threshold → Email alert triggered when nearing the limit.​
 

○​ Max KM Threshold → Email alert triggered when vehicle exceeds configured KM.​
 

●​ Enable Custom EHS Distance → Allows setting custom mileage/distance values for 
EHS-based alerts.​
 

 

3. Approval Alerts 
●​ Alert on Email if Approval Status Pending​

 
○​ Triggered if approval pending longer than configured Hours.​

 
●​ Alert on Email for Approval Done​

 
○​ Sent when documents are successfully approved.​

 

 

4. EHS Alerts 
●​ Alert on Email if EHS Status Expired​

 
○​ Triggered before expiry, based on configured Hours.​

 
●​ Alert on Email if EHS Status Failed​

 
○​ Sent immediately upon failure.​

 
●​ Alert Frequency​

 
○​ Alerts can repeat at configured intervals → Every configured Day(s).​

 

 



 

 

5. Recipients of Alerts 
●​ Transport Operations → Comma-separated email IDs can be configured.​

 
●​ Office Wise Email IDs → Configure alerts by office location.​

 
●​ Vendors → Vendors can also receive alerts; email IDs can be viewed/edited.​

 

 

6. Vehicle Activation/Deactivation Alerts 
●​ Email Alert on Vehicle Activation/Deactivation​

 
○​ Sent whenever a vehicle status changes.​

 
●​ Recipients​

 
○​ Transport Operations (configurable email list).​

 
○​ Vendors (via configured vendor email IDs). 

 
 

 



 

 
 

 

 



 

🚨 Compliance Alert Rules – Driver 
Approaching Non-Compliance 

A driver is marked as “Approaching Non-Compliance” if any of the following alert rules are 
triggered. 

Path : Site Administrator > Compliance Configuration >  configure compliance & Alerts > Alert 
Configuration > driver section 

 

1. Document Expiry Alerts 
For each compliance document, alerts can be configured to trigger via email before expiry or if 
status remains unchanged: 

●​ License → Alert before expiry​
 

●​ Badge → Alert before expiry​
 

●​ Background Status → Alert if background verification is not updated within set days.or if 
status not updated.​
 

●​ Police Verification → Alert before expiry or if status not updated.​
 

●​ Medical Verification → Alert before expiry or if status not updated.​
 

●​ Training Verification → Alert before expiry or if status not updated.​
 

●​ Eye Test Verification → Alert before expiry​
 

●​ Vaccination Verification → Alert before expiry​
 

 

2. Status Threshold Alerts 
●​ Background Check Status → Alert if status is selected as (Failed/in progress/pending)​

 
●​ Police Verification Status → Alert if status is selected as(Failed/in progress/pending)​

 

 



 

●​ Medical Verification Status → Alert if status is selected as(Failed/in progress/pending)​
 

●​ Training Verification Status → Alert if status is selected as(Failed/in progress/pending)​
 

●​ Driver Vaccination Status → Alert triggered 1 day before expiry or if status unchanged.​
 

 

3. Age Alerts 
●​ Driver Age Alert → Email alert when driver age crosses configured limit (Default: 65 years).​

 

 

4. Approval Alerts 
●​ Pending Approval Alerts → Email sent if approval remains pending longer than configured 

Hours.​
 

 

5. Profile Alerts 
●​ Profile Image Alert → Driver marked approaching non-compliance if no profile image is 

uploaded.​
 

 

6. Alert Frequency 
●​ Alerts can repeat automatically based on configured interval → Every X Day(s).​

 

 

7. Recipients of Alerts 

 



 

●​ Transport Operations → Comma-separated list of emails can be set (example: 
Transporttps@tatapower.com).​
 

●​ Office Wise Email IDs → Configure recipients per office.​
 

●​ Vendors → Vendors can also receive alerts; vendor email IDs can be viewed/edited.​
 

 

8. Driver Activation/Deactivation Alerts 
●​ Email Alert on Driver Activation/Deactivation → Alerts are triggered whenever a driver is 

activated or deactivated.​
 

●​ Recipients​
 

○​ Transport Operations (configurable email IDs).​
 

○​ Vendors (via configured vendor email IDs). 
1.​  

 

2.​ Define the status for which the “Approaching Non-Compliance emails should be triggered” 
amongst success/failed/pending. 

 



 

 
 

3.​ Email Frequency and whom to trigger?? 

 
 
COLUMN Configuration 
 
Page Direction : Site Administrator > Compliance Configuration >  Compliance Configuration & 
Alerts > Column Configurations Tab 

 



 

 
Under this tab all the compliance checks for vehicles and drivers are available, selecting these 
checks will impact in two ways: 

1.​ The selected field will start reflecting as a column in the compliance page. 
2.​ The selected field will be included in compliance status calculation. 

 
For Vehicles :  
 
 
 
 
 
 
 
 
 
 
 
 
 
For Drivers: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



 

 
 
 
 
 
➔​Common Issues and causes 

 
◆​ Unable to view Manage compliance page. 

●​ Refer to the access table and check if the required properties are enabled for 
the mentioned role. If disabled please reach out to the support team. 

◆​ Unable to view the Approval Dashboard. 
●​ please reach out to the support team to check if the access is provided for the 

mentioned role 
◆​ Active vehicle/driver reflecting under inactive compliance tab or vice versa. 

●​ This is data fix issue create a TO ticket with the vehicle/driver details 
◆​ The vehicle/driver compliance documents and details are uploaded, still the 

vehicle/driver is non-compliant. 
●​ Check the approval dashboard if the uploaded details are not approved yet the 

vehicle/driver will be non-compliant. Ask the customer to approve the 
documents. 

◆​ The compliance document is not expired, still reflecting non-compliant. 
●​ Check the “Rules for Non-compliance” that before how many days a certain 

document will expire and convey the same to the client. 
●​ Also if the configuration is set to “0 days” the document will expire on the date 

of expiry itself at 00:00. 
◆​ The compliant vehicles are reflecting non-compliant on the routing page. 

●​ It is possible that the vehicle is compliant but the associated driver is 
non-compliant which is why the pair is reflecting non-compliant. 

●​ Check if the both the vehicle and drivers are compliant on the compliance 
page and still the vehicle is non-compliant on routing page- Raise a TS-ticket 

◆​ The client wants to remove an unwanted compliance field/Column from the 
compliance page or wants to remove from compliance calculation. 

●​ Check the column configurations under compliance configuration- if the field is 
enabled it will be considered for compliance calculation- ask the client to 
uncheck the particular field. 

◆​ Approaching non-compliance email IDs need to be changed/ Email frequency 
needs to be changed. 

●​ Refer to the alert configurations under the compliance configurations. 
◆​ The EHS checklist needs to be updated/ New EHS items need to be added in the 

list. 
●​ For existing EHS line items you can guide the client how to enable/ disable a 

field or add the check list, we can add the required field from EHS checklist 
section 

 



 

●​ For new items to be added, raise a TO ticket. 
 
 

EHS 
 
EHS Configuration 
 
Page Direction : Site Administrator > Compliance Configuration >  Compliance Configuration & 
Alerts > EHS Configurations Tab 
 

1.​ EHS Checklist: 
   
The EHS checklist contains all the EHS parameters that need to be checked while passing the EHS 
for a vehicle. 
To enable a particular line item we have to mark the checkbox in front. We can also make a 
parameter mandatory which will ensure that if it is not checked you cannot pass the EHS for that 
vehicle. 
If any customer needs to add a new checklist they can use the option to add category and checklist 
in compliance configuration under EHS checklist section. 
 

2.​ Email Alerts: 
 
Under this tab we define the type of EHS emails should be triggered and whom to send these 
emails. Also we can define the office wise email IDs like other compliance emails. 
 
 

Driver configuration 
 
Driver configuration is introduced to automate the BGV and PV documents and expiry dates. 
 
If the Driver config switch is enabled for BGV and PV then manual expiry date additions will be 
disabled in the documents section in manage driver page, The expiry date will be calculated from the 
current date + ‘buffer configured at the status level on BU’. e.g. When the status is set to 
"In-Progress," the Expiry Date should be auto-populated as 15 days from the current date. or When 
the status is set to "Success," the Expiry Date should be auto-populated as 365 days (or 3 years) 
from the current date. 
 
To change status , the user will be asked to delete the existing document and upload a new one. e.g. 
When BGV is in progress (expiry date and the doc exists), an attempt is made to set the status Success, 
an Alert popup will appear to delete the existing document first. 

 



 

 
 
 

Non Compliance vehicle warning and blocking 
 
Compliance violation 
 
We have a configuration where you can block the non compliant vehicle while assigning it to a 
route/tripsheet. 
 
Path :  Settings => config dashboard => Compliance configuration => Compliance violation action 
 
If we enable the switch, we can select any actions below to act on non compliant vehicles in the 
routing page. 
 
Warn non-compliant vehicle / drivers - We will warn saying the vehicle/driver combination is non 
compliant while assigning the vehicle in the routing page. 
Block non-compliant vehicle / drivers- We will block the assignment of vehicle saying the 
vehicle/driver combination is non compliant. 
Remove Future Trip Assignment On Non-Compliance - If the vehicle becomes non compliant after it 
is being assigned to a trip then we will remove the future trips associated with that vehicle. 
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