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Major steps

e Step 1: Starting a new document in InDesign
o Step 2: While composing the document

e Step 3: Exporting to PDF within InDesign
e Step 4: Within Acrobat Pro

Note:

Each step ends with a Checkpoint.
Ensure you have completed the checkpoint list before moving on to the next step.

Topics under investigation

These are issues/topics that need updating or still need content:
e Fillable form elements
e Table lines not being artifacted correctly
e Spanned cells
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Step 1: When starting a new document in InDesign

A. Set the title and the author for document

In File > File Info: type in the document title and author. This will transfer to the PDF
(with the correct export settings later in the process) and will be the title that appears in

the browser tab when the PDF opens, what search engines will discover, and what blind

people hear when they open the PDF.

File Information for Untitled-1.indd

Origin

IPTC

IPTC Extension
GPS Data
Audio Data
Video Data
Photoshop
DICOM

AEM Properties

Raw Data

Powered By

Document Title:

Author:

Author Title:

Description:

Rating:
Description Writer:

Keywords:

Copyright Status:

Copyright Notice:

Copyright Info URL:

Creation Date:
Modification Date:

Application:

A

How to export an accessible PDF from InDesign

Marshall Sunnes

Semicolons or commas can be used to separate multiple

values

Unknown

Adobe InDesign 15.0 (Windows)

f Preferences I Template... ~ ‘ Cancel I
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B. Set Paragraph Styles for headings
1. Ensure the Paragraph Styles panel is open (Type > Paragraph Styles)

2. Input six separate text areas with “Heading 17, “Heading 2”, etc for headings 1
through 6 using the Typing Tool. Style the headings as you see fit. This will be

the template for that heading level. (Hint: stick with names like “Heading 17)

i Paragraph Styles

[Basic Paragraph]

[Basic Paragraph]
Heading 1
Heading 2
Heading 3
Heading 4
Heading 5

Heading &

C. Edit all export tags

Now that you have set your Paragraph Styles for headings, you need to set how those
styles will export to the PDF tags.
1. Find the Paragraph Styles panel (Type > Paragraph Styles)

2. Select the pane fly-out menu (g) > Edit All Export Tags
3. At the top of the Edit All Export Tags window, select the PDF option button.
4. For each style you created, select the corresponding Tag:

EPUB and HTML © PDF 0K

Teg |::’ Cancel )

f Heading 1 H1 - g
% Heading 2 H2
% Heading 3 H3
9 Heading 4 [Automatic]

P

H1

H2
v

% Heading 5
% Heading 6

H4
H5
He
Artifact

Note:

You can map multiple styles to a heading tag.
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Checkpoint — “Step 1: Starting a new document in InDesign”

Before you begin composing your document, make sure you have:
o Set the title and author for the document

o Added Paragraph Styles for Headings 1 through 6
o Set your Export Tag settings
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Step 2: While composing the document

A. Use a separate layer for your background content.

Although all content can be contained
within the same layer, it may be
beneficial to place background content
in a separate layer from the text and
important images. This helps avoid
overlapping issues when ordering the
layers content later. You may also
choose to put all images in a separate
layer group.

2 Layers

O ~ Background & Decorative

o <Histor...Graduate School .=

o =linax=

o <line=

o <line=

o I <line=

o » <groups

~ Text & Important Images 4
<Washin... by Fernand Har...>
<weddingwashsquare.jpg=

=The Gr...hool of Arts and ...>

<Histor...he Graduate School=

B. Use paragraph styles to mark headings

Use the paragraph styles to identify the major headings in the document as you
compose.
Use heading styles to indicate text that is functioning as a heading; do not use heading
styles to change the formatting of text if the text is not functioning as a heading:
e Heading 1: Title of the document (use once)
e Heading 2: Major topic/idea (can be used multiple times)
e Heading 3: Items that topically are children of heading 2 (can be used multiple
times)
And so on...

To apply the heading style
Select the heading text > Paragraph Styles pane > select the appropriate heading style.

Note:

You can visually change how the heading looks after you set the paragraph style.
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C. Use built-in lists

Make sure to use the built-in lists that come with InDesign. The time savings will be
considerable.

D. Use built-in tables

Make sure to use the table options provided with InDesign, in particular, always use
table headers, and do not use tables as “layout” tables.

Even with best practices, you will still have to do some work in Acrobat Pro. To minimize
how much work you need to do, avoid spanned (merged) cells. Spanned cells can be
made accessible later, but it is usually not an easy process.

E. Anchor images into the text flow

InDesign allows you to insert machine-readable reference images in the text by
anchoring. To anchor an object in an accessible location in the text flow without
changing the original position of the object, click and hold the blue square, and then
drag it to the desired location within the text and release. The blue square changes to
an anchor icon, indicating that the object is anchored.

k 1 e . Crererrsin gy e i s by-old Sew
wcades dollar vo o B bl otk e vy the bl ok 4 s s e B [

- P -
e d ol oo | ﬂmmh r\-l&nl'\-‘u-:ldi-lhh-hl ﬂuﬂ‘nﬂ.h

Plaors b Vg i Farin. R
s of (e gl e gt ot et o of s g b g s sz o . | bl oamablih o m...u,mm- kit
| T 1 A E— B | T N L S S E———.
et b i et araca ] prodasid il ook, Redar, L casrhat s ol cacit e e et | prokasid sl foods. Redar, th casrkat u ol
L o S PR Y ——— Aonmmalder s 1 ey bl s e Y ————
cablastot st of Ok B, cuakdey thi dhwir | jbislocavanis abkascst it of O Bote', catko tha dirweiy | b boravameit
sprderirus paredie. Wisdon hoppmgisscple Tt i 8 feverirol pickers s mperdert i parediee. Windon hopymgis s copder Trmmarhet in o frverinol proicen sodiag
s g o s ket . e sl bbbt sl oo i B, Ui s i i oo sl k. o | Mbaribi's sl oo il G, 1 sk
Dewsdur L : 1 2 I ’ L : 1

To anchor an object, drag the blue square on a frame (left) to the desired location in the text. When
anchored (right), the blue square becomes an anchor icon.

Image source: Adobe "Creating Accessible PDFs"
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F. Add alt-text to your essential images
You can add alt-text (descriptions for the blind) to any image you deem essential.

To determine if an image is essential, ask yourself: “If the image were removed for all
users, then would any critical information be lost?” If the answer is “yes”, then provide
alt-text for only that information that is lost. It is not necessary to provide aesthetic
information if it is not critical, but also consider if an image adds to the tone of your
document.

Examples of critical information/imagery:

Dates

Images of text not provided in the actual text

Icons that indicate a warning or highlight something that isn’t conveyed in the text
Imagery that provides tone or meaning that is not otherwise conveyed in the text
Logos of institutions, departments, and sponsors

Photographs of people that do not have a text caption or label

Examples of non-critical information/imagery:

Most stock photos

Horizontal separators (unless they convey differences between two or more
things)

Clip art

Background colors

Purely aesthetic icons

G. Use Table of Contents (TOC) feature (if applicable)

The TOC feature in InDesign uses the paragraph styles you created earlier to create the
table of contents. Make sure to use paragraph styles to mark headings before using this
feature.
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H. Check the color contrast of the document

Use the Colour Contrast Analyser to check if the contrast between text and the
background of text (including text in images) passes at a minimal level.

Interpreting the results of the Colour Contrast Analyser

Colour Contrast Analyser (CCA — *
Colour Contrast Analyser (CCA)  Edit  View

Foreground colour

Background colour (white)

H#FFFFFF

¥ Sample preview

example text showing contrast ]]ﬂ\h}

WCAG 2.1 results Contrast ratio
4.1:1

P 1.4.3 Contrast (Minimum) (AA) 3

4 Q Fail (regular text) @ Pass (large text)

> 1.4.6 Contrast (Enhanced) (AAA)

€ rail (reqular text) €3 Fail (large text)

» 1.4.11 Non-text Contrast (AA)

@ Pass (Ul components and graphical objects)

Use the eyedropper for fast results, or input the HEX code from InDesign
Foreground means the text color

Your text content should at least comply with 1.4.3 (Minimum) (AA)
Regular text: <18pt or <14pt bold

Large text : 218pt or 214pt bold

o kw0~
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Checkpoint — “Step 2: While composing the document”

Before you move on, make sure you have:
0 Used a separate layer for background content

o Marked all headings with the correct paragraph style

0 Used in-built lists (humbers and bullets)
o Used in-built tables

o Anchored images into the text flow
o Added alt-text to all essential images

o Used Table of Contents (TOC) feature (if applicable

o Checked the document color contrast
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Step 3: Exporting to PDF within InDesign

A. Ensure Layers items are in the correct reading order

The reading order of a PDF is based on the layers within InDesign. This controls
highlight order for the cursor within the PDF and the order assistive technologies like
Text-to-Speech will read the PDF.

Ordering layers

In the Layers panel, content is the reverse of the expected reading order. In other
words, what should be read first is the last layer item and the last item you would read is
the first layer item. To arrange the elements in the proper reading order, select an
element in the Layers panel and drag it to another spot.

4 Layers
o I ~ Background & Decorative
o | <History of the Graduate Schodl ...»
0 Il
£
o I
© History of the Graduate School o |
o I
o I » <group=
— o ~ Text & Important Images
o <Washington Square by Fernand Har...>
eTﬂe Graduate School of Arts and Science wrban ervironment as both source an. d students anrolled inour ds o 5 .
was fourded in 1286 by Henry Mitchell inspiraticn for academnic life. He bali and programs, as well as in =weddingwashsquare jpg>

Ma=Cracken, a prafessar of philasaphy that the Liivers erests lay number of institutss and i

5
4
o 3 -The Graduste School of Arts and ...>
2
1

and lagic, and vice-chancelior at New in its interactions with the city, By the
“ferk Univarsity. ats Scheol had o <History of the Graduate School=
MacCracksn belimved that universities N B N o
majer glabal issuss, and the curricul lum
should respend to the nesds reflected movernent toward progressive
nity by giving unprecedented priority ales.
to advanced ressarch and professional
training New York University was the MacCracken's new vision of graduste 100 countries. The Graduate School
second university in America to award training attracted ever-growing numbers  still honors the ideal expressed by
a Ph.D. on the basis of of young women and men to doctoral Akert Gallatin, the University's first
performance and s programs. The first female graduate president, who articulated

students anterad the University in 1885, tizn's primary goat "4 private universi
Teday, wornen constitutes over half of the in the public service.” |
awer 5,000 master's and Ph.D. gracuats

In addition to the empha: ecellence
in ressarch, MacCracken recognized the

Photograph courtesy
af Hirschl & Adler
Gallerics, Inc.

History of the Gradoate School [/ NYU Graduaee School of Ares and Sclence [/ 2021-23

(full resolution image of layer figure)
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B. Add content to Articles

Setting the reading order in the layers only the first part. You also need to identify the
content that is available in the PDF tags. This is what assistive technologies on Screen
Readers will be using to read the document.

1.
2.

Open the Articles panel: Window > Articles

Critical: Select the pane fly-out menu (g) > Use for Reading Order in Tagged
PDF should be checked. If you don’t do this, then nothing will carry over.

Create an article for each page: pane fly-out menu (=) > New Article.

Note, what you name the article will not affect accessibility; it’s just for your
reference.

Drag content from the document into the Articles pane under each page article in
the order it should read. Unlike the layers, the order in the Articles pane is top to
bottom. This includes headings, text, lists, tables, images, and other content that
needs to be read. Images: you only need to drag in the essential images you
described.

B} A A

@ History of the Graduate School

T <

(', L
was founded in 186 by Henry Mitchell

o I ——
-

History of the Graduae School / NYU Graduare School of Ares and Science / 2021-23

(full resolution image of article order)
Most items you drag in will have a “T” label, even if a heading style, list, or table.
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Using layers to create Articles:

If you have set the correct reading order of your layers, then you can use the layer
selector to efficiently drag content into the correct article order. Note that you should not
use this technique if your layer contains background content.

a. Select the layer group selector > Right click (options) menu > "Select Item(s) on..."

% Layers % Articles

o ~ Background & Decorative Mo content. Drag skories and objects here o ﬂlﬁ ]

o <Histor,..Graduate Schoal .= -:reat_el_a.ne.ﬂ-' Arficle and adl:! u:-:n_l:enl: '33 O '
Cirl-click the Add button to add all document

o <lines content at once to a new or selected Article. m

o =linex

< =line=

O =linex

O } =group>

e  Text & Important Images &

Mew Layer...
o <Washin... by Fernand Har...>

Duplicate Layer "Text & Important lmages”
o =weddingwashsquarajpg=

Delete Layer "Text & Important Images”
s O =The Gr...hool of Arts and ...>
o =Histor...he Graduate Schoal= Layer Opticns for "Text & Important lmages”..,

- Select ltem(s) on "Text & Important Images”

b. The content is now selected in the editor. Click the + Add button in the Articles pane.
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e When you export to PDF (File > Export), you can choose either Adobe PDF
(Print) or Adobe PDF (Interactive).

e \When using "Print" mode: In the Export Adobe PDF modal dialog > General tab,
ensure that “Create Tagged PDF”, “Bookmarks”, and “Hyperlinks” checkboxes

are selected.

Export Adobe PDF

Adobe PDF Preset:

Standard:

General
‘Compression
Marks and Bleeds
Output

Advanced
Security

Summary

[High Quality Print] (modified)

None

Compatibility: ' Acrobat 5 (PDF 1.4)

General

Description: [Based on '[High Quality Print]"] Use these settings to create Adobe PDF

documents for guality printing on desktop printers and proofers.

Created PDF documents can be opened with Acrobat and Adobe

Reader 5.0 and later.

Pages
O Al O Range: 1 View: Default
Export As © Pages () Spreads Layout: Default

[ Create Separate PDF Files ] Open in Full Screen Mode

[] Vview PDF after Exporting

Options

[l Embed Page Thurr Create Tagged PDF
Optimize for Fast Web View

Export Layers:  Visible & Printable Layars

Include

Bookmarks ] Mon-Printing Objects

Hyperlinks [J visible Guides and Baseline Grids

Interactive Elements: Do Not Include

..;:

Cancel
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e In the Export Adobe PDF modal dialog > Advanced tab, ensure that Display
Title is set to “Document Title” and Language is set to the appropriate language.

Export Adobe PDF

Adobe PDF Preset: | [High Quality Print] {modified)
Standard: None Compatibility: ' Acrobat 5 (PDF 1.4)

General Advanced
Compression
Fonts
Marks and Bleeds . . . R E
=== Subset fonts when percent of characters used is less than:  100%
Output —
l:i} All fonts with appropriate embedding bits will be embedded.
Advanced =
Security 0PI

SITIET) Omit for OPT: [J EPS ] PDF [ Bitmap Images

[Medium Resolution]

Accessibility Options
Display Title:  Document Title
Language: | English: USA

Description
Hover over an option to view description.

«=D

Note:
You can make these settings default by using the PDF preset within InDesign.

Checkpoint — “Step 3: Exporting to PDF within InDesign”

Before you move on, make sure:
o Ensure Layers items are in the correct reading order
o "Use for Reading Order in Tagged PDF" is checked

o All essential content is in the Articles pane and in order

o The correct settings are in place when exporting to PDF
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Step 4: Within Acrobat Pro

A. Tables
Ensure that you have marked the column headers within InDesign.

Row headers

For complex tables, it is necessary to mark the header cell for each row.
How to mark header rows in Acrobat Pro
e “Touchup Tool” is also known as the “Reading Order Tool”:
Tools > Accessibility, and then choose Reading Order in the right pane
e How to find the Document Tags

Spanned cells

How to make spanned cells accessible in Acrobat Pro.

B. Run the Accessibility Checker

Your last accessibility check will occur in the Adobe Acrobat Pro Accessibility Checker.
If you followed the steps listed above, then there should be no outstanding accessibility
issues. If there are no outstanding issues, then the document is ready to post on a
public resource. Note that the document is not PDF-UA compliant using the Acrobat Pro
Accessibility Checker.

Note:

Logical Reading Order and Color contrast will be flagged by the Adobe Acrobat
Accessibility Checker each time the checker is run.

Checkpoint — “Step 4: Within Acrobat Pro”

Before you share the PDF, make sure to:
o Add row headers to tables

o Ensure spanned cells are made accessible
o Verify accessibility in the Acrobat Pro Accessibility Checker
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