Summary

Installation

Modifier Workflow overview

UI overview

Some Tips

TroubleShooting

Commands

Final Words and Spicy Links

(CTRL(+) / (-) to Zoom)


Installation

Close Maya and Extract the RAR Archive in : \Users\User_Name\Documents\maya\Maya_Version\scripts\

Go to Window>Setting/Preferences>Hotkey editor

Set a Hotkey (in order)

Enter the field and type -in : source “ndmods.mel”;

save and Set the KeyBoard Shortcut and you’re done!

Modifier Workflow overview

a Modifier can be described as a network of nodes that is set in such a way Data can travel back and forth. Thus a modifier provide non-destructive features.

Properties of the Control Mesh

With NDM Phoenix each Modifier are Linked to a mesh I like to call the Control Mesh, as its name suggest it allows to Control the Mesh underneath it which is the mesh being affected by the Modifier. The only Modifier that seem to be an exception is the Lattice Modifier.

With any modifier applied you can apply any modeling commands to the Control Mesh, You can even delete control mesh History if you want more performances. The location of the Control Mesh doesn’t matter , it can be moved or scale , rotate...etc.

NDM Phoenix Core Concepts

Because of the way NDM Phoenix Modifiers work there had to be Creators and Destructors, that respectively Create geometry and destroy it. once a modifier is applied it needs to be destroyed in order to get It’s output. And so in reality each modifier has Its own destructor with exclusive features in It. A cool trick is to select all the vertices or faces or edges and Hit the destructor Button to see the Selection on the output. What about Savior ? Savior button will save the Control Mesh if your Undos are too far already.

Note: NDMP is not to use along with CREASE+, unless you Use Savior then apply other tool’s commands and rethrow the modifier on the mesh.

Modifiers

Bevel Modifier

 (Hit Two times)The bevel modifier is similar to how Quad-Chamfer Modifier works in 3ds Max. The Rule is that all Hard edges are beveled. Unlike RT modifiers Bevel Modifier needs an update each time new polygon are created. This mechanism allow for better performances (most importantly if you model fast like me.). One way to Update The result is to select any component, or the Mesh itself and HIt the bevel button. For the same sake of performances default setting for divisions is 1, having more divisions during modeling time can drastically affect performances, and thus it’s recommended to keep it at 1’ and Increase it in the final stage. Take a look at the Options that from the UI to see all the settings.

FWVN Modifier

(Hit two times)FWVN Modifier works like the Bevel modifier, except Its goal is to impact the Normal towards the Face Weighted Vertex Normal Worklflow. Its purpose is complete only and only if the input mesh is not Beveled(The modifier is based on Hard edges). It is the most accurate Method for Face Weighted Vertex Normals on the condition that your mesh is not yet beveled otherwise you Must use the Algorithm Options .It possess the same update mechanism than Bevel Modifier. Get in Options tab to see all Its settings. More about FWVN : http://wiki.polycount.com/wiki/Face_weighted_normals

RT-Shell Modifier

One of My favorite. It allows you to create interactive thickness from your Open Mesh. If you want it to add thickness in the opposite direction just reverse the normals of your Mesh.Get in Options tab to see all Its settings.

RT-Mirror

Mirrors your mesh across the Wanted Axis, While you can edit the Model in real-time.

RT-Tris

Real-time Triangulation display (wireframe) while you model. Use Savior to save the original mesh or Destructor to get the Output.

Cable

Cable is not a modifier. Generate cables out of curves based on a different algorithm rather than the extrude circle “thing”. The cables are bound to a curve that can be modified until History is deleted. Doesn’t support edge selection. Does support to at a certain extent periodic/closed curves (without closing them in the process). If no curves are selected you will enter Bezier Curve Tool. Note : that this one was an Idea of Romain Chauliac that wanted something closer than 3ds Max workflow, let’s thank him now. See Cable Settings in Option Tab. Beware : the better the curve quality, the better will be the Clip settings, It’s not best to assume the otherwise, this workflow is centered around Bezier curves notably.

A-Diamond

Will create interactive array of diamonds based on Control Mesh vertices. See Its settings in Options Tab. To get selection of interest select all the vertices before hitting destructor in the Final stage, you can then convert it to face...

A-Square

Will create interactive array of squares based on Control Mesh faces. See Its settings in Options Tab. To get selection of interest select all the faces before hitting destructor in the Final stage.

A-Poke

Will create pokes array out of the Control Mesh faces. See Its settings in Options Tab.

Smooth

Smooth is not a modifier. It allows to toggle smooth mesh preview on the mesh being affected. You can Hit pageUp/pageDown to increase/decrease the Level of subdivisions on the mesh.

RT-Lattice

Creates a lattice around the Control Mesh. If you select the lattice itself and Hit the lattice button it will reset the lattice points. beware that you can only modify lattice Divisions on the condition that you didn’t tweak them locally. You can move and scale the lattice around to see it taking effect on the Influence the Control Mesh is bound to. Hit the Destructor button to get rid of the lattice and the Control Mesh.

UI overview

In the Main Tab you will find all things Modifier related.

You can customize the color of the Windows by Going in >Custom>Color.

In the Options Tab lies the settings (channel Box) and Helpers for displays, and selection. You can make the current settings default for a Modifier by Hitting Make Default Button.

You can access the modifiers from Commands’ menu in Options Tab.

Some Tips

TroubleShooting

Already read this and want help? Get it here : http://polycount.com/discussion/183042/maya-ndm-phoenix-non-destructive-modifiers-and-tools-for-maya#latest

Rules :

_____

This might be due to your quotation marks being incorrect.Make sure you have written the correct one and try again.Here is the correct line,just copy-paste it to your hotkey/shelf/marking menu button :

source "ndmods.mel";

Hold [CTRL](Control Modifier) when dragging with MMB (Middle Mouse Button). Even though you can let it go if you change the settings right from the Options Tab.

Commands

You must call and close the Window before using these commands or legit Runtime Commands bound to a Hotkey. To get More Info on what these commands do, get to the Modifiers Description far above.

nDdestroyer()

Calls Modifier Destructor

nDsavior()

Calls Savior

nDsmt()

Calls Smooth toggle

nDbvlExe()

Calls Bevel Modifier

nDfwnExe()

Calls FWVN Modifier

nDshlCreator()

Calls Shell Modifier

nDmirCreator()

Calls Mirror Modifier

nDtriCreator()

Calls Tris Modifier

nDcab()

Call Cable command

nDdmdCreator()

Calls Diamond Modifier

nDsqrCreator()

Calls square Modifier

nDpokCreator()

Calls Poke Modifier

nDlatCreator()

Calls Lattice Modifier

nDfwvnP()

Calls Face Weighted Normal Perimeter Calculation Algorithm

nDmakeDef()

Make current Modifier Settings Default.

nDselectSimilar()

Call NDM select similar

nDheDisplay()

Toggle Hard edge real-time Display

nDnDisplay()

Toggle Vertex Normal Display

nDheSel()

Select Hard edges of Selected Objects

Final Words and Spicy Links

You can tell me what you want , tool wise, feature wise and All via this delicious form I made for you (you can Even report bugs) : https://goo.gl/forms/h9YBWYwxY1hrQijt1

Polycount Thread (It gets spicy here sometimes): http://polycount.com/discussion/183042/maya-ndm-phoenix-non-destructive-modifiers-and-tools-for-maya#latest

Youtube Channel: https://www.youtube.com/channel/UCTqvs11P9AewdP_E315JzdA

Thank you so much for your support this product knows success because of you guys!

//AUTHOR : BAIDHIR HIDAIR © 2017.