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1​ Preface 

This brief starter was developed mainly for the participants of the Capacity Building 

Workshop for Modeling Energy and Land Use Change in Haiti, held in Santo Domingo 

between March 21 and 24. 

 

The main goal of this document is to guide participants to completely run the model 

for any test area within the country of Haiti. All scripts (extensions .egoml and .R) can 

be opened, edited and saved using Dinamica EGO and R respectively, or any other code 

editor such as Notepad++ or Sublime. 

 

As mentioned during the presentation, MoFuSS is now intended to be fully web-based, 

using Haiti as our first study.  
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2​ Computer specifications 

Dinamica EGO is only available for Windows operating system (OS). The model has 

been tested successfully in various configurations of Windows 7, 8 and 10 versions, and 

in Intel-based Macs using Boot Camp. No sound tests have been conducted so far in 

Linux using Wine. 

 

Some geoprocessing operations in MoFuSS use parallel computing, detecting how 

many cores are available, and using all of them at maximum capacity. Eventually, you 

might experience that your computer becomes very slow if you try, for example, to 

open some other program or perform any other task requiring of CPU’s processing 

power. This is however barely noticeable for small areas of analysis. Please note that if 

you cancel any geoprocessing operation using multiple cores, be sure that all 

Rscript.exe instances are stopped before proceeding with any other tasks: Press 

Ctrl+Alt+Del to check all processes running in your computer and wait until all 

Rscript.exe instances are turned off. 

3​ Download MoFuSS files 

Copy the following folders from the UBS that was provided into any location of your 

hard drive. It is recommended to keep paths as short as possible and with no spaces, 

accents or characters. 

MoFuSS_Haiti_StoDomingo2023 (located here in the USB drive: …\MoFuSS 2023 CCA 

Haiti\data\mofuss_haiti\) 

mofuss_gitlab (located here in the USB drive: …\MoFuSS 2023 CCA Haiti\software\) 

 

Unzip the file DinamicaEGO241.zip (located in 

…\mofuss_gitlab\linwin\interpretersWindows\) 

 

Inside the unzipped folder you’ll find two executables from a freeware called Dinamica 

EGO. First install “SetupDinamicaEGO-241.exe” and then 

“SetupDinamicaEGO-241-MinGW.exe”, in that order. When asked, accept all default 

setting during installation. MoFuSS uses an old but super stable version of Dinamica 

EGO (version 2.4.1). The latest version of Dinamica EGO will produce some errors and 

warnings that are not easy to jump unless you are familiarized with this software. If you 
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have any previous versions of Dinamica EGO installed, you can leave them as there is 

no conflict. 

4​ Install all other required freeware 

Install R and RStudio for Windows. If you are not familiar with this software, follow the 

links “Download R for Windows” and then “install R for the first time”. During 

installation you can keep all default options (e.g. install both 64-bit and 32-bit files if 

you don’t know your OS type). MoFuSS can read your machine configuration and pick 

the correct version. 

 

Once R and R Studio are installed, we need to install al required libraries. Open RStudio 

and you should see a similar layout (with a white background perhaps): 

 

 

You can change the layout to “dark” in Tools -> Global Options -> Appearance -> Editor 

Theme -> (select Tomorrow Night 80 if you want to be exactly as Adrian’s)  

 

Go to File -> Open File and load …\MoFuSS 2023 CCA 

Haiti\software\mofuss_gitlab\linwin\scripts\00_load_pkgs_wrstudio.R 
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Wait a few seconds and then click the “Install” tab as shown in the figure below. Please 

be careful not to click in the Don’t Show Again tab as it will make installation more 

complicated: 

 

 

 

Installation of R packages can take a while. Be patient and the instructor will debug any 

issues at this point. 

IMPORTANT: Please try not to touch anything in your laptop until the red circle 

disappears: 
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Finally, click on the “source” button to double check all packages were successfully 

installed: 

 

 

 
Install Google Earth, it’s the easiest and more practical way to select your area of 
interest. If you already have it, then skip this step. 
 

For MoFuSS to produce a summary report in .pdf, a LaTeX to PDF compiler is needed. 

Download and install the Basic MiKTeX for 32-bit or 64-bit depending on your system 

(install both if not sure). Note that not all compilers work properly for R running in 

Windows, so, even if you already have another version of TeX/LaTeX on your computer 

you still might need to install MiKTeX. But it is suggested that you wait for error and 

warning messages during pdf compilation before moving forward with any new 

installation. 

 

You need any GIS software to explore the spatial data that is being generated by 

MoFuSS. The best option is QGIS, as its free, powerful, and scalable. 

 

You need a pdf reader to open the summary report and see some warnings and other 

messages triggered by Mofuss. You can test whether your current PDF reader is 

compatible with multimedia files (e.g. Acrobat Reader  >9.x), as two animations are 

inserted in the pdf summary report. If you already have this software, then skip this 

step. Note – if you do not have a pdf reader installed, MoFuSS will stop running 

because it is unable to deliver messages and instructions at the beginning of the 

process. 

 

Finally, MoFuSS will produce animations in .avi, .mp4 and .wmv format. You can install 

VideoLAN (VLC) to open these files or use any other compatible software already 

installed in your computer. 
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Windows, or your antivirus, or your firewall may ask for different kind of permissions. If 

this happens, please allow executables to communicate through networks and for the 

system to open/read/save files:  

 

 

5​ Selecting an Area of Interest (AOI) in Haiti 

Open Google Earth and zoom-in over Haiti. Draw a small1 polygon by clicking the 

polygon icon in the top menu bar, name it, and save it into Google Earth by clicking 

“OK”. If you are not experienced drawing polygons in Google Earth, use as few vertices 

as possible to avoid errors: i.e. one click per vertex (each vertex is shown as a small red 

square): 

1 It is important that you first select a small area (similar to Figure A2 or smaller) to save time and check 
that everything is working. You can try with large areas later and let the model run overnight. 
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To save the polygon into MoFuSS right click over the newly created polygon (likely 

under My Places or Temporary Places at the left side of your screen) and save it (Save 

Place As…) as a KML file (not KMZ) into 

C:\Users\aghil\Documents\MoFuSS_Haiti_StoDomingo2023\LULCC\DownloadedDatas
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ets\SourceDataHaiti\InVector_GCS\your_polygon.kml (Figure A3)2. You can save more 

than one Google Earth polygon in this folder but later you will be asked to choose only 

one through a file dialog box: 

 

 

 

You can now close Google Earth, discarding any changes. 

 

2 If a new area is to be selected after running MoFuSS for the first time, you must save the new .kml 
file directly in …\MoFuSS_v6\LULCC\SourceData\InVector_GCS\your_polygon.kml, and start from 
script #2. 
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6​ Run MoFuSS by means of a user-friendly interface - Part I 

As already mentioned, this is the last MoFuSS course to be run locally, we expect next 

courses be fully web-based. As we are in the middle of this migration (because this 

course was delayed by a few years due to Covid19) we will need to run some R scripts 

with no user-friendly interface. The following instructions are intended to be as 

detailed as possible. 

 

6.1​ Hands-on Exercise #1: Using MoFuSS for one small Area of Interest (AOI) 

Open (or go to) RStudio. and open the following four scripts: 

 

…\mofuss_gitlab\linwin\scripts\1_choose_country_win.R 

…\mofuss_gitlab\linwin\scripts\2_harmonizer_win.R 

…\mofuss_gitlab\linwin\scripts\3_scenarios_win.R 

 

 

 

 

With the first script highlighted as in the previous figure, click the button “source” to 

run it.  
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This first scripts needs to know where your data is. You’ll be asked three questions: 

1)​ Where is your mofuss_gitlab folder? 

 

 

2)​ Choose a country 

 

 

3)​ Select your MoFuSS_Haiti_StoDomingo2023 folder 
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Please wait until the scripts runs, it can take up to 5 minutes. After this, we will debug 

the results in each laptop.   

 

Note: Just click “Cancel” if a similar dialog boxes appear, it is just looking for files in 

your laptop 

 

 

 

We know the script has stopped running when the red circle disappears 

 

 

Once everything worked ok, we’ll repeat the same operations for script 2 

(…\mofuss_gitlab\linwin\scripts\2_harmonizer_win.R) . First you need to highlight it 
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The following questions need to be answered this time: 

1)​ Resolution 
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2)​ Area of interest format: Google Earth vs shapefiles. Please change the default 

from “v” to “g” si we can work with Google Earth 
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3)​ Area of Interest: please select AGB_debugging.kml 
 

 
 
 
Finally we need to run …\mofuss_gitlab\linwin\scripts\3_scenarios_win.R 

 
1)​ Type of Scenario 
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2)​ Produces the pressure maps using your own laptop (YES) vs a super computing 
cluster (No). Leave yes as you don’t have access to the cluster yet. But we’ll d a 
demonstration the second day using webmofuss. 

 
 
 
3)​ Friction maps running in Dinamica or R, you can choose whatever for locally 

running MoFuSS 
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At this step we need to open Dinamica EGO Wizard Presenter.3  

 

 

 

Use this software to open and run subsequently the following scripts carefully 

following ALL instructions from the Wizard (user-friendly interface).  When in doubt 

about any parameter just leave the default value.  

 

…\mofuss_gitlab\linwin\scripts\4_FW_dyn_lulcc_Sc9.egoml 

 

Like the first script, some TeX/LaTeX packages will be installed during the first time you 

run this script (Figure A9). Always click “Install”. You can click out the option “Always 

show this dialog before installing packages” to avoid receiving anymore warnings until 

all TeX/LaTeX packages are installed. Eventually you might receive a warning about 

Dinamica EGO having trouble to compile this particular script. It’s a bug in the log 

console and does not affect performance. 

 

3 Dinamica has other executables that won’t work here (e.g. Dinamica Console Launcher, Dinamica Ego, 
Dinamica Map Viewer). 
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Note: Allow TeX/LaTeX packages to be installed. Click out the option “Always show this 

dialog before installing packages” if do not want to be asked each time a package need 

to be installed. 

 

 

 

7​ Explore outputs 

Summary outputs, including a .pdf summary report4 are saved into the following 

folders:  

Summary outputs, including a .pdf summary report  are saved into the following 

folders:  

…/Summary_Report/  

…/OutBaU/  

…/HTML_animation_OutBaU/  

 

 You can also check all other meaningful results in …/Temp, much better if you use 

QGIS or any other GIS software  

 

8​ Selecting a new analysis area and re-running MoFuSS 

4 The .pdf file should open automatically once the model finishes completely. 
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If a new area is to be selected after running MoFuSS for the first time, then you must 

select a NEW test area in Haiti as done previously but, in this case, the. KML file should 

be saved directly in …\LULCC\SourceData\InVector_GCS\your_polygon.kml, and start 

again from script #2: …\mofuss_gitlab\linwin\scripts\2_harmonizer_win.R 

 

9​ Erasing all temporal data and results 

The script …\mofuss_gitlab\linwin\scripts\0_erase_all_win.R  serves to wipe out all 

temporal data and results. After running this script, only input data, scripts and the 

folder structure will be maintained. 

 

10​ Run MoFuSS by means of a user-friendly interface - Part II 

10.1​ Hands-on Exercise #2: Using MoFuSS for different small Area of Interest (AOI) 
within Haiti, modifying input parameters in a BaU scenario 

At this stage, instructions are rather general as you already know how to tweak 
parameters and rerun from this:  
…\mofuss_gitlab\linwin\scripts\2_harmonizer_win.R 

to 
…\mofuss_gitlab\linwin\scripts\4_FW_dyn_lulcc_Sc9.egoml 
 
 
Let’s now “play” with different AoI and check results among all of us. Remember to 
keep it small.  
 
 
Second, lets “play” with supply parameters. 
 
 
Third, lets “play” with demand parameters. 
 
 

10.2​ Hands-on Exercise #3: Using MoFuSS for any small Area of Interest (AOI) within 
Haiti, to compare the BaU to an intervention scenario 

Choose FT instead of BaU and let it run for 30 years: 2010->2040. 
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