
[Guide] How to make animated gifs from any video file with Photoshop CS5 & VirtualDub

This guide might seem long, but I tend to over explain stuff just to make it clear as possible. The whole process
shouldn't really take more than 10 minutes or so depending on what you want to do.

This tutorial is intended for Photoshop CS5, however it’s also possible with Photoshop CS4 and CS3. Photoshop
CS6 is out now, no real changes have been made to the program so it should be all the same.

Things you’ll need:
● Photoshop CS5. I've linked the free 30 day trial, you'll need an Adobe account to download, but you can use

one of the logins from here.
● VirtualDub. Free, current latest is 1.9.11.
● Directshow Input Driver. Current latest is 0.93, the zip contains both 32bit and 64bit versions.

I've put together VirtualDub 1.9.11 and the DirectShow driver 0.93 into a single zip here (32bit) for convenience. You
can ignore the step below, unless newer versions come out.

Once you’ve installed VirtualDub, go to the folder where it’s located, i.e. C:\Program Files\VirtualDub and put the
DirectShow driver (DShowInputDriver.vdplugin) into the plugins32 folder - not "plugins". If that folder doesn’t exist,
create it.

Small Note: It is possible to create gifs solely with VirtualDub alone, however I don't use that method since you
cannot control the quality of the gif or do more advanced stuff like changing the delay of particular frames and add
borders. However if you wish to know how, please read the last section of this guide.

Some info on the DirectShow Input Driver:
The DirectShow driver is necessary as it'll allow you to open any video in VirtualDub such as mkv, mp4, rmvb, wmv
and flv.

For the DirectShow driver in VirtualDub to work, you need to have the correct codecs installed beforehand, the
easiest way to check is to try and play the video file in MPC or Windows Media Player or any other DirectShow
aware media player. VLC and other self contained media players don't install codecs outside of their own folders, so
they don't count.

If it doesn't play, I suggest installing CCCP which covers the most popular and common codecs. Other codecs worth
mentioning are QuickTime Lite (QuickTime Alternative) and Real Alternative, but generally you won't need these two.

Basic summary:
You use VirtualDub to take a video file and extract the frames as individual images. You then use Photoshop to take
the images you exported and create your gif. So in essence:

Open video in VirtualDub, select the part you want, export as Image Sequence. Open images in Photoshop and save
as a gif.

Note: Please click on the images to see their full size versions.

Tutorial - Using VirtualDub:
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1. Open VirtualDub and go to File > Open video file... you'll get a window that looks something like this:

2. Firstly, make sure you change the Files of type option to DirectShow input driver. Pick a video file you want to
use and click Open.

3. Use the seek slider (D) to roughly jump to the section of video you want, use your keyboard cursor/arrow keys for

http://img826.imageshack.us/img826/5758/opendirect.png
http://img718.imageshack.us/img718/7324/vdubcontrols.jpg


more precision.

4. Once you're at the start of the section you want, click the Set selection start button (A). Find the point where you
want it to end and click the Set selection end button (B).

You'll see the portion of video you've selected in the seek bar (C).

Note: You could just save what you have to images right now, however there'll be a lot of duplicate frames and the
gif tends to animate quite slowly. Ideally, what you want to do is have as few frames as possible to make the gif small
(downloads quicker for people to see), but at the same time not too few so as you'll destroy the smoothness of the
animation.

5. Go to Video > Frame Rate.... Click on the Convert to fps option and enter your desired speed. I find anywhere
from 10 to 15 to be a pretty good balance between size and animation smoothness. Play around with the fps and
see what looks best to you. Generally, I tend to use 10 fps.

The Process every other frame (decimate by 2) or decimate by 3 options also work OK sometimes.

6. Go to File > Export > Image sequence... pick an empty folder to save all the frames to and I tend to change
Output format toWindows BMP so as I can easily preview them from Windows. Lastly press OK to begin
exporting, which should take a few seconds.

http://img543.imageshack.us/img543/9200/vdubfps.png


Tutorial - Using Photoshop CS5:

7. In Photoshop CS5, go to File > Scripts > Load Files into Stack... a window should popup like the one below:

8. Change the Use option to Folder, click the Browse button and find the folder where you exported the image
sequence to in Step 6. Click OK when done and Photoshop will take a moment to load all the images.

9. Go toWindow > Animation to bring up the animation panel.

http://img834.imageshack.us/img834/5640/vdubexport.png
http://img715.imageshack.us/img715/5115/psstack.png


10. In the top right of the animation panel, click the panel menu button (A) and select Make Frames From Layers
(B).

11. I don't know why, but the animation is always imported backwards so to correct this, repeat Step 10, but this time
select Reverse Frames (C).

12. You'll want to make the image smaller, otherwise the file size is going to be huge. Go to Image > Image Size...
and change the width & height there to whatever you want.

Tip: At the bottom of the Image Size window is an option on how you want to resample the image. It's already
labelled, but use Bicubic Sharper for reductions and Bicubic Smoother for enlargements.

*You can ignore this section if you wish and go straight to Step 13.

http://img804.imageshack.us/img804/9049/pslayers.jpg


There are a few options in the Animation panel that you might want to familiarise yourself with:

● D. How you want the gif to loop, either forever or a set number of times.
● E. The frame delay, this changes how quick it jumps from one frame to the next thereby making the animation

faster or slower. You generally won't need to touch this setting if you've exported it right from VirtualDub.
● F. Playback controls, pretty self explanatory, use these to preview the gif.
● G. Trash can button to delete any unwanted frames.

13. Go to File > Save for Web & Devices... and you'll see the window below:

14. You can now just pick a Preset (H) i.e. GIF 128 Dithered, hit Save and be done. See the Advanced file saving

http://img228.imageshack.us/img228/9826/psanim.jpg
http://img706.imageshack.us/img706/8805/pssavebasic.jpg


section for more details.

Photoshop CS5 - Advanced section - This section can be skipped:

Advanced file saving:

I like to try and get the best balance between file size and quality, for that, you'll need to play with the options.

Firstly, change the view to 2-Up by clicking on the tab at the top, this way you can compare your original image and
compressed image in one screen.

There's quite a lot of options here, but you won't need to touch most of them and you don't really need to know what
everything does, just play around with the settings until it looks decent and is reasonably small.

http://img863.imageshack.us/img863/7316/pssave.jpg


● I. Change your file format to GIF if it isn't already.
● J. Here you choose how colours are handled. Generally Selective or Adaptive seem to give the smallest file

sizes.
● K. Here you choose how many colours the gif will use. More colours means bigger file size, but use too few

and you'll start to lose detail. Generally 128 colours is a good balance, but you can drop that down further if it
still looks good.

● L. Select the type of dithering here. You may want to use dithering when you've got gradients in your gif, it'll
blend the colours better rather than leaving large blotches, however it will also add a grain to the image and
increase the file size. Diffusion is probably the best type, but it depends on the scene.

● M. Here you choose how much dithering to use. I tend to just leave this on 100%, but again, play around with
it and see what looks good.

You'll want to leave Transparency ticked as it tends to make the file size a fair bit smaller. All the other options you
can ignore.

● N. Keep an eye on this section when changing any of the options, it'll give you an estimate of what the file
size will be.

● O. Playback controls you can use to preview the gif. Do note that the playback speed can be incorrect in this
section. It’s better to preview the gif in a browser.

Adding a basic border:

This section I'll explain how to add a very basic outline around your image.

1. In the Animation panel, make sure you select the 1st frame. In the Layers panel, select the top layer.
2. Make a new layer by clicking on the New Layer icon in the Layer panel or go to Layer > New > Layer...
(Shift + Ctrl + N). This layer should be at the top of all other layers, if it's not, drag it up until it is.
3. Go to Select > All (Ctrl + A) and then Edit > Stroke, you'll get the window below:

http://img864.imageshack.us/img864/5107/stroke.png


4.What I've seen people do is use a double border, a white outline, then a black outline. To do this, set theWidth to
2px, change the colour to white, select Inside and press OK.

5.Without deselecting anything, go back to the Stroke options (Edit > Stroke). This time change theWidth to 1px
and the colour to black, leave the other options as they are and press OK.

You can of course change the border colours to whatever you want.

You should get something like this:

Changing/fixing brightness & contrast:

Sometimes the video you have might lack contrast or could do with some brightness fixing. The easiest way to
change this is to use an Adjustment Layer.

1. In the Animation panel, make sure you select the 1st frame. In the Layers panel, select the top layer.
2. Go to Layer > New Adjustment Layer and pick one of the options, I like to use Levels. A little window will popup,
just name it whatever or leave it as it is and press OK. This layer should be at the top of all other layers, if it's not,
drag it up until it is.

http://i.min.us/im5gJs.gif
http://img855.imageshack.us/img855/8819/levelse.png


3. The Adjustments panel should popup (image above).
● A. Here you can just pick a preset if you're lazy.
● B. This slider controls the dark shades and shadows, sliding it to the right will make things darker.
● C. This slider controls the midtones, use this to fine tune the contrast.
● D. This slider controls the light shades highlights, sliding it to the left will make things lighter.

Generally, you'll want the the shadow (B) and highlight (D) sliders to be touching the edges of the histogram (the
black mountain type graph). Then use the midtones slider (C) to tweak it further, this will usually give you a nicely
balanced image.

There are a whole load of other type of adjustment layers, so feel free to play around with them. It's best to use these
since they're non destructive and also they affect all layers below them. All other filters (in the Filters menu) like
sharpen or blur etc, will have to be applied to each layer individually making it a bit of a chore.

Making gifs with just VirtualDub:

Follow the first 5 steps of this guide and then continue with the rest from here.

6a. You will almost certainly want to resize your gif. To do this, go to Video > Filters... (CTRL + F) and you'll see
something similar to the image below.

7a. Click on the Add button in the Filters window, scroll down to the resize filter, select it and press OK.

http://imageshack.us/m/405/6233/addresizeb.png


8a. The Resize filter options should come up (as seen above), there are a lot of options here, but you won't need to
touch the majority of them. Here you can resize via 2 different ways, Absolute or Relative. Most of the time you will
want to resize with fixed dimensions so click on Absolute (pixels) and enter the width or height you want.

You can click on the Show preview button to see what kind of size you're going to get. This is more useful when
you're resizing by eye and you don't have any specific dimensions or when you're resizing relatively (using
percentages).

Once you're done, click OK and you can export (Step 12a).

*Steps 9a to 11a cover cropping and can be skipped depending if you need it.

9a. This isn't always necessary, but you can also crop within VirtualDub too. Note, it's possible to stack filters, i.e.
resize and crop at the same time. Go to Video > Filters... again, but this time add the null transform filter.

10a. Nothing will happen when you add the null transform filter, you need to click the Cropping... button to bring up
the options.

http://imageshack.us/m/855/5567/resizeoptions.png
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11a. Click on the little up and down arrows beside each offset to change the viewable area (how it'll be cropped).
Once you're happy, click OK.

12a. Go to File > Export > Animated GIF... and a little window will come up like the image above. Here you can
choose where you want to save your gif to, what you want to name it and also how it will loop. Most of the time you'll
just want to leave it on Infinite loop. Click OK to begin exporting.

http://imageshack.us/m/717/7357/gifexport.png

