R1

hostname R1

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 100.0.0.1 255.255.255.255

!

interface FastEthernet0/0

 ip address 10.0.12.1 255.255.255.0

!

interface FastEthernet0/1

 ip address 10.0.14.1 255.255.255.0

!

interface FastEthernet1/0

 ip address 101.0.0.2 255.255.255.252

!

router ospf 1

 log-adjacency-changes

 passive-interface FastEthernet1/0

 network 1.1.1.1 0.0.0.0 area 0

 network 10.0.0.0 0.255.255.255 area 0

 network 100.0.0.0 0.0.1.255 area 0

!

router bgp 64500

 no synchronization

 bgp log-neighbor-changes

 network 100.0.0.0 mask 255.255.254.0

 neighbor AS64500 peer-group

 neighbor AS64500 remote-as 64500

 neighbor AS64500 update-source Loopback0

 neighbor AS64500 route-reflector-client

 neighbor AS64500 next-hop-self

 neighbor 2.2.2.2 peer-group AS64500

 neighbor 3.3.3.3 peer-group AS64500

 neighbor 4.4.4.4 peer-group AS64500

 neighbor 101.0.0.1 remote-as 64501

 no auto-summary

!

ip route 100.0.0.0 255.255.254.0 Null0


R2

hostname R2

!

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

 ip address 10.0.23.2 255.255.255.0

!

interface FastEthernet0/1

 ip address 10.0.12.2 255.255.255.0

!

interface FastEthernet1/0

 ip address 102.0.0.2 255.255.255.252

!

router ospf 1

 log-adjacency-changes

 passive-interface FastEthernet1/0

 network 2.2.2.2 0.0.0.0 area 0

 network 10.0.0.0 0.255.255.255 area 0

 network 100.0.0.0 0.0.1.255 area 0

!

router bgp 64500

 no synchronization

 bgp log-neighbor-changes

 network 100.0.0.0 mask 255.255.254.0

 neighbor 1.1.1.1 remote-as 64500

 neighbor 1.1.1.1 update-source Loopback0

 neighbor 1.1.1.1 next-hop-self

 neighbor 102.0.0.1 remote-as 64502

 no auto-summary

!

ip route 100.0.0.0 255.255.254.0 Null0


R3

hostname R3

!

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

!

interface FastEthernet0/0

 ip address 10.0.34.3 255.255.255.0

!

interface FastEthernet0/1

 ip address 10.0.23.3 255.255.255.0

!

router ospf 1

 log-adjacency-changes

 passive-interface FastEthernet1/0

 network 3.3.3.3 0.0.0.0 area 0

 network 10.0.0.0 0.255.255.255 area 0

 network 100.0.0.0 0.0.1.255 area 0

!

router bgp 64500

 no synchronization

 bgp log-neighbor-changes

 network 100.0.0.0 mask 255.255.254.0

 neighbor 1.1.1.1 remote-as 64500

 neighbor 1.1.1.1 update-source Loopback0

 neighbor 1.1.1.1 next-hop-self

 no auto-summary

!

ip route 100.0.0.0 255.255.254.0 Null0


R4

hostname R4

!

nterface Loopback0

 ip address 4.4.4.4 255.255.255.255

!

interface FastEthernet0/0

 ip address 10.0.14.4 255.255.255.0

!

interface FastEthernet0/1

 ip address 10.0.34.4 255.255.255.0

!

interface FastEthernet1/0

 ip address 100.0.0.5 255.255.255.252

!

router ospf 1

 log-adjacency-changes

 passive-interface FastEthernet1/0

 network 4.4.4.4 0.0.0.0 area 0

 network 10.0.0.0 0.255.255.255 area 0

 network 100.0.0.0 0.0.1.255 area 0

!

router bgp 64500

 no synchronization

 bgp log-neighbor-changes

 network 100.0.0.0 mask 255.255.254.0

 neighbor 1.1.1.1 remote-as 64500

 neighbor 1.1.1.1 update-source Loopback0

 neighbor 1.1.1.1 next-hop-self

 neighbor 100.0.0.6 remote-as 64504

 no auto-summary

!

ip route 100.0.0.0 255.255.254.0 Null0