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Some Quick Rules: 
1.​ You can’t claim that the Spirit Avatar is your own work. 

2.​ You can’t redistribute, share, or resell any of the Spirit Avatar files. 

3.​ If you want to sell a customisation (e.g. a custom skin or other modification) of the Spirit Avatar 

to someone else, you may only do so if both you and the other person have purchased it. 

4.​ If you want to upload your Spirit Avatar as a Public VRChat Avatar, you need to include the 

CreditQuad object (inside the chest) with its material, unchanged from the template avatar. 

 

 
 

Join the Spirit Sanctuary!  discord.gg/djdvPABtK5​ ​ Copyright © 2022 HIYU 
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Setting up your Unity Project 

 Installing the VRChat Creator Companion 
Download and install the Creator Companion app from the VRChat Downloads Page. If you 

don’t already have VRChat’s version of Unity Engine installed, the app will prompt you with a 

button that installs it. 

Creating a new Unity Project 
Once the correct version of Unity is installed, click ‘New’ in Creator 

Companion, and choose ‘Avatar’ as the project type. The Unity editor 

will start up with your new project. 

Importing the Unity Package 
Drag and drop the .unitypackage file from the .zip into the ‘Project’ tab 

of your Unity Project. 

If the Project tab doesn’t let you do that, make sure you don’t have 

anything written in its search bar. 

If the file fails to extract from the .zip, try extracting it to another folder 

first, before dragging it in. 

Alternatively, you can choose Assets > Import Package > Custom 

Package… and navigate to the .unitypackage file. 

Quest Version 
It’s now recommended to use the same Unity Project for both PC and Quest avatars. 

When you’re ready to upload your Quest version, you’ll need to switch to Android mode: Click 

File > Build Settings… and select Android from the list. 

Change Texture Compression to ASTC (it’s much prettier!). 

Click Switch Platform in the bottom right of the window. Unity will do a Big Think for a bit. 

(To return to PC mode, select PC in the Build Settings window and click Switch Platform again.) 

 

If you ever get confused which mode your Unity editor is set to, a quick way to check is to look 

at the top title-bar of the Unity window, and it’ll specify the current platform there. 

 

Note: Quest prefers lower-resolution texture settings. See the instructions in the next section if 

you’re using your own custom textures!  

 

https://vrchat.com/home/download
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Importing Textures 
Example textures are provided in Avatars/SpiritAvatar/SpiritAvatar. 

 

1. Create a new folder in Avatars/SpiritAvatar/ with the name of your character (I recommend 

doing this from within the Project view in the Unity editor). 

If you are exporting from Substance Painter, you can create & choose this folder from the export 

dialog. By default, the provided Painter projects will name your textures based on the project's 

file name. (I recommend exporting to Avatars/SpiritAvatar/<CharacterName>/Textures) 

 

2.  PC  Select all of your textures and look in the Inspector. Set the Max Size setting to 2048, 

and enable Streaming Mip Maps (under Advanced). Click Apply, or continue to the next step. 

 

 

Note: If you notice colour banding/visible texture compression on your Spirit, you can set the 

‘Compressor Quality’ setting of your Albedo (_A) and Emission (_E) textures to High Quality. 

Note: You can set the Normal (_N) texture’s Max Size to 4096 for more definition on skin. 

 

3.  Quest  Click the Android logo tab in the compression settings (1), then select Override for 

Android (2). 

 

Set the Max Size setting to 1024 (3) and change the Format (4) to RGB(A) Compressed ASTC 

6x6 block. Click Apply. 

If you need some extra resolution on Quest, set the Albedo texture’s Max Size to 2048.
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Setting up Materials 
1. Navigate to Avatars/SpiritAvatar/SpiritAvatar/Materials. 

You will see 4 materials - the body, the eye gloss layer, the eyes, and the Quest material. 

 

2. Select all materials except the EyeGloss and duplicate them (Ctrl+D), then drag-and-drop 

the new materials into your own character's folder. It's helpful to add your character's name to 

each - I also recommend making a dedicated Materials folder for these. 

Note: The Body and Eye materials are exactly the same, except that the Body material has a 

black texture in the Emissive by default. This prevents eye emission appearing at texture seams. 

 

3. Inside each new material, replace the default textures with your own. There's two ways to 

do this: 

Click the texture slot and find your texture 

or​ Drag-and-drop your texture from the Project view into the slot. 

Notes: 

- You don’t need to change out the Subsurface texture unless you changed any of the 

Transmission values in Substance Painter. 

- You shouldn’t modify the Effect Masks texture. 

- I’ve found that the Quest version doesn’t really benefit from having a Normal texture assigned. 

Leaving it unassigned reduces file size and memory usage. 

 

4. Navigate to Avatars/SpiritAvatar/ and open the Scene file (SpiritAvatar.unity). 

You can choose to use the existing SpiritAvatar object, or duplicate it (Ctrl+D) and make another. 

I also recommend renaming this new one to your character's name, and moving it to the side. 

 

5. Click on your Spirit in the Scene view, then click again to select the Body object. In the 

Inspector, set the first material to your Body material, the second material to your Eye material, 

and leave the third material as the EyeGloss material. 

 

 

 Using the Fur Shader 
If you’d like more detailed fur, download Warren’s Fast Fur Shader (a free ‘Lite’ version is 

available for download on the same page). Import the Fast Fur Shader .unitypackage into your 

project, then navigate to Avatars/SpiritAvatar/CommonFiles/Materials/ and duplicate either the 

Fur Shader Template or Fur Shader (Lite) Template material. You can edit this fur material and 

assign your custom texture(s) to it.  

 

https://warrenwolfy.gumroad.com/l/atntv
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Custom Fur Colours Shader 
The unitypackage includes a special material that lets you change the fur colours in-engine! 

This uses its own shader, so is only available on PC. There’s two ways to make use of it: 

 

Method 1: In-Game 
In the SpiritAvatar scene, you’ll find a Spirit called SpiritAvatar Customizable In-Game. 

Uploading this to VRChat will give you custom colour options on the Radial Menu, including the 

ability to save & load your own in-game colour preset: 

 

 

 

Note: This Spirit uses its own set of menus, parameters, and animators. In-game, It will override 

existing colours in its materials. If you want to set the colours within Unity, use Method 2. 

 

Method 2: In Unity 
You can also apply the same customizable material to your own avatar, and set its colours 

directly in Unity. Set your avatar’s body and eye materials to the materials found in 

Assets/Avatars/SpiritAvatar/Customizable/Materials, then select both materials and change 

their colours together. 
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Uploading to VRChat 

PC Version Upload 
Note: This section assumes you are uploading for PC first, before uploading for Quest! 

 

1. In the top menu bar, select VRChat SDK > Show Control Panel. 

 

2. Sign in to the VRChat SDK control panel. 

 

3. On the Builder tab (ensuring the correct avatar is selected if you have multiple), you'll see a 

breakdown of your avatar's performance stats and any issues it may have. If there are no issues, 

you can click the Build & Publish button. 

 

4. Unity will start packaging your avatar for upload, then will enter Play mode where the SDK 

shows an interface in the Game view. 

After entering a name for your avatar, you can set up your thumbnail image using the 

freshly-created VRCCam object. For this, I recommend dragging the Game view to be alongside 

the Scene view, so you can see both at once. 

 

Recommended camera settings: 

●​ Position & Zoom 

○​ I've set up a camera called Main Camera in a clear position. In the Hierarchy, drag 

the VRCCam object on top of the Main Camera so that it becomes a child of it, 

then go to the Inspector, right click at the top of its Transform component, and 

select Reset. Zoom in with the Field of View slider (18 is a good value). 

●​ Post Processing (requires Post Processing package, find in Window > Package Manager) 

○​ Unity cameras display only raw colour by default, without being tuned to what 

the eye expects to see. On the VRCCam, click Add Component, and add a Post 

Process Layer. Set the Layer dropdown to Water, and if you want, set Anti-aliasing 

to SMAA. 

 

5. Upload your Spirit! 
 

Note: when using Full-Body Tracking, I’ve found that setting VRChat’s in-game IK setting to ‘Lock 

Hip’ gives the best results with Spirit. This is due to the size of the head & neck in relation to the 

rest of the body. Otherwise, switch to ‘Lock All’ to go granny mode. 
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Quest Version Upload 
You will be uploading your Quest version to the same Avatar ID as your PC version. 

This will not overwrite the existing PC version, so don’t worry. When you're wearing your avatar, 

PC and Quest users will each see the version that was uploaded for their platform. 

 

1. If the VRCSDK is not shown, select VRChat SDK > Show Control Panel. 

 

2. If you aren’t signed in already, Sign in to the VRChat SDK control panel. 

 

3. In the Content Manager tab, find your existing PC Spirit Avatar and click Copy ID. 

 

4. Select your Quest avatar and look in the Inspector for the Pipeline Manager component. 

Paste the ID into it and click Attach. 

 

5. Switch Unity into Android build mode as described in this section. 

 

6. Go to the Builder tab, ensuring you have your Quest avatar selected in the SDK, and click 

Build & Publish for Android. 

 

Your Spirit should now have both a PC and Quest version uploaded to the same ID! 

 

Quest/PC Fallback Avatars (Optional) 
VRChat allows you to upload a super-optimised avatar that users will see if the avatar you’re 

wearing is hidden to them for whatever reason (usually safety settings). This is called a Fallback 

Avatar - and both PC and Quest fallback avatars are included. 

This is a special type of avatar, so you’ll need to upload it to a new avatar ID, ensuring that it 

has a performance rank of Good or Excellent. Quest and PC fallback templates are included in 

the Scene. 

 

To unlock the SDK option to set an avatar as a Fallback, you’ll need to be in Android/iOS mode 

in Unity, have a rating of Good on mobile, and also have every other avatar in the scene 

hidden/disabled. 

 

Upload your Quest fallback first, then upload your PC fallback to the same ID. 

 

Note: Quest fallbacks are especially useful if you have multiple PC versions of an avatar, and 

don’t want to upload a separate Quest version for each.  
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Texturing 

Substance Painter 

The Workflow 
The first layers I recommend changing are the ones highlighted in  Blue . 

Optional layers for more detailed editing, e.g. separate eye colours, are  Green . 

Some of these will reference a separate, shared Anchor for their colour input - replace this (in 

the Properties panel, not the Layers panel) if you want to change them individually. 

Note: For editing the fur on the body, I recommend not touching the Fur Data layer at the 

bottom of the Fur folder, and only adjusting the colours & masks of the various colour layers. 

 

When you’re done, you will need to export the textures. The correct export settings are 

already set up in the project - you just need to set an export location. As mentioned in 

Importing Textures, I recommend Assets/Avatars/SpiritAvatar/<CharacterName>/Textures. 

 

2D Graphics Editors e.g. Photoshop 
A .PSD file is available for download. It has the same layer setup as the Substance Painter file. 

 

Included is a Guides layer group with a UV wireframe and labels for the UV islands: 

 

​  

 

To locate a UV island in Photoshop, you can use the Name search function in the Layers tab.
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Modelling (Optional) 
You don’t need Blender to upload the Spirit Avatar to VRChat. 
This section is for users who want to make custom edits to the base model’s shape. 

For adding custom textures & uploading, see the Unity Project section. 

 

Three .blend files are provided - for PC, Quest, and Quest Fallback. 

Editing the Model 
When editing the model, proceed with caution - Spirit has lots of Shape Keys - adding or 

removing anything from the mesh may break them. Ensure that you’re in the Basis shape key 

when making changes to the base model. If you’re not adding or removing any geometry, then 

starting with a new Shape Key to contain all your edits is also a recommended workflow (the 

shape key can be set to 100% on the mesh in Unity). 

Exporting Your Custom Model to Unity 
I highly recommend using Asset Creation Toolset (a free addon) for exporting to Unity from 

Blender. You can access it from the Object Mode sidebar after installing & enabling the addon. 

In ACT’s Import/Export Tools tab, set Export Mode to All -> One FBX. Choose a name & export 

path, then select both the Body mesh and Armature and click Export FBX to Unity. 

 

Otherwise, if you aren’t using ACT, select both your Body mesh and Armature, and choose File > 

Export > FBX. Use these settings for your FBX export: 

 

https://mrven.gumroad.com/l/hPXIh
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Setting Up Your Custom Model in Unity 
If you’re unfamiliar with avatar creation for VRChat, it’s good to first read the Creating Your First 

Avatar page on the VRChat docs.  

 

Before we get started, click on the FBX file, and its Import Settings will show up in the Inspector. 

Go to the Model tab and enable Read/Write Enabled, as well as Legacy Blend Shape Normals. 

 

Now go to the Rig tab, and set the Animation Type to Humanoid. From this point, there’s two 

ways you can set it up: 

 

Method 1: Inheriting properties from the existing Spirit Avatar 

Set Avatar Definition to Copy From Other Avatar, and choose SpiritAvatarAvatar (from the 

original SpiritAvatar mesh), or for Quest, SpiritAvatar_QuestAvatar. This will allow you to easily 

switch out the mesh in the Skinned Mesh Renderer on the existing Spirit in the scene. 

You can also place your model into the scene and copy everything over from the existing 

SpiritAvatar object. To do this easily, I recommend using the Copy Components function of 

Pumkin’s Avatar Tools. 

 

Method 2: Full custom setup 
With Avatar Definition set to Create From This 

Model, click Configure. 

 

Spirit uses a digitigrade approximation, consisting 

of a specific arrangement of bones and rotation 

constraints. Set up the Leg and Foot assignments 

as pictured (right). 

 

Note: VRChat doesn’t support constraints on 

Quest avatars, so this arrangement is not present on the Quest version. 

 

Ignore errors about the avatar not being in T-Pose. 

 

In the Head section, make sure there’s no Jaw bone assigned. Then click Apply. 

In the scene, you’ll need to copy the Avatar Descriptor, Avatar Dynamics components, and 

Constraints from the existing SpiritAvatar (as well as the CreditQuad, if you’re making a public 

avatar). As above, I recommend using the Copy Components function of Pumkin’s Avatar Tools 

to do this all-in-one-go.  

 

https://docs.vrchat.com/docs/creating-your-first-avatar
https://docs.vrchat.com/docs/creating-your-first-avatar
https://github.com/rurre/PumkinsAvatarTools
https://github.com/rurre/PumkinsAvatarTools


 

12​

Acknowledgements 
People who helped make this project what it is! My heartfelt thanks go out to: 

 

 

Eslar @EslarFox 

For the awesome Substance Painter Fur Brush & Transition Filter 

 

DragonSkyRunner DragonSkyRunner 

For their invaluable Digitigrade Legs Tutorial 

KaideArt @Kaideart 

For their video version 

 

AtlasTheFox @atlasthefoxx 

BleuSomme @BleuSomme 

Kyderra @Kyderra 
For feedback and beta testing 

 

The Furality Team @Furality 

 

My Patrons on Patreon: 
 

Pebble 

Ethan Wheeler 

tyler brown 

Patroll 

Tim D. 

Beatfox 

Kosmic the Stoat 

Zael Zolnir 

Selwyn 

Semni Istiqlal 

Ethan Staghorn 

Berty 

Hubble The Wolverine 

Kakurady 

binaryfox 

Collinh71 

Viridis the Coyote 

Rreze 

Korrin 

Max Cook 

Foxo! 

Runoratsu 

Orin 

Bastion Otto 

Space 

Sibir Lupus 

Slick 

 

 

For your generosity and support. 

Thank you! 

 

https://twitter.com/EslarFox
https://gumroad.com/eslar#hxlDG
https://www.furaffinity.net/user/dragonskyrunner/
https://www.furaffinity.net/view/44035707/
https://twitter.com/Kaideart
https://twitter.com/atlasthefoxx
https://twitter.com/BleuSomme
https://twitter.com/Kyderra
http://twitter.com/furality
https://www.patreon.com/hiyu

	 
	 
	 
	 
	 
	 
	 
	 
	Spirit User Manual 
	Setting up your Unity Project 
	 Installing the VRChat Creator Companion 
	Creating a new Unity Project 
	Importing the Unity Package 
	Quest Version 
	Importing Textures 
	Setting up Materials 
	 Using the Fur Shader 
	Custom Fur Colours Shader 

	Uploading to VRChat 
	PC Version Upload 
	Quest Version Upload 
	Quest/PC Fallback Avatars (Optional) 


	Texturing 
	Substance Painter 
	The Workflow 

	2D Graphics Editors e.g. Photoshop 

	Modelling (Optional) 
	Editing the Model 
	Exporting Your Custom Model to Unity 
	Setting Up Your Custom Model in Unity 

	Acknowledgements 

