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1. Introduction: The Core Concept 
Welcome to the This2That Suite Manager!  

This addon doesn't just add one tool; it acts as a central hub for a growing collection of powerful 
and efficient sub-addons. The core concept is to provide a clean, organized, and customizable 
workflow. Instead of cluttering your interface with dozens of panels, the Suite Manager lets you: 

●​ Enable Only What You Need: Activate individual modules from the Add-on 
Preferences. If you don't use a tool, you don't have to see it. 

●​ Control Visibility: Once a module is enabled, you can easily show or hide its panel 
directly in the 3D Viewport's N-Panel. This keeps your workspace tidy while giving you 
instant access to your favorite tools. 

●​ Discover New Features: The manager will show you all possible modules in the suite, 
including special features available to those who support the addon's development. 

 



 

This2That Directory Structure 
 

This2That_Extension_(version)_(date)_(type).zip* 

​ |_ This2That_Extension_(version) 

​ ​ |_ Camera2View Pro 

​ ​ |_ Location2Curve 

​ ​ |_ Material2Selection 

​ ​ |_ Object2View 

​ ​ |_ Ops2Macro (former Selection2Macro) 

​ ​ |_ Overlay2Camera 

​ ​ |_ Overlay2View​
​ ​ |_ Preset2Camera 

​ ​ |_ (any other future module) 

 

 
* Refers to the name of the package. It can be named This2That_Extension_(version)_(date).zip (includes Free2Use 
modules) or This2That_Extension_(version)_(date)_Support2Develop.zip 
(includes Free2Use and Support2Develop modules). If you have purchased individual modules, the name can be 
something like This2That_Extension_(version)_Camera2View_Pro_(version).zip  



 

2. Installation & Troubleshooting 
This section covers the correct way to install the This2That Suite Manager as a Blender 
Extension and provides steps to solve common issues. 

Installation 

Because This2That is a modern Blender Extension, the installation process is slightly different 
from traditional addons. Please follow these steps carefully: 

1.​ Download the This2That_...zip file. 
2.​ Open Blender and navigate to Edit > Preferences. 
3.​ Go to the Get Extensions tab on the left. 
4.​ Click the Install from Disk... button. 
5.​ Navigate to your downloaded .zip file, select it, and click "Install from Disk". 
6.​ Blender will automatically install the extension. Now, switch to the Add-ons tab (still 

within Preferences). 
7.​ Find "This2That Suite Manager" in the list and tick the checkbox next to it to enable the 

addon. 

Once enabled, you can manage its sub-modules from within this same Add-ons panel, and the 
UI will appear in the 3D Viewport's N-Panel under the "This2That" tab. 



 



 

Troubleshooting Common Issues 

If you encounter bugs, errors, or unexpected behavior, it is often due to conflicting files from a 
previous installation. Following these steps will solve the vast majority of problems. 

How to Perform a Clean Reinstall 

This is the most effective way to fix issues. 

1.​ Disable the Addon and uninstall the Extension: go to Edit > Preferences > Addons, 
find "This2That Suite Manager", and un-tick the checkbox to disable it, then go to Edit > 
Preferences > Get Extensions > Uninstall 

2.​ Restart Blender: This is a crucial step to ensure Blender fully unloads the addon's code 
from memory. 

3.​ Manually Delete Old Folders: You need to find and delete the addon's installation 
folder. The location depends on your operating system: 

○​ Windows: C:\Users\<YourUsername>\AppData\Roaming\Blender 
Foundation\Blender\<BlenderVersion>\extensions\user_default\ 

○​ macOS: /Users/<YourUsername>/Library/Application 
Support/Blender/<BlenderVersion>/extensions/user_default/ 

○​ Linux: ~/.config/blender/<BlenderVersion>/extensions/user_default/ 
4.​ Inside that user_default directory, find and delete the entire this2that folder. Note: The 

folder name might be slightly different, like This2That_Extension, depending on the 
package. 

5.​ Restart Blender Again: This ensures Blender recognizes that the old files are 
completely gone. 

6.​ Re-install: Follow the installation steps above to install the new version of the addon 
from the .zip file. 

 



 

"My Checkboxes Are Grayed Out!" 

●​ This is not a bug! This is the intended behavior when a module from the 
Support2Develop category is not physically present in your extension folder. It is an 
indicator that the feature is available in a different version of the extension. You can click 
"Learn More!" link next to it for more information. 

 

 



 

Reporting a Bug 

If you have performed a clean reinstall and are still experiencing a persistent, repeatable error, 
you have likely found a genuine bug. Please help us fix it by: 

1.​ Going to Window > Toggle System Console in Blender. 
2.​ Reproducing the error. 
3.​ Copying the entire error message (the full Traceback... block). 
4.​ Reporting the issue on our Discord Support Channel, including the error message and a 

brief description of what you were doing when it occurred. 

 

 

https://discord.gg/exk6M8qgmG


 

3. How to Use the Manager 
Managing your tools is a simple two-step process: 

Step 1: Enable Modules in Preferences 

This is the main control panel where you decide which tools are fundamentally active. 

1.​ Go to Edit > Preferences > Addons. 
2.​ Find and expand the This2That Suite Manager. 
3.​ You will see a list of all available sub-modules with checkboxes. Tick the box for each 

module you want to use. 
4.​ Modules that are physically missing (e.g., in the free version) will be grayed out but will 

show a message on how to get them. 

 

 



 

Step 2: Show/Hide Panels in the 3D Viewport 

Once a module is enabled in the preferences, you can control its visibility in your workspace. 

1.​ In the 3D Viewport, press the N key to open the side panel. 
2.​ Click on the "This2That" tab. 
3.​ You will see a list of toggle buttons for all the modules you enabled in Step 1. Click these 

buttons to show or hide the individual panels for each tool within this tab. 

 

 

 



 

4. Module Library 
The suite is divided into ‘Free2Use’ and ‘Support2Develop’ modules. All modules are 
designed to turn one thing ("This") into another ("That"), speeding up your workflow. This 
structure is designed to be both fair and sustainable, allowing the addon to grow and improve 
over time. 

Our philosophy is simple: everyone in the Blender community deserves access to high-quality 
tools that solve real-world problems. The Free2Use modules are the foundation of the 
This2That suite. They are not limited 'demos'; they are complete, powerful utilities designed to 
be genuinely useful in your daily workflow. We are committed to maintaining and improving 
these core tools for the entire community. 

The Support2Develop modules represent the next step in the suite's evolution. These tools 
often solve more complex or specialized problems and require significantly more development 
time and research to create and maintain. By choosing to support the development, you are not 
just unlocking these advanced features for yourself; you are directly investing in the entire 
project's future. 

Your support makes it possible to dedicate the time needed to develop ambitious new ideas, 
keep all modules updated with the latest Blender releases, and continue improving the core 
'Free2Use' tools as well. We believe this model offers the best of both worlds: a powerful, free 
toolkit for everyone, and a path for dedicated users to help us build even more amazing things 
together. 

Thank you for being a part of this journey! 

 



 

Free2Use Modules 

These modules are available to all users. 

 

 



 

Location2Curve / Free2Use Module 

●​ Purpose: This is a highly versatile tool for generating a Bezier curve object from the 
positions of other objects. It has two primary modes: creating a static path from a group 
of objects or creating a dynamic motion path from an animated object's keyframes. It 
also features a powerful "Live Edit" mode. 

●​ Usage:​
Workflow 1: Creating a Curve from Multiple Objects​
This mode is perfect for creating paths, cables, or guides that connect a series of static 
objects. 

○​ Select two or more objects in your scene (e.g., Empties, Meshes). The order of 
selection does not matter; they will be sorted alphabetically by name. 

○​ In the Location2Curve panel, click "Create from Selected". A new curve object 
will be created, connecting the origins of your selected objects. The original 
objects will be deselected, and the new curve will become active. 

○​ This new curve is now "aware" of the objects it was created from. You can now: 
■​ Move the original objects to new positions. 
■​ Click "Update Now" to refresh the curve's shape to match the new 

positions. 
■​ Click "Start Live Edit" to enter a modal mode where the curve updates 

automatically in real-time as you move the tracked objects. This is 
incredibly powerful for interactive adjustments. To stop, either press ESC 
or click the "Stop Live Edit" button. 

●​ Workflow 2: Creating a Motion Path from Keyframes​
Use this to visualize the trajectory of an animated object. 

○​ Select a single object that has location keyframes in its animation data. 
○​ Click "Create/Update Keyframe Curve". 
○​ A new curve is created that perfectly follows the animated object's path through 

its keyframes. 
○​ The addon cleverly links the animated object and the curve. If you change the 

animation (add, move, or delete keyframes) and click the button again, it will 
intelligently update the existing curve instead of creating a new one. 

●​ Curve Utilities 
○​ Set Curve Resolution: This handy utility lets you quickly change the 

smoothness of any selected curve(s). Click it to bring up a dialog where you can 
set the resolution value. 

 

 



 

 

 



 

Material2Selection / Free2Use Module 

●​ Purpose: A streamlined utility for managing and applying materials. It simplifies the 
process of transferring materials between objects/faces and applying materials from your 
scene's library. 

●​ Usage: This tool's behavior changes intelligently based on whether you are in Object 
Mode or Edit Mode.​
Transfer Material​
This section is for copying a material from your active element to the rest of your 
selection. 

○​ In Object Mode: Select multiple objects. The last object you select (with the 
yellow outline) is the "active" one. Click "Transfer from Active" to copy the 
active material from that object to all other selected objects. 

○​ In Edit Mode: Select multiple faces. The last face selected is the "active" one. 
Click "Transfer from Active" to apply the material from that face to all other 
selected faces. 

●​ Apply from Library​
This section provides a visual gallery of every material in your current .blend file. 

○​ Each material is shown with its name and a shader ball preview. 
○​ Simply find the material you want and click the "Apply" button next to it. 
○​ In Object Mode, it will be applied to all selected objects. 
○​ In Edit Mode, it will be applied to all selected faces. 

 



 



 

Object2View / Free2Use Module 

●​ Purpose: To precisely position and orient selected objects directly in front of your 
viewport or active camera view. It is an essential tool for framing shots, creating product 
turntables, or placing objects for sculpting and modeling. 

●​ Usage: 
○​ Select one or more objects you want to place. 
○​ Adjust the settings in the Object2View panel to define how they will be placed. 
○​ Click the "Place/Update Selected" button to apply the transformation. 

●​ Key Settings: 
○​ Distance: Sets how far away the object will be placed from your viewpoint or 

camera. 
○​ Enable Real-time Updates: When this is checked, the addon will update the 

object's position live as you drag the Distance slider. This is fantastic for 
interactive placement but may be disabled for performance. 

○​ Orientation Mode: This powerful dropdown controls the object's rotation: 
■​ Keep Current: The object is moved to the target position but keeps its 

original rotation. 
■​ Transfer View: The object's rotation is changed to match the 

camera/view's orientation. 
■​ Use Stored Original: Reverts the object's rotation to what it was before 

you started using the tool on it. Perfect for undoing orientation changes 
without losing your position. 

○​ Snap to Surface: If checked, the tool will project a ray into the scene and place 
the object on the first surface it hits, ignoring the Distance setting. 

○​ Align to Surface Normal: An option that appears when "Snap to Surface" is on. 
If checked, the object's local Z-axis will align with the surface it's snapped to, 
making it look like it's sitting "flat" on that surface. 

○​ Camera Center Guide: A simple utility to toggle the visibility of the camera's 
cross-shaped composition guide, helping you center your objects perfectly. 

 



 

 

 



 



 

Support2Develop Modules 

These are more advanced or specialized modules available to users who support the addon's 
continued development. Thank you for your support! If these modules are unavailable, a link will 
guide you on how to get them. 

Activating Your Support2Develop Modules 

Thank you for supporting the development of the This2That suite! When you get the supporter 
version, you will receive a complete This2That_...zip file that contains both the Free2Use and 
the Support2Develop modules bundled together. 

To avoid any file conflicts, the easiest and safest way to upgrade is to perform a clean 
installation. 

1.​ First, completely remove the old version: Follow all the steps in the "How to Perform 
a Clean Reinstall" guide in the Troubleshooting section above. This involves disabling 
the addon, restarting Blender, and manually deleting the old addon folder. This step is 
crucial to prevent issues. 

2.​ Install the new ZIP file: Once the old version is gone, follow the standard installation 
procedure (Edit > Preferences > Extensions > Install from Disk...) to install the new, 
complete .zip file you received. 

3.​ Enable the modules: Go back into the Add-on Preferences for the This2That Suite 
Manager. You will now see that the checkboxes for the Support2Develop modules are no 
longer grayed out. You can now tick them to enable them just like any other module. 

Alternative Method (Manual Placement): 

If you have received an individual module folder (e.g., just the Ops2Macro folder) and want to 
add it to your existing installation, you can do so manually. This is a more advanced method. 

1.​ Find your Blender extensions directory (the same one mentioned in the "Clean Reinstall" 
guide). 

2.​ Navigate into the This2That folder. 
3.​ Place the new module folder (e.g., Ops2Macro) directly inside this This2That folder, 

alongside the others like Location2Curve. 
4.​ Restart Blender. The addon manager will automatically detect the new module on 

startup, and its checkbox in the preferences will become active. 

 

 

 



 

Camera2View Pro / Support2Develop Module 

●​ Purpose: This is a comprehensive camera management and animation toolkit designed 
for artists, animators, and directors. It goes far beyond simply creating a camera; it 
provides a complete workflow for setting up multiple shots, keyframing camera 
properties, and even managing different render resolutions for each camera, all from one 
convenient panel. 

●​ Usage: The panel is divided into logical sections that follow a typical shot-creation 
workflow.​
1. Core Camera Actions​
This is your starting point for creating and animating cameras. 

○​ Create Camera from View: The primary function. Frame your shot exactly as 
you want it in the 3D viewport. When you click this button, the addon: 

1.​ Creates a new, sequentially named camera (e.g., Camera2View_001, 
Camera2View_002). 

2.​ Perfectly matches the new camera's position, rotation, and lens settings 
to your current view. 

3.​ Sets this new camera as the active scene camera. 
4.​ Automatically switches your view to Camera View and locks the camera 

to the view. This is a huge time-saver, as you can immediately start 
orbiting and panning to refine your shot. 

○​ Keyframe Active Camera: With your active camera selected and positioned, 
click this button to insert a keyframe for its Location and Rotation on the current 
frame of the timeline. 

●​ 2. Camera & Keyframe Navigation​
Once you have multiple shots or keyframes, this section becomes essential. 

○​ Next/Prev Camera: Cycles through all cameras in the scene that were created 
by this addon (i.e., named Camera2View_...). This lets you rapidly switch 
between your shots like flipping through a storyboard. 

○​ Next/Prev Keyframe: Jumps the timeline to the next or previous keyframe of the 
currently active Camera2View camera, allowing you to quickly review your 
animated camera moves. 

●​ 3. Camera Properties & Animation​
This section gives you direct control over the active camera's data properties. 

○​ You can adjust settings like Focal Length, Shift X/Y, and Clipping. 
○​ Keyframe Icon: Next to each property is a small keyframe icon (diamond 

shape). Clicking this will insert a keyframe for that specific property only. This is 
perfect for animating effects like a lens zoom (keyframing Focal Length) or a rack 
focus (keyframing Depth of Field Distance) without affecting the camera's 
position. 

●​ 4. Custom Resolution Per Camera​
This is an advanced feature for managing multiple aspect ratios within a single project. 



 

○​ Use Custom Resolution: Ticking this checkbox on a camera "un-links" it from 
the main scene render resolution. The camera now has its own Resolution X and 
Resolution Y fields. 

○​ Automatic Override: When a camera with this option enabled is the active 
scene camera, it temporarily overrides Blender's main Output Properties. Your 
viewport will update to show the new aspect ratio. If you switch to another 
camera that doesn't have this enabled, the scene resolution instantly reverts to 
the original settings. Your main project settings are always safe. 

○​ Apply Custom Resolution: This button provides a manual way to "commit" the 
active camera's custom resolution to the main scene render settings. This is 
useful if you've decided that a specific shot's aspect ratio should now be the new 
project default. 

●​ 5. Scene Output Format​
For convenience, this section displays the current, final render resolution of the scene, 
reflecting any overrides from the active camera. This gives you a clear confirmation of 
what your final render dimensions will be. 

 



 

Ops2Macro (former Selection2Macro) / Support2Develop Module 

●​ Purpose: A powerful macro system that allows you to record, save, and replay 
sequences of operations to automate complex and repetitive tasks. Macros are saved 
permanently into Blender's preferences, so your library is available across all your 
projects. 

●​ Usage: The workflow is designed to be simple and intuitive.​
1. Recording a Macro 

○​ Click "Start Recording". The addon will now monitor the actions you perform. 
○​ Execute any sequence of operations in Blender (e.g., select an object, switch to 

Edit Mode, select a loop, bevel it, switch back to Object Mode). The panel will 
show a live count of the operations being recorded. 

○​ When you are finished, click "Stop & Save". This will prompt you to give your 
new macro a name. Alternatively, click "Stop & Discard" to cancel the recording. 

●​ 2. Running a Macro 
○​ From the dropdown list under "Manage & Run Macros," select the macro you 

want to run. 
○​ Click the "Run Macro" button. The addon will execute the entire saved 

sequence of operations instantly. 
○​ Deselect After Execution: If this is checked, the addon will attempt to deselect 

everything after the macro finishes, leaving you with a clean state. 
●​ 3. Managing Your Library 

○​ With a macro selected in the dropdown, you can use the Rename or Delete 
buttons to organize your library. Deleting is permanent, so be careful! 

○​ Import / Export: These crucial features allow you to save your entire library of 
macros to a .json file. You can use this to back up your work, move your macros 
to a new computer, or share your favorite automated workflows with other artists. 
When importing, you have the option to Merge with your existing library or 
Overwrite it completely. 

 

 



 

 

 



 

 



 

Overlay2Camera / Support2Develop Module 

●​ Purpose: To create and manage 3D overlay objects that are linked to a specific 
camera. Unlike a simple screen overlay, these are real objects in your scene, allowing 
you to build complex reference setups, storyboards, or composition guides that are 
unique to each shot. 

●​ Usage: The panel is context-sensitive; it always shows the overlays for the currently 
active scene camera.​
1. Adding Overlays 

○​ Add Image: This opens Blender's file browser. Select an image, and the addon 
will create a new image plane object, automatically set up its material, and link it 
to the active camera. The plane's aspect ratio will perfectly match the image. 

○​ Add Custom: This creates a slot for a "Custom Object" overlay. You can then 
use the object-picker to select any object from your scene (e.g., a text object, a 
low-poly model, a grease pencil object) to serve as the overlay. 

●​ 2. Managing Overlays​
Each overlay you create appears in a list with its own set of controls: 

○​ Naming and Visibility: Rename each overlay for organization, and use the eye 
icon to quickly toggle its visibility. 

○​ Transform Controls: Precisely adjust the Scale, Distance from the camera, X/Y 
Offset, and Rotation of each overlay object independently. 

○​ Parent All to This Camera: This master checkbox determines if the overlay 
objects are children of the camera. When checked, they will move and rotate 
perfectly with the camera. When unchecked, they are "stamped" into world 
space, allowing the camera to move independently of them. 

●​ 3. Finalizing Your Setup 
○​ Refresh All: Updates all overlay objects for the current camera. Useful if 

something seems out of sync. 
○​ Realize Overlays: This is a powerful "baking" function. It creates permanent, 

independent copies of all visible overlays for the active camera and places them 
in a new, timestamped collection. This is perfect for when you are finished with 
your reference setup and want to convert the overlays into regular, editable 
scene objects. 

 



 

 

 



 

 

 



 



 

Overlay2View / Support2Develop Module 

●​ Purpose: To draw one or more custom overlays (images or placeholder shapes) in the 
center of your 3D Viewport. This is ideal for using reference images, storyboards, or 
composition guides that stay fixed to your screen regardless of how you move the 3D 
camera. 

●​ Usage: This panel allows you to manage a list of overlays. 
○​ Click "New Overlay" to add a new overlay item to the stack. You can create as 

many as you need. 
○​ For each overlay in the list, you have a set of controls: 

■​ Visibility & Naming: Use the eye icon to toggle the overlay on/off, and 
click the name field to rename it for better organization. Use the 'X' to 
remove it. 

■​ Image Source: Click the large image field to open Blender's file browser 
and select an image. This will be your overlay. If no image is selected, the 
tool will draw a colored asterisk (*) as a placeholder. 

■​ Transform Controls: 
■​ Scale: Makes the overlay larger or smaller. 
■​ Offset X / Offset Y: Moves the overlay left/right or up/down from 

the center of the screen. 
■​ Rotation: Rotates the overlay. 

■​ Asterisk Color: If you are not using an image, this controls the color of 
the placeholder asterisk shape. 

 

●​ Utilities: 
○​ Refresh Textures (Refresh Icon): If you edit one of your overlay images in an 

external program (like Photoshop or GIMP) and save it, click this button to force 
Blender to reload the image and display the updated version. 

 



 

 

 



 

 



 

Preset2Camera / Support2Develop Module 

Purpose: This module focuses on bringing real-world camera and lens characteristics directly 
into your Blender workflow. It is designed for artists, photographers, and cinematographers who 
think in terms of specific lenses and their unique looks. It saves you from manually entering lens 
data, provides a creative launchpad for setting up shots, and consolidates essential camera 
settings into one convenient panel. 

Usage: The panel is organized to help you quickly select a lens style and then refine the 
camera's visual properties. 

1. Real-World Lens Presets 

This is the core of the module. Instead of manually setting Focal Length and Aperture, you can 
instantly apply the settings of well-known real-world lenses. When you click any preset button, 
the addon: 

●​ Sets the Focal Length of the active camera to the preset value. 
●​ Sets the Aperture F-Stop to the preset value. 
●​ Automatically enables Depth of Field (DOF) on the camera, as applying an F-Stop 

implies its use. 

The presets are grouped into collapsible categories for easy navigation: 

●​ By Use Case: The best place to start if you have a specific shot type in mind (e.g., 
Portrait, Landscape, Macro) but aren't tied to a particular brand. 

●​ Photography Lenses (by Brand): Contains presets from popular photo lens 
manufacturers like Canon, Sony, and Nikon, including famous lenses like the "Nifty Fifty." 

●​ Cinema & Video Lenses (by Brand): Focuses on lenses commonly used in filmmaking 
and video production, including cine primes and zooms from ARRI, Cooke, and others. 

●​ Film & Vintage Lenses (by Brand): Provides presets that emulate the look of classic 
lenses from the film era, including Leica and Medium Format options, to achieve a more 
retro or analog feel. 

2. Custom DOF Settings 

After applying a preset, this section allows you to fine-tune the Depth of Field effect. It acts as a 
convenient shortcut to the settings found in the main Camera Properties, so you don't have to 
leave the N-Panel. 

●​ Use Depth of Field: A master toggle for the effect. 
●​ Focus Object: The most powerful way to control focus. You can pick an Empty, a 

character's face, or any object, and the camera's focus will automatically follow it. 
●​ Focus Distance: Allows you to set the focus distance manually, which is useful for static 

shots or for animating a "rack focus" effect. 



 

●​ Aperture: This sub-panel lets you customize the look of the "bokeh" (the out-of-focus 
blur). You can change the number of Blades, their Rotation, and the Ratio to simulate 
different real-world lens characteristics. 

3. Viewport Display 

This section consolidates settings that control how the camera's view is displayed in the 
viewport, helping you focus on composition and framing without affecting the final render. 

●​ Passepartout: When enabled, this blacks out the area outside the camera's view, 
removing distractions and helping you focus on your composition. You can control the 
opacity with the Alpha slider. 

●​ Safe Areas: Overlays standard broadcast-safe guides for titles and action. Essential for 
video work to ensure critical elements aren't cut off on different screens. 

●​ Limits & Mist: Provides a visual representation in the viewport of the camera's clipping 
distances and mist range, helping you diagnose objects that might be disappearing 
unexpectedly. 



 

5. Support & Contact 
●​ Get Support / Join the Community: Discord Server 

Thank you for using the This2That Suite Manager! We hope it enhances your Blender 
experience. 

 

https://discord.gg/exk6M8qgmG
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