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SHORTCUTS (OG and REMAPS): 
 

●​ CTRL+ . → Edit pivot mode (2.81+) 
●​ CTRL+ A → Freeze transforms 
●​ CTRL+Right click → Lasso select 
●​ CTRL+(Numpad +/-) → Select More / Less → remap to CTRL+MouseWheelUp & Down 
●​ CTRL+J → Join (attach) 
●​ CTRL+B → Bevel 
●​ CTRL+B,V → Bevel vertices 
●​ CTRL+X → Dissolve selection 
●​ CTRL+0,1,2,3… → Subdivision levels 
●​ /,ç → Local mode (isolate) → Remap to ALT+Q for left-hand convenience 
●​ M → Merge menu (weld) 
●​ ALT+N (face selection) → Flip normals 
●​ ALT+D → Instance (linked) duplicate object 
●​ ALT+E → Extrude menu 
●​ ALT+J → Convert tris to quads 
●​ ALT+Middle click → Center view on mouse cursor 
●​ ALT+S → Push/pull along normal 
●​ ALT+Z → Enable x-ray mode 
●​ SHIFT+A → Add mesh 
●​ SHIFT+D → Duplicate object 
●​ SHIFT+G → Select Similar 
●​ SHIFT+S → Snap menu 
●​ SHIFT+R → Repeat last action 
●​ SHIFT+Z → Wireframe mode 
●​ SHIFT+RMB → Move 3D cursor. In keymap preferences, change orientation from “view” 

to “object”. 
●​ NUMPAD . → Frame selected (works in outliner too!) 
●​ INICIO → Frame all objects 
●​ A → Select all 
●​ ALT+A or AA → Deselect all 
●​ D → DECALmachine 
●​ G → Move 
●​ GG → Slide 
●​ GG, C → Slide outwards (clamp) 
●​ E → Extrude 
●​ I → Inset 
●​ F → Fill, create face 
●​ L → Select Linked (double click in Maya, element selection in Max) 
●​ K → Knife (cut) 
●​ P → Separate (Detach)  
●​ J → Connect vertices 
●​ X → Delete 
●​ Y → MESHmachine (remap) 
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●​ Y → Split (detach inside object) 
●​ Z → Render type (pie menu) 
●​ . → Pivot point (pie menu) 
●​ Remap Select linked to LMB double click (in Mesh and UV categories), as well as 

leaving the default “L” key. 
●​ 2 → Remap to “Display As”, in the object properties tab. Useful for booleans. 
●​ F1 → Remap to Search Menu 
●​ F3 → Remap to Wireframe toggle 
●​ F4 → Remap to Wireframe on shaded toggle 
●​ F5 → Remap to Face Orientation. 
●​ W → Select tool → Remove “Cycle” option so it stays in the same toggle. 
●​ F → Select and move island (UV Editor)  
●​ ALT+Mousewheel Up or Down → Frame offset (REMOVE) 

 
+----cursor parking lot----+ 
|​ ​ ​ ​ ​ ​ | 
|​ ​ ​ ​          ​ | 
+----------------------------------+ 
 
MY BLENDER VIDEO TUTORIAL: 
Weapon development in Blender 
 
PLUG-INS 
 
Extensions (just hit install from menu) 
Orient and origin to selected 
BoolTool 
Extra Mesh Objects 
Extra Curve Objects 
LoopTools 
UV Toolkit 
Inset straight skeleton 
HDR Rotation 
F2 
Scatter Objects 
  
Older: 
NodeWrangler  
Edit Mesh Tools  

 
Blender 2.8+ guide for 3D artists                                                                                                    Alejandro Medina 
 

https://www.artstation.com/learning/series/QRq/weapon-development-in-blender
https://extensions.blender.org/add-ons/orient-and-origin-to-selected/
https://extensions.blender.org/add-ons/bool-tool/
https://extensions.blender.org/add-ons/looptools/
https://extensions.blender.org/add-ons/uv-toolkit/
https://docs.blender.org/manual/en/dev/addons/node/node_wrangler.html
https://docs.blender.org/manual/en/dev/addons/mesh/edit_mesh_tools.html
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Modifier Tools  
Mesh Tools  
Material Utilities  
Align Tools 
Copy Attributes 
 
Free 
Maxivz’s Interactive Tools 
https://github.com/maxivz/interactivetoolsblender 
EdgeFlow 
https://github.com/BenjaminSauder/EdgeFlow 
TexTools 
https://github.com/SavMartin/TexTools-Blender 
Simple Lattice  
https://github.com/BenjaminSauder/SimpleLattice 
YAVNE (Custom Normals Tool) - DEPRECATED 
https://github.com/fedackb/yavne 
Texel Density Checker 
https://gumroad.com/l/CEIOR 
Bevel after boolean 
https://blenderartists.org/t/wip-bevel-after-boolean/693072 
Embark tools (batch exporter) 
https://github.com/EmbarkStudios/blender-tools/releases 
UV Squares (align shells) 
https://github.com/Radivarig/UvSquares 
Script to Button 
https://github.com/RivinHD/ScriptToButton 
Screencast Keys 
https://github.com/nutti/Screencast-Keys/releases/ 
UV Highlight (location: UV viewer → N panel → View → Display → UV Highlight) 
https://github.com/BenjaminSauder/uv_highlight 
Visibility handler https://3dbystedt.gumroad.com/l/visibility_handler 
 
Premium 
UV Packmaster 
https://gumroad.com/l/uvpackmaster2 
UV Toolkit 2.0 (Alexander Belyakov) - OFFLINE DUE TO SANCTIONS, GET EXTENSION 
INSTEAD 
https://gumroad.com/l/tslqD 
PME (Pie Menu Editor) 
https://blendermarket.com/products/pie-menu-editor 
MESHmachine 
https://machin3.io/MESHmachine/ 
DECALmachine 
https://machin3.io/DECALmachine/ 
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https://docs.blender.org/manual/en/dev/addons/interface/modifier_tools.html
https://blender-addons.org/mesh-tools-addon/
https://docs.blender.org/manual/en/dev/addons/materials/material_utils.html
https://docs.blender.org/manual/en/latest/addons/object/align_tools.html
https://docs.blender.org/manual/en/2.90/addons/interface/copy_attributes.html
https://github.com/maxivz/interactivetoolsblender
https://github.com/BenjaminSauder/EdgeFlow
https://github.com/SavMartin/TexTools-Blender
https://github.com/BenjaminSauder/SimpleLattice
https://github.com/fedackb/yavne
https://gumroad.com/l/CEIOR
https://blenderartists.org/t/wip-bevel-after-boolean/693072
https://github.com/EmbarkStudios/blender-tools/releases
https://github.com/Radivarig/UvSquares
https://github.com/RivinHD/ScriptToButton
https://github.com/nutti/Screencast-Keys/releases/
https://github.com/BenjaminSauder/uv_highlight
https://3dbystedt.gumroad.com/l/visibility_handler
https://gumroad.com/l/uvpackmaster2
https://gumroad.com/l/tslqD
https://blendermarket.com/products/pie-menu-editor
https://machin3.io/MESHmachine/
https://machin3.io/DECALmachine/
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RizomUV Bridge 
https://github.com/MattAshpole/BlenderRizomUVBridge/releases 
https://gumroad.com/l/DTJiP 

 
 
QUICK FAVORITES 
Commonly used tools to keep on the quick favorites tab (Q). 
 
Object Mode 

●​ Wireframe 
●​ Quick Origin (Maxivz plugin) 
●​ Show Overlays 
●​ Cavity 
●​ Face Orientation 
●​ Show Object Location (toggle gizmo) 
●​ Toggle Local View (Isolate Object) 
●​ Import 
●​ Export 

 

 
 
Edit Mode 

●​ Wireframe 
●​ Display Seams 
●​ Quick Origin (Maxivz plugin) 
●​ Coplanar (from Select Similar) 
●​ Checker Deselect 
●​ GStretch (from LoopTools addon) 
●​ Select Boundary Loop 
●​ Clean Up 
●​ Edge Loops 
●​ Edge Rings 
●​ Face Orientation 
●​ Show Object Location (togle gizmo) 
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●​ Faces by sides (select ngons) 
●​ Display Split Normals 
●​ Set from Faces (reset normals) 
●​ Recalculate Outside (reset flipped faces) 
●​ Origin to selected (quick origin alternative)2 
●​ Display Sharp 
●​ Display Seams 
●​ Auto Merge Vertices 

 

 
 
HOW-TO 
Useful tips and tricks 
 
Select all the N-gons 
(Edit Mode) Select → Select All By Trait → Faces by sides 
 
Create locator in object’s pivot 
SHIFT+S: Set 3D Cursor to Active (3) → SHIFT+A: Create empty 
 
Collapse windows 
Click RIGHT CORNER (or the closest corner to the next window) and drag to the next window. A 
small arrow will appear if the windows are going to merge. 
 
Open new window in different screen 
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Window → New main window 
 
Fix camera clipping 
N panel → View → Clip start → reduce value 
 
Copy and paste modifiers 
You cannot use the modifier panel to apply a modifier to multiple objects, it only applies it to the 
one selected last. However, you can use Ctrl + L (link) to copy the modifier on one mesh to all 
the other selected ones. You select the object(s) to apply the modifier to then the one that has 
the modifier (active object). 
 
(Shader editor) Add a normal map 
Create NormalMap node and plug into shader. Set the image color space to non color. 

 
 
(Shader editor) Add an opacity map 
Plug map into “alpha” node in Principled BDSF output. Then, go to Material page → Settings → 
Blend mode → Alpha clip 

 
 
Navigate 3D space more comfortably 
In Preferences → Navigation check Auto Depth & Zoom to Mouse Position 
 
“Select every other” is called “Checker deselect” and it works in reverse. 
 
Alternative: Select every other element (pattern select) 
Just click on the 2 first elements to establish the pattern and then hold CTRL+SHIFT+ "+" to add 
and "-" to remove elements.  
 
Select every other, or every X others (Select Next Active): 
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Select the 2 first elements (they have to be inside a loop or it won’t work) and then press “CTRL 
+ SHIFT + NUMPAD+” 
 
Use the keyboard to transform/rotate/scale in 2 axis at the same time 
Use SHIFT + the axis normal to the 2 ones you wanna transform in. To transform in the XY axis, 
press SHIFT+Z. 
 
Easily create splines 
Duplicate an edge from a mesh, go to (object mode): Object→ convert to → spline from mesh 
and now we can assign a shape for the spline.We can also create it from scratch by extuding 
vertices. Careful with mirror modifiers on splines, they might crash. 
 
Better splines 
Splines are missing many modeling tools, so I usually just stick to regular mesh edges. To give 
them “volume” I apply a Skin modifier, then select all verts and adjust the thickness with the X 
and Y values on the N panel. Then, to make it round, I apply a subdiv modifier. 
 
Slice a straight plane 
Don’t use the bisect tool. The knife tool also does it, and with angle constraints: K (knife), C 
(angle constraint toggle), Z (cut through mesh). 
 
Join meshes without losing UVs 
Just make sure they share the same UV Map name! 
 
Duplicate a material 
You can copy and paste material settings from the material tab. Note that you need to add a new 
material ID before you paste copied settings into. 

 
 
(Shader editor) Cut material nodes 
Drag RMB + CTRL and cut the node links. 
 
(Shader editor) Make a texture tile 
Inside the image node, select “repeat” instead of “clip”. 
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Transform subobjects in a different, custom orientation 
Use the command “create orientation” or this button in the axis menu while selecting a face with 
the orientation you want. 

 
 
Swap interface windows 
Same procedure as collapsing windows (drag from the corner) but holding CTRL. 
 
Add items to Shading Pie Menu (Z) 
There’s a checkbox for this in Preferences → Keymap. 
 
(Shader editor) Add custom HDRIs 
(Activate the NodeWrangler default addon first). Select the “World” option above the shading 
menu. Select the “Background” node, hit CTRL+T and then click “Open” inside the Environment 
Texture node and open an HDRI. You can use a mix shader with another background node as a 
solid color below, the main one on top and, as “fac”, use “light path” node and “is camera ray” 
option. Good place to get them is: 
https://hdrihaven.com/hdris/ 
 
Export preferences and scripts to another computer 
Preference files are located on User/appdata/roaming/blender foundation 
A quick way to open this folder is writing %appdata% on the windows start menu. 
 
Applying any change to all selected objects instead of only the active one 
Just press ALT and accept, depending on the selection mode (ALT+Click for toggles, ALT+Enter 
for numerical values, etc) 
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Isolate selected faces 
Select faces and: 
SHIFT + H → Hide everything not selected 
ALT + H → Unhide everything 
 
Alternative: select faces, CTRL+I to select inverse, then H to hide. 
 
Delete unused materials from scene 
On the top of the outliner there’s a dropdown list. Choose “blender file” instead of “view layer” 
and then go to materials and delete them. 

 
 
Load materials into another scene 
Go to File → Append and load another scene with the original materials, then choose exactly 
what you want to import. 
 
Display scene polycounts 
Overlays button → Statistics.  
It does not take modifiers into account so to know the real polycount you might have to collapse, 
view and and then CTRL+Z. 
 
Target Weld (AutoMerge) 
This isn’t a tool but a toggle called Auto Merge. When active, moving a vertex very close (within 
a threshold) or on top of another one, they will merge. Put on Quick Favorites. Set the value very 
very small or you will merge random small stuff.  
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Simulate physics 
Go to Physics tab and add “Rigid Body” to objects. Set receptacle or floor to “Passive”, the rest 
to “Active”. Set weight. shape and Margin. TIP: If the objects are too small, try scaling them up 
so units work correctly. 

 
 
Get simulated meshes from animation 
Search bar → Convert to → Mesh 
or 
Just export them in FBX and reimport  
 
Preserve UVs for 3D shapes 
Blender preserves UVs when sliding: G, G, ALT. Now (in 2.9+) there’s a new method:   N panel 
→ Tool → Options and toggle “Correct Face Attributes”. Don’t forget to also check “Keep 
connected”. If you DO want to stretch the UV islands sometimes, turn off “Correct Face 
Attributes”. 
 
Hide parent object and children at the same time 
Hold SHIFT while clicking on the eye icon 
 
Make quad spheres completely spherical 
Use the cast modifier on sphere mode, on top of the quad sphere 
Alternative: collapse subdiv and then search and apply command “To Sphere” 
 
Extrude a border with same offset (ideal for floaters) 
(Edit Mesh Tools Plugin) Select edges → CTRL+E (edge edit tab) → Offset edges → Extrude 

 
Blender 2.8+ guide for 3D artists                                                                                                    Alejandro Medina 
 



 
Blender 2.8+ guide for 3D artists                                                                                                    Alejandro Medina 

 
 
Create semicircle from edge 
(Edit Mesh Tools Plugin) Select edges → CTRL+E (edge edit tab) → Roundify edge 

 
Alternative: just bevel the sides until they touch and then weld the middle point. 
 
Batch rename tool 
CTRL+F2 

 
 
Link (instance) modifier parameters 
Select the desired parameter to instance on the main modifier → RMB → Add Driver → Copy as 
New Driver → Paste driver on itself. Then, on the new objects, Link Modifiers and Link 
Animation Data. Downside: this can only link 1 parameter at a time, and the driver can only be 
modified from the original object, which will be used as a controller. 
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Break instances 
Object → Relations → Make Single User → Object & Data.  

 
Alternative: click on number displayed in the mesh tab, next to the object name. 
 
Toggle wireframe like in 3Ds Max 
Go to Preferences → Keymap → 3D View → Global → Add new, and add: 
“wm.context_toggle” in the main text and 
“space_data.overlay.show_wireframes” in the Context Attributes box. Map it to F4 like in Max.  
The same applies to the F3 wireframe key: Add new and write “view3d.toggle_shading” with 
type “Wireframe”. Remap Search Menu (wm.search_menu inside Window category) to F1, and 
disable the online manual key. 
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To enable Face Orientation in F5, write “wm.context_toggle” and 
“space_data.overlay.show_face_orientation” in the Window category. 
Alternatively, there are toggles for these options in the Maxivz tools plugin. 
 
Isolate a subobject selection 
Blender doesnt allow to isolate subobjects but there’s a nice workaround: Select Inverse with 
CTRL+I and then H to hide the rest. Recover the hidden parts with ALT+H. 
 
Alternatively we can just use SHIFT H.  
 
Export OBJ to Zbrush for polish 
The correct configuration is 
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Slide an edge with the same slope as the next edges 
GG to slide, E to slide uniformly and F to choose the side it will follow 
 
Select faces by angle (3Ds Max) 
Select → Coplanar 
Alternative: Select → Linked flat faces 
 
Make diamond pattern from quad mesh 
Just use the decimate modifier in “Un-subdivide” mode 
 
Make an object translucent in viewport 
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Modify the alpha value in the color settings inside Object → Viewport Display → Color → Modify 
alpha value (Set the render mode to Object instead of Random!) 

 
 
Instancing objects or groups while keeping modifiers - Collection Instance 
We just have to create a collection instance. Select the desired object or group of objects and 
press CTRL+G to create a “group collection”, and set a name. Then, simply SHIFT+A to add a 
Collection Instance. 
 
Viewing backfaces easily while modelling 
-Preferences → Themes → 3D Viewport → Face orientation front → drag down the alpha value 
so it doesn’t show blue at all 
-Keep “face orientation” turned on in the Overlays panel, now the blue is transparent but the red 
is still there to check flipped faces 
 
Duplicated addons and matcaps when using Blender for Steam 
Blender’s configuration files can be found in two paths, appdata and the Steam folder: 
 
C:\Users\USERNAME\AppData\Roaming\Blender Foundation\Blender 
 
C:\Program Files (x86)\Steam\steamapps\common\Blender 
 
This can cause duplication issues. The solution is to leave the appdata folder as it is, and 
remove or rename these folders from the Steam files: 
 
scripts/addons  
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datafiles/studiolights/matcap 
 
Fix object orientation after applying rotation 
In edit mode, select a face you want to align it to. 
-Create Orientation (“+” button in Transform Orientations menu in top center of screen, can be 
added to Quick Favs) 
-Go back to Object Mode 
-Options → Affect only Origins 
-”Align to transform orientation”: now Origin is properly oriented and can be zeroed 

 
Alternative: with the “Orient to Selected” addon, just go to local axis mode, select the face we 
want and hit the “Orient to Selected” button. 
 
Find mesh errors 
Select → Select All by Trait → Non-manifold 
We can uncheck “boundaries” since those are usually correct. 
 
Control bevel width precisely 
Use “Width Type: Percent” and then use edge loops on the sides to control how the bevel is 
wider towards the back and narrower towards the front. 
 
Save a new startup file 
Simply click on the File dropdown, hover over “Defaults” and click Save Startup File, or use the 
hotkey Ctrl+U. This will save the entire scene as the default startup file – every mesh, object, 
texture, setting, UI layout, everything.  
 
See flipped UVs at a glace 
Activate the vanilla plugin “Magic UV” and then in the plugin options, check “UV Inspection” and 
“Flipped”. 
 
Fix UVToolkit Checkers not appearing on some meshes 
It’s the Viewport Display option. Solid and Textured are 2 different things, so sometimes while 
working with booleans it becomes solid. Just set it back to textured. 
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Flip a normal map’s green channel (Y) 
We could use a combination of Separate RGB, Invert and Combine RGB, but it’s much easier to 
just add a RGB Curves node after the normal map and invert the colors there! 
 
Change default meshes size 
They depend on the file grid size. Modify the grid scale, and default mesh size will vary too! 
Example: with grid set to 1m squares, a default cube will be 1x1x1m. 
 
Modifier List Addon 
-We can add default modifier values: it saves a TON of time 
-Favorite modifiers on buttons 
-When updating the modifier, do not uninstall the previous version, this way you will keep the 
favorites configuration 
 
Materials order getting jumbled in LODs 
-Sometimes exported meshes have wrong material order in the LODs because of the vertex 
number discrepancy. To fix this: 
-Just select all faces from all LODs at the same time and go Mesh → Sort Elements → 
Materials 
 

WORKFLOWS 
 
Ron Frölich’s smoothing method (similar to dynamesh+polish) 
-Create object and booleans 
-Freeze modifiers (or duplicate base object and apply modifiers) 
-Set proper sharp edges (they will drive face sets) 
-Sculpt mode 
-Face sets → initialize face sets → from sharp edges 
-Remesh (top right menu) 
-Now we could use the "mesh filter" brush in "smooth" mode (equivalent to zbrush's polish), but 
it presents problems: 
   -shading is wrong: noisy artifacts in borders 
   -it only allows for a single bevel width in the whole piece 
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-Solution: mask brush → turn on face sets boundary → paint over everything. It will mask 
everything but the borders between face sets 
-Invert mask (CTRL+I) 
-Face sets → face set from masked → will group every border in one face set 
-Clear mask 
-To be able to set different bevel weights in different places: Initialize face sets → by face set 
boundaries 
-"Edit face set tool" brush → grow face set mode 
-Optional step: face sets → relax face sets (in theory it fixes the stepping created by voxels, but 
breaks corners, be careful) 
-"Edit face set tool" brush → fair tangency mode → Click on the border set → bevels are created 

 
 
NOTES:  
Problem: there are very detailed/small bevels connected to a larger bevel & the fair tangency 
mode CANNOT be masked 
Solution: cut the borders of the smaller face sets using new face sets and then initialize face 
sets by loose parts to make them independent. Now they can be grown and shrunk 
independently. They should be joined back into 1 single set before applying the fair tangency 
(SHIFT+W, select a set and hold CTRL and hover over the other set to combine them). 
 
This method, like zbrush, requires curved surfaces to have many divisions. One way to 
control every bevel modifier in the scene is creating a custom driver: 
-Scene: custom properties → DRIVERS → Create our own 
-RMB → copy as new driver. now you have it for the duration of your session. Do this every time 
we start the scene. 
-Then in the bevel modifiers for each boolean piece, just "paste driver" 
-We can edit the driver's expression to add a x2 or x4 in a specific modifier that we want bigger 
or smaller 
 
Ron’s smoothing method 2 (faster) 
-Make base mesh and booleans 
-Save a backup of the original mesh with the live booleans 
-Remesh modifier in Sharp mode (crisp edges) 
-Apply modifier stack 
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-Initialize face sets by normals (threshold is locked to 0.5, only changeable if you change 
shortcut, it's a bug!) 
-Set a shortcut for the Grow Mask command and disable auto iteration count! it makes masks 
grow in smaller steps 
-Mask brush without face set borders to mask everything, then unmask the small bevels where 
we won’t do fair tangency 
-Invert Mask → Face Set from Mask → Fair Tangency 
-Do a new Remesh modifier in Sharp mode (with more iterations), this one for the smaller bevels 
-Mesh filter Brush in Smooth mode - using this for the smaller bevels gives fewer artifacts 
-Decimate modifier to take care of most of the remaining inaccuracies from the remesh (double 
vertices), and also make it manageable for Blender to work (less geometry) 
-Collapse the stack to bring back performance 
 
Ron's method 3 (less artifacts!) 
-Make mesh and booleans 
-Sharp remesh modifier (octree depth 8) 
-RMB → Apply visual geometry to mesh 
-Sculpt mode 
-Init face sets from mesh normals 
-Mask brush - Toggle face sets boundary 
-Paint whole mesh 
-Invert mask 
-Face set from masked 
-Initialize face sets by face set boundaries 
-Fair tangency only on big bevels 
-Sharp remesh with bigger octree depth (for the small bevels) 
-Init face sets - from mesh normals (it will ignore the big bevels now) 
-Mask again 
-Hide overlays to conserve face sets while seeing the shading better 
-Use smooth brush instead of smooth mesh filter! just turn off "front faces only" and use the 
"anchored" brush mode (drag from center, works radially) instead of the normal one, with a huge 
size to cover the whole mesh. Apparently the result from this is way fewer artifacts than using 
the smooth filter. 
 
Fixing the Init Face Sets Normals Threshold 
-Go to preferences → Keymap → 3D View → Sculpt → Sculpt (Global) → Add New 
-Make a new entry with “sculpt.face_sets_init” 
-In “mode” select “Face Sets from Mesh Normals” 
-Make copies of these with different thresholds and bind them to the final numbers in the 
keyboard (5,6,7…) 

 
-This way we can effectively modify the threshold property 
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Boolean Workflows (from the Michael Kinsey artstation tutorial): 
 
Remesh 

 
Booleans → Remesh modifier (dynamesh) with octree depth (8) → Smooth modifier (polish) 
factor of 2, very high repeats (20) → Decimate → Triangulate, rid of ngons 
 
Bevels + Weighted Normals 

 
Subdivision (with auto support loops) 
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Booleans → Bevel with 2 segments and profile of 1 to create automatic support loops → 
Triangulate the ngons and then subd 
 
The Matthias’ Way (more control) 
Since the remesh modifier kills the vertex groups, we can duplicate the base object and then 
transfer them back using the Data Transfer modifier.  
 
FUTURE FEATURES 
Stuff I would like  
 
-(UV editor) See all UV shells in edit mode without needing to select all faces. 
-(UV editor) Double click in face select for island select in, instead of L key to select linked. → 
This can be remapped maybe? 
-(UV editor) Render inside of inverted UV islands in red. Change color when islands are stacked 
to more easily identify them. 
-(UV editor) Texel density picker and setter (integrated in blender). 
-(UV editor) Missing features: Cut, unfold, optimize/relax. We need more ways to edit existing 
UV shells without re-unwrapping, because usually textures are already done and we just need 
some small changes.  
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-(UV editor) Align features 
-(UV editor) A way to edit UV vertices without them being synced with actual vertices (which 
usually correspond to 2 or more UV vertices and cause mistakes). Right now we have to choose 
between seeing the whole mesh and editing UV vertices. 
 
-Double click in face select for linked select in, instead of L key → Can be remapped, but only 
works with the first object of the selection 
 
-Display split normals in object mode. 
 
-When exporting FBX, export selected objects by default when there are any currently selected. 
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