Pencil 0.4.4b TUTORIAL © Edyta Jurys 2014                                                                    www.edytajurys.blogspot.com

Pencil 0.4.4b

animacje 2D

TUTORIAL

 Utwory, autorstwa Edyty Jurys są dostępne na licencji Creative Commons Uznanie autorstwa-Na tych samych warunkach 3.0 Unported. Uprzejmie proszę, aby w przypadku cytowania moich wpisów wyraźnie podawać źródło: "Tekst pochodzi z bloga Echo ho-ho! Blog nauczyciela terapeuty znajdującego się pod adresem www.edytajurys.blogspot.com".  

Pencil 0.4.4b został opracowany w systemie Mac OS 10.4 przy użyciu Qt, a następnie przeniesiony na systemy Linux i Windows. Stworzony przez Patricka Corrieri i rozbudowany przez Pascala Naidon (który wprowadził nowe narzędzia i funkcje) Pencil 0.4.4b jest programem do tworzenia animacji, a jego nazwa może się zmienić w przyszłości. To projekt na wczesnym etapie rozwoju należący do grupy oprogramowania Open Source.

Pencil nie jest skomplikowany i można go polubić. Mimo, iż menu jest w języku angielskim, każdy kto miał do czynienia z programami graficznymi szybko się w nim odnajdzie.

Aby stworzyć najprostszą animację należy zapoznać się z podstawowymi funkcjami i narzędziami. Zatem rozpoczynamy zwiedzanie :)

Opracowała

 Edyta Jurys

SPIS TREŚCI

>> PODSTAWY PRACY Z PROGRAMEM

DOWNLOAD & INSTALACJA

MENU

TOOLS

DISPLAY

TIME LINE

COLOURS

>> TWORZENIE ANIMACJI 

ANIMACJA W SZKOCOWNIKU

PRZYGOTOWANIE TŁA

ŚCIEŻKA DŹWIĘKOWA

PODSTAWY PRACY Z PROGRAMEM

DOWNLOAD & INSTALACJA

Pencil 0.4.4b pobierzemy ze strony Pencil Tradicional Software. Program możemy zainstalować w środowiskach Mac, Linux, Windows, jednak na chwilę obecną w tym ostatnim niektóre funkcje nie są jeszcze dostępne (możliwy jest eksport ramek i zapis pliku Flash).

Po zainstalowaniu i uruchomieniu program jest gotowy do pracy. Poniżej zamieszczono kilka wskazówek, jak pracować w Pencil 0.4.4b.

Powrót do: Spis treści

Menu - File

W Menu File otwieramy nowe pliki, wcześniej zapisane na dysku, zapisujemy pliki oraz importujemy i eksportujemy. Jak juz wspomniano w SO Windows dostępne jest eksportownie do pliku Flash oraz zapisywanie serii obrazów .jpg. Możemy zaimportować serię obrazów wcześniej wykonanych w innym programie, które zostaną umieszczone w osobnych klatkach.

Powrót do: Spis treści

Menu - Edit

Menu Edit wspomaga edycję pliku. Tutaj można kopiować obraz, wklejać, zaznaczyć cały obraz. Wprowadzone do projektu zmiany można cofnąć, można też ponowić już cofnięte. Tutaj znajduje się opcja importowania obrazu z innego pliku oraz dźwięku. Na samym dole ramki znajdziemy opcje ogólne dla Pencil 0.4.4b opisane poniżej pod nazwą Edit-Preferences.

Edit - Preferences 

Powrót do: Spis treści

Menu - Layer

Dzięki Menu Layer utworzymy nową warstwę. Ich rodzaje opisano poniżej. Warto pamiętać, iż nowe warstwy pozwalają nam tworzyć opcje w Time Line.
Praca w warstwach wygląda następująco:

Powrót do: Spis treści

Menu - Help

Menu Help odeśle nas do odpowiedniej strony web.

Powrót do: Spis treści

Menu – Windows

Menu Windows pozwala na pracę z zadokowanymi (nieruchomymi) oknami narzędzi i finkcji albo z “pływającymi”. Jeżeli zaznaczymy opcję Death All Palettes będziemy mogli owe ramki przesuwać w dowolne miejsce w oknie programu.

Powrót do: Spis treści

Tools

Narzędzia w Pencil 0.4.4b są typowe dla każdego graficznego programu (np.Paint, Corel, PhotoShope). Znajdziemy tu ołówek, pióro, “wielolinię”, gumkę, wypełnienie, pipetę, zaznaczenie danego obszaru oraz strzałkę wybierającą i zaznaczającą obiekt. Inne to Clear, Move/Zoom canvas i Modify curve. Poniżej zamieszczono zrzut z wyglądem narzędzi oraz linki do przykładowego ich wykorzystania.

Linkownia - pokazy w You Tube:

Powrót do: Spis treści

Tools options

Opcje narzędzi pozwalają ustawić grubość i miękkość (smużenie) narzędzia. Mamy tu podgląd aktualnie używanego koloru. Inne opcje opisano w ramkach obok obrazu.

Powrót do: Spis treści

Display 

Funkcje Display związane są z obrazem, który możemy przerzucać w poziomie. Przy włączonej opcji Invisible odpowiednia funkcja pokazuje niewidzialne linie. Inna pokazuje tylko “wyjściowe”.

Powrót do: Spis treści

Time line - Layers

Pracę w warstwach częściowo opisano przy okazji Menu Layer. W Time Line Layers tworzymy nowe warstwy, nadajemy im, nazwy, przełączamy się miedzy nimi oraz mamy możliwość ukrywania nie potrzebnych w danej chwili.

Powrót do: Spis treści

Time line – Keys & Onion skin

Keys to “klucze do animacji” czyli poszczególne klatki ruchu. Dodajemy nowe przy pomocy plusa (+) oraz możemy usunąć niepotrzebne przy pomocy minusa (-). Dzięki Onion skin zobaczymy poprzednią klatkę, dzięki której łatwiej utworzymy nową symulującą ruch. Przy dużej ilości klatek przyda się też funkcja pokaż następną klatkę.

Powrót do: Spis treści

Time line – Przyciski akcji

Przyciski akcji pozwalają wykonać próbę animacji. Jeżeli spojrzymy wyżej, pod Keys, przez wszystkie warstwy przechodzi czerwony pasek. Chwytając go myszką i przesuwając przez kolejne klatki również będziemy w stanie przeprowadzić test wykonanego projektu.

Powrót do: Spis treści

Colours

Paletę kolorów pokaże/ukryje przycisk znajdujący się w ramce Options. Poza widoczną podstawową paletą można dodać (+) własne kolory. Jeżeli chcemy jednorazowo na chwilę zmienić odcień, umożliwiają to suwaki Red, Green, Blue, Alpha.

Powrót do: Spis treści

TWORZENIE ANIMACJI

Animacja w szkicowniku

  1. File/New
  2. Wybierz narzędzie do szkocowania – narysuj schemat animacji w warstwie Bitmap layer
  3. Zaznacz Schow previus frame i Show next frame
  4. Wybierz Keys i kliknij + (dodaj klatkę)
  5. Wybierz narzędzie do rysowania – rysuj/maluj w tej samej warstwie
  6. Powtórz czynności z pkt. 4. i 5. aż uznasz, że animacja jest ukończona
  7. Sprawdź projekt używając przycisków akcji (ewentualnie popraw)
  8. Zapisz animację File/Save albo File/Export/…. (wybieramy, co nam pasuje)

Linkownia:

Pokaz tworzenia prostej animacji 2D w szkicowniku Pencil 0.4.4b w You Tube

Przygotowanie tła

Ścieżka dźwiękowa

Powrót do: Spis treści

Koszalin 2014