
 

Awesome Table - Documentation 
 
 

This documentation is OUTDATED 
and not updated any more. 
 
Please find the up-to-date Awesome Table 
documentation here : 
https://support.awesome-table.com/

hc/en-us 
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Awesome Table can be used to create a table from a spreadsheet and add interactive controls 
to manipulate the data it displays. 
 
 

Example: Using the Awesome Table gadget to display a list of files 
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Issue impacting Awesome Table + new Google Sheets + formulas 

Formulas aren't automatically recalculated by Google in the new version of Google Sheets. 
All cells containing formulas might appear as empty (thus if you have only formulas in your 
Sheet not real data, it will appear to Awesome Table as empty and you'll see the error 
message "no data to display"). 
 
Current fix: keep the Sheet open in a web browser, it will force Google to recalculate all 
formulas regularly and will prevent the cells from appearing empty. 
For now on, please try to not use formulas in Sheets using Awesome Table. 
 
Google is working on a fix. - Click here to be notified once the issue will be fixed 

 
Follow those instructions to use this gadget in your Google Site 
>> or watch this video tutorial  

1 - Create or open an existing Google Sheet 
 

 
 

https://docs.google.com/forms/d/1P5SDSTa2UPMX-24LTsq_ZHPHJx_F8p5zyQOSgfSE47M/viewform
https://www.youtube.com/watch?v=SsmXEFtxwr0


1.1 Fill the Sheet with the data that will be displayed by Awesome Table 
 

 
 

1.2 Share the spreadsheet 
Use the standard sharing settings available in Google Spreadsheet to share it to specific people, 
or everyone in a domain or everyone in the world. People won’t be able to use the gadget if they 
don’t have viewer permission on the data it displays (ie the spreadsheet). 
 

 

2 - Configure the spreadsheet 

2.1 - The first row should contain the column headers 
Those column headers will be reused in the gadget. 



 

2.2 - Configure the filters on the second row 
Fill the second row with the filters you want for the gadget 

 
 

2.3 Available filters 
●​ StringFilter 
●​ NumberRangeFilter 
●​ CategoryFilter  
●​ DateFilter 
●​ csvFilter​

 
And also: 

●​ NoFilter 
●​ Hidden (which can be also used as additional attribute, i.e. CategoryFilter - Hidden) 

 



StringFilter can be used to filter columns containing free text 

 

Note: for now on, this filter cares about accents (you must type the accent in the filter to 
show results that have accented characters). If you wish it could be smarter than that, 
please star this issue. 

 
 can be used to filter columns containing numbers - warning: actually a range filter is 
automatically created for all columns containing numbers. If you don’t want the filter to be 
displayed, indicate NoFilter on that column. Contrary to other filters, you don’t have to write 
“NumberRangeFilter” to display that filter (as it is automatically created). 

 

 
CategoryFilter can be used to filter columns containing a list of similar values (choose from a 
list) 

 
 

DateFilter can be used to filter columns containing dates (several date formats are available, 
you can choose the format in the gadget parameters) 

 
 

https://code.google.com/p/google-visualization-api-issues/issues/detail?id=1615


 
 
csvFilter can be used to filter columns containing comma separated values - eg a list of skills 

 
 
Beta - Labels inside filters 
By default, you should get something like this: 

 
 
It is also possible to include the labels inside each filter to get something like this (example): 

 
 
This might become the standard way to display filters in the future but for now on, to get the 
same result, open Awesome Table settings and add the keyword “insideFilter” into the “caption” 
field. 

https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/people-directory


 
 

3 - Add the gadget to your Google Site 

3.1 - Open the Google Site Page where you want to add the gadget 

3.2 Edit the page and click on menu Insert > More gadgets 
 

 
 

3.3 Look for the Awesome Table gadget in the featured section of the gallery 
 



 
 

 

4 - Configure the Gadget 

4.1 Go to the Sheet Created in the Step 1 and copy the Sheet URL 

 

4.2 Paste Sheet URL in the corresponding Box 
 



 

4.3 Do the same for sheet Name & data range 

 
 
Range: Take a look to your Spreadsheet and see on which column ends the data. In case last 
column is D you should use A1:D in case that last column with data is F use A1:F 
 

 



4.4 Save the gadget 
Note: You don’t have to configure the height. It is automatically recalculated depending on the 
data to display. If you include a scrollbar it will mess with the automatic resizing. So don’t check 
the option “Include a scrollbar” (keep in mind that after saving changes you have to reload the 
page to get this automatic resizing).  
 

 
 

 
 



5 - Advanced tips 

5.1 HTML in cells 
You can put HTML tags in the cells of your spreadsheet to improve the look of your text and 
display hyperlinks and images. 
 
For example, if you put this HTML tag in a cell of your spreadsheet, it will display an image: 
<img src="http://trinityhotelsrlimbe.com/trinity/images/stories/appartments/appartment2.jpg" 
width="300px"/> 
 

 
 
In the same way, to display clickable links, you can put anchor tags in cells of your sheet. 
<a href="URL_OF_YOU_LINK" target="_blank">TEXT TO DISPLAY</a> 
<a href="http://www.google.com/" target="_blank">Search</a> 
<a href="mailto:someone@example.com?Subject=Hello%20again" target="_blank">@</a> 

5.2 Querying specific rows of the spreadsheet 
It is possible to use the Google Visualization API Query Language to show only a specific subset 
of your data in the table. It means people won’t be able to see some information from the table 
even if the information is stored in your spreadsheet. 
 
For example, if I have a column in my spreadsheet filled with document types, I can filter on a 
specific type (like pdf) and thus only pdf files will be visible through the Awesome Table gadget: 
select * where D = 'pdf' 
 
To do that, there’s a specific field in the configuration area of the gadget, in which you can enter 
your query: 

https://developers.google.com/chart/interactive/docs/querylanguage


 
 
This lets you filter by text, dates, numbers,... 
 
Here are a few examples of queries: 

select * where dayOfWeek(H) = 2 
select * where L >= 50 
select * where dateDiff(H, now()) > 0 
select * where dateDiff(H, now()) > 0 or H is null 
select * where I contains 'Script' 
select * where dateDiff(H, now()) + 30 > 0 
select L order by A desc limit 20 
select L where dateDiff(A, now()) + 30 > 0 order by A desc 
select L where (month(now()) = month(A)) AND (year(now()) = year(A)) order by A desc 

 

5.3 Connect a Google Form to the gadget 
You can easily use this gadget with a Google Form. Create your form, post some responses and 
add a new row in the spreadsheet between the headers and the first response (to indicate which 
filters you want to use). Example 
And you can even use Awesome Table to create an Advanced Summary of Responses for your 
form. Example 

5.4 Let users update your data / add the ability to read & write data 
Google Forms are very useful to let people submitted new data in a spreadsheet but you can 
also use a form to let people update previous entries. Try a live example. 
 

https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/using-a-form
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/advanced-summary-of-responses
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/using-a-form


 
 

 
All you need for that is to store the unique URL letting you edit each form response. And you can 
grab all those unique URLs with a little script. 



 
 
1- Open the spreadsheet linked to your form and add a column to contain the edit link 

 
 
2- In the spreadsheet click on the menu: Tools > Script Editor 
3- Past the following code into the script editor 

var formURL = 
'https://docs.google.com/forms/d/18AuVZ2WTdox-x53DVM31mBzNL6QQ6SpO5JGJO0Et1cg/viewform'; 
var sheetName = 'Form Responses'; 
var columnIndex = 8; 
 
function getEditResponseUrls(){ 
  var sheet = SpreadsheetApp.getActiveSpreadsheet().getSheetByName(sheetName); 
  var data = sheet.getDataRange().getValues(); 
  var form = FormApp.openByUrl(formURL); 
  for(var i = 2; i < data.length; i++) { 
    if(data[i][0] != '' && data[i][columnIndex-1] == '') { 
      var timestamp = data[i][0]; 
      var formSubmitted = form.getResponses(timestamp); 
      if(formSubmitted.length < 1) continue; 
      var editResponseUrl = formSubmitted[0].getEditResponseUrl(); 
      sheet.getRange(i+1, columnIndex).setValue(editResponseUrl); 
    } 
  } 
} 

 



3- Replace the first 3 rows of the script with your own parameters 
●​ formURL: your form URL 
●​ sheetName: the name of the sheet containing the form responses 
●​ columnIndex: the index of the column where you want to put the links to edit the form 

responses (eg: column H >> columnIndex = 8). It will not work if the column doesn’t have 
a header (“Update” in our example). 

 
4- Trigger the script through the menu Run 
A dialog will ask you permission to run the script. After that you should see the link to edit each 
form response in your spreadsheet. 
 
5- Automate the process for each new entry / form response 
You certainly don’t want to manually trigger the script every time a new entry is submitted. In the 
script editor, click on the menu Resources > Current project’s triggers and set up an automated 
trigger as follow: 

Done! Now people will be able to edit each data entry in your spreadsheet.  

5.5 Use row-level permissions (through Google Apps Script proxy) 
You can display specific rows of your Sheet, depending on the connected user, without sharing 
the Sheet. For example, if you are collecting usernames through a Google Form, you will be able 
to let users only see their own submissions. 
>> Learn all the possibilities to display conditional lines 

5.6 Add a sidebar 
You can choose a 2-columns layout to display the list of results on the left and the details of a 
result on the right. - Example 
 
Simply add the keyword “Sidebar” on the second row of your Sheet, in the column you want to 
display as a sidebar (same way you display filters like StringFilter). 
 

http://goo.gl/Hhz4h5
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/people-directory


 
 
There is also another way to display the sidebar. It’s a bit more complex to set up, but it loads 
faster if you have a lot of data in your Sheet and it provides direct (deep) linking feature. 
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/people-dir
ectory?q=camille.lambert@demo.com 
This opens an Awesome Table view with a sidebar and directly display in the sidebar the profile 
indicated in the URL. 
 
To get this feature, instead of adding the keyword “Sidebar” on the second row of your Sheet, 
add it in the Query field, among the parameters. The first column indicated in your “select” 
should contain the data you will use in your URLs for direct linking (eg. in my People Directory, 
column E contains email addresses, so I begin my select with “select E” and I’ll then be able to 
use this syntax page_url?q=email_address to display a specific profile). 

 
 

5.7 Use Google Maps 

https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/people-directory?q=camille.lambert@demo.com
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/people-directory?q=camille.lambert@demo.com


 
 
To display data from your spreadsheet as a maps in the Awesome Table gadget, you can switch 
the view from table to Maps in the parameters of the gadget. 
See this video for more information. 
 

 
 
You can use either addresses or latitude + longitude data (coordinates - Lat-Long pairs). But it's 
preferable to use the second option (coordinates) as the first one (addresses) takes a veeeery 
long time to load if you have a lot of entries to display. 
 
Only 2 columns should be displayed: the one with your addresses and the one with the info to 
display in the tooltip (if you are using latitude + longitude data, 3 columns should be displayed: 
latitude, longitude and tooltip). All other columns should be hidden. See 5.8 to learn how to hide 

http://www.youtube.com/watch?v=cQWaJqewXLw


the other columns. 
 

 
 
Best is to start with only two columns in your sheet, the first one with the addresses and the 
second one with the info to display in the tooltip. Then install the gadget to see if the map is 
correctly displayed. After that you can add other columns to setup your filters. 
Note that the map can display a maximum of 400 entries. 
 
If this map view isn’t suitable for you, you can try the geochart view instead. It creates a basic 
map and display markers of different colors and sizes. 
 

 
Contrary to the standard Maps view in which only 2 columns of your Sheet should be displayed, 
here you need 5 columns. 

https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/geochart


●​ Latitude 
●​ Longitude 
●​ Marker color 
●​ Marker size 
●​ Tooltip content 

 

 
You can make a copy of this sheet if you don’t want to start from scratch. 

5.8 Hide some columns 
You can use the keyword “Hidden” on the second row to hide some columns. If you want to 
display a filter but not the actual data in the table, you can use multiple keywords for the same 
column, eg: “CategoryFilter - Hidden”. 

5.9 Allow people to download the data displayed 
It is possible to display a button at the bottom of the table to download the filtered data as csv 
(meaning that the content of the csv will be different if the user select some filters). 
 

https://docs.google.com/spreadsheet/ccc?key=0AnxR7WfXrj7adGpzRFE3TVpZbk95WmdrUkluMktuNEE&usp=sharing#gid=0


 
 
To activate this feature, simply check the box in the gadget settings. 

 
 

5.10 Dependent category filters 
It is possible to link a category filter to another, for example to display a list of countries and a 
list of cities. When you select a specific country, only the related cities are displayed in the 
dependent filter. 



 
 
To do that, simply indicate inside parenthesis the Column Index of the subfilter / dependent 
filter. 

 
 

5.11 Link Analytics to the gadget 
If you want to track the number of clicks on a specific item in the Table, it’s possible! Useful if 
you display a list of files to download for example. 

Note: This has been updated to use the new tracking code from Google Analytics (linked to 
Universal Analytics) 

 
1.​ In the gadget settings make sure you specify your Google Analytics Tracking ID. 
2.​ In your spreadsheet, at some HTML to display links in the table, with a call to Analytics 

when a user clicks on a link​
<a href="URL-to-your-file" onclick="ga('send', 'pageview', 'URL-to-track');">Link Text</a>​
<a href="URL-to-your-file" onclick="_gaq.push(['_trackPageview', 'URL-to-track'])">Link 
Text</a>​
Where  

a.​ URL-to-your-file is the full web address of the file you want your viewers to 
download (e.g. a file uploaded to your site or in Google Drive) 

b.​ URL-to-track is the partial URL you want to appear recorded in Google Analytics: 
for example you want your viewers to download 
http://www.example.com/files/download.zip so make this URL-to-your-file and 
make URL-to-track /files/download.zip​
eg: <a href="http://www.example.com/files/download.zip" onclick="ga('send', 
'pageview', '/files/download.zip');">Link Text</a>​
<a href="http://www.example.com/files/download.zip" 

https://support.google.com/analytics/answer/2790010?hl=en


onclick="_gaq.push(['_trackPageview', '/files/download.zip'])">Link Text</a> 
 
Learn more on Steegle.com 
 

5.12 Use a custom CSS file 
If you don’t like the look of the gadget, you can make it look the way you want. 
In this page you will see some alternative looks and links to CSS files you can reuse. 
 

 
 

 

 

 

http://www.steegle.com/websites/google-sites-howtos/awesome-table-gadget
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/custom-css


6 - Examples 

6.1 Display a list of Drive files 

 
 
A combination of a script to list your Drive files in a spreadsheet + the Awesome Table gadget to 
display those files. 
Use this script http://goo.gl/cWjJka on your spreadsheet. 
>> Watch the video 
 

6.2 A list of flat for rent 

 
 

http://goo.gl/cWjJka
http://www.youtube.com/watch?v=7_YzhVn1Sy0


 

6.3 People Directory 

 
>> See example 

6.4 Google Maps 

 

https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/people-directory


 
>> Watch the video or >> See example 
 

6.5 Simple Gantt chart 

 
>> See example 
 

6.6 Cards view 

 
>> See example 

6.7 Advanced summary of responses for Google Forms 

https://www.youtube.com/watch?v=cQWaJqewXLw
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/google-maps
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/gantt-chart
https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/cards-view


 
 
>> See example 

https://sites.google.com/site/scriptsexamples/available-web-apps/awesome-tables/dashboard-for-google-form

	Issue impacting Awesome Table + new Google Sheets + formulas 
	1 - Create or open an existing Google Sheet 
	1.1 Fill the Sheet with the data that will be displayed by Awesome Table 
	1.2 Share the spreadsheet 

	2 - Configure the spreadsheet 
	2.1 - The first row should contain the column headers 
	2.2 - Configure the filters on the second row 
	2.3 Available filters 

	3 - Add the gadget to your Google Site 
	3.1 - Open the Google Site Page where you want to add the gadget 
	3.2 Edit the page and click on menu Insert > More gadgets 
	3.3 Look for the Awesome Table gadget in the featured section of the gallery 

	4 - Configure the Gadget 
	4.1 Go to the Sheet Created in the Step 1 and copy the Sheet URL 
	4.2 Paste Sheet URL in the corresponding Box 
	4.3 Do the same for sheet Name & data range 
	4.4 Save the gadget 

	5 - Advanced tips 
	5.1 HTML in cells 
	5.2 Querying specific rows of the spreadsheet 
	5.3 Connect a Google Form to the gadget 
	5.4 Let users update your data / add the ability to read & write data 
	5.5 Use row-level permissions (through Google Apps Script proxy) 
	5.6 Add a sidebar 
	5.7 Use Google Maps 
	5.8 Hide some columns 
	5.9 Allow people to download the data displayed 
	5.10 Dependent category filters 
	5.11 Link Analytics to the gadget 
	5.12 Use a custom CSS file 

	 
	 
	6 - Examples 
	6.1 Display a list of Drive files 
	6.2 A list of flat for rent 
	6.3 People Directory 
	6.4 Google Maps 
	6.5 Simple Gantt chart 
	6.6 Cards view 
	6.7 Advanced summary of responses for Google Forms 


