Step 1: Download and install IntelliJ IDEA
We will use the Community Version 2019.2.4.

Step 2: Start IntelliJ IDEA and import an existing repository

B wWelcome to Intelli) IDEA

IntelliJ IDEA

=+ Create New Project
¥ Import Project
= Open

|+ Check out from Version Control +

LI Configure ¥  GetHelp =

Select Check out from Version Control, select Git and enter something like the following:

Clone Repository

URL: https://github.com/kovzol/gecgebra.git ~ Test

Directory: |C:\Users‘\Kova’csanta'n\ldeaPrnjects\gengebra—discnvery—1'I!

Leg in to GitHub... ? Cancel

Note that the version you will download is not the official version of GeoGebra. It is an unofficial fork that
provides some additional features like automated discovery, real geometry comparison, partial Java 11 support
and some bugfixes, but maybe not completely up-to-date to the newest official version of GeoGebra.

Click on Clone. The cloning process will take several minutes. After then you will see something like this:

Cheekout From Version Control

9 You have checked out an Intelli) IDEA project file:
ChUsers\Kovacs ZoltandeaProjects\geogebra-discovery-114build . gradle

Would you like to open it?

Yes Mo

Select Yes. Then the following screen will show up:



m File Edit View Mavigate-Jlode Analyze Refactor Build Run Teools VCS Window Help geogebra-discovery-11 [...\geogebra-discovery-11] = ke

'3 geogebra-discovery-11 A |AddConfiguration...| » # T W Gt ¥ v O O K B Q

W 1:Project

& Build:  Sync - o —
s . iy
é S  geogebra-discovery-11:failed ot 2 2 m 21 < 755 s Run with --stacktrace option te get the stack trace. Run with --infe or --debug optior >
x| | S
» * Get more help at https://help.gradle.org

g
-§ e Deprecated Gradle features were used in this build, making it incompatible with Gradle
= Use "--warning-mode all' to show the indiwvidual deprecation warnings.
:;I See https://decs.gradle.org/5.4.1/userguide/command_line_interface.html#fsec:command_13

H g: version Control M Terminal - = g TODO () Event Log
] Git: master

That is, you get an error message. The reason is that Java 8 (that is installed on the system we are working
with in this tutorial) is no longer fully supported in the used fork of GeoGebra, namely, in its Gradle build
system. Therefore you need to download a more recent one. Oracle Java 11 SE JDK will be one working
option. It is available on Oracle’s web site, one may need to register to access to the Download area. After
installing it go to File > Project Structure... > Project Settings > Project > Project SDK > New...:

m Project Structure

— = Project name:
| geogehla—digcovely—'l'l

Project Settings

—

This SDK is default for all project modules.

Modules
. A module specific SDK can be configured for each of the modules as required.
Librari
fraries | Ga<No sDK> ~| | New.. Edit
Facets
. Project language level:
Artifacts This language level is default for all project modules.
Platform Settings A medule specific language level can be configured for each of the modules as required.
SDKs | 12 - Mo new language features =
Global Libraries
Project compiler output:
This path is used to store all project compilation results.
Problems o A directery corresponding to each module is created under this path.

This directory contains two subdirectories: Production and Test for production code and test sources, respectively.
A medule specific compiler output path can be configured for each of the modules as required.

| &= |

Select JDK and click on the freshly installed JDK:



Select Home Directory for JOK b4

+ Hide path

> jdk-11.0.5
jdk1.8.0_131
jrel.8.0_161
JetBrains

mcafee

d drop a file into th

Now click OK.

Then go to File > Settings... and type “Gradle” in the search field on the top-left, then change the Gradle JVM
to version “11”:

Settings X

O gradle Build, Execution, Deployment » Build Tools * Gradle For current project Reset

" Appearance & Behavior General settings

MNotifications

Gradle user home: |}

Keyina Owverride the default location where Gradle stores downloaded files, e.g. to tune anti-virus software on Windows
* Editor [] Generate *.iml files for modules imported from Gradle
Inspections Enable if you have a mixed project with Intellil IDEA modules and Gradle modules so that it could be shared via VC5

File and Code Templates Gradle projects

QEOQEkﬁ'diSCWE"_‘f"‘ [] Automatically import this project on changes in build script files

Live Templates

Plugins

** Build, Execution, Deployment
* Build Tools
Gradle-Android Compiler
Instant Run
* Languages 8 Frameworks
Android (Experimental)

Build and run

By default Intelli) IDEA uses Gradle to build the project and run the tasks,

In a pure Java/Kotlin praject, building and running by means of the IDE might be faster, thanks to optimizations.
Mote, that the IDE doesn't support all Gradle plugins and the project might not be built correctly with some of them,
Build and run using: | Gradle (Default)

Run tests using: Gradle (Default)

Gradle
Use Gradle from: | 'gradle-wrapper.properties’ file ~
Gradle JVM: = 11 (java version "11.0.5", path: C:/Program Files/Java/jdk-11.0.5) i

Cancel Apply

Now press OK. Click on the “Project” tab on the left and on the “Gradle” tab on the right to open them and click
on the “Reload” icon on the top-left of the Gradle tab on the right:
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» [, geogebra-discovery-11 '\ Uzers\ous
>l External Libraries

"0 Scratches and Consoles
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2 Build:  Sync, -
i A .
E o _ geogebra-discovery-11: Configure build.. 2 m 27 s | Gradle Daemen started in 2 s 328 ms =
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»
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i= & TODO H g: Version Control B Terminal - Q Event Log

] 4% 2 processes running...  Git: master

After several seconds the error message will no longer appear, that is, the configuration will be successful:
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Iz geogebra-discovery-11 A |Add Configuration...| » # T W et v v O O K B Q
EPlojedv @% l:l—

» | geogebra-discovery-11 [geogebra]
> lllll External Libraries
PoScratchs and Consoles

Build:  Sync -

o
E}
o .
E = + geogebra-discovery-11: successful 2 m 2 784 ms | Gradle Daemon started in 2 s 328 ms =
= ] =+
[ Deprecated Gradle features were used in this build, making it incompatible with Gradle —
» Use '--warning-mode all' to show the individual deprecation warnings.
_E ® See https://decs.gradle.org/5.4.1/userguide/command_line_interface.html#sec:command_13
§ -
E
ol CONFIGURE SUCCESSFUL in 3m 2s
*
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Now click on the Build tab (at the bottom): you will disable it. Then the following screen will be shown (in the
meantime the option “enable auto-import” was confirmed, if you do not confirm it, you can do it later, but in that
case the “auto-import enabled” option will not be displayed in parentheses):
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Step 3: Compile the desktop version of GeoGebra

(The following screenshots were created under Linux, but the look is mostly the same.)
Open the task hierarchy on the right in Gradle’s window:



geogebra-discovery-11 [~/workspace/geogebra-discovery-11]

Eile Edit View Navigate Code Analyze Refactor Build Run Tools VCS Window Help

'z geogebra-discovery-11

E|ije(‘.‘tv a = & —

* 2: Favorites

I Structure

[ geogebra-discovery-11 [geogebra] ~/workspa
= Il External Libraries

"o Scratches and Consoles

H 9 version Control  EH Terminal  “ Build = 6 TODO

A [Add Contguation..| » 5 G = (Gt v O 5 m BQ

Gradle

o —

S+ - || FH|HF|F

WY e

¥ = geogebra
> Iz Tasks
» ' ar-base
» @ common
F @ common-jre
v v desktop
- [ Source Sets
v [z Tasks
v [ application

[z build
[z distribution

[z help

[z ide

'z other

5 verification

» & editor-base

-« editor-desktop
itnr-weh

v

[S
>
» I documentation
>
[S
>

Q) Event Log

]

Start the task “run” by double-clicking on it:

geogebra-discovery-11 [~/workspace/geogebra-discovery-11]

Git: master

File Edit View Navigate Code Analyze Refactor Build Run Tools VCS Window Help

'z geogebra-discovery-11 4 | .geogebra-discovery-1l:desktop[run] » | ¢z # G W Gt ¥ v O O B B Q
= Project [ZIENIE - Gradle a — %
» [ geogebra-discovery-11 [geogebra] ~/workspa S+ - Wl F z
= Il External Libraries ¥ 4 geogebra
"% Scratches and Consoles » 1z Tasks
» @ ar-base
¥ common
& common-jre
v« desktop
» I Source Sets
v bz Tasks
v [ application
» %% build
E » Iz distribution
.:% Run:  +_geogebra-discovery-11:desktop [run] - T —
:| @& v O geogebra-discove 7 - Note: /home/l.(ovzo%/works;.)ace/geogebrt.i-l:llscovery-]..l/retex/emtor-Uesktop/src/maln/] avi =
- ) :common:compi 6 < Note: Recompile with -Xlint:deprecation for details. .
% ; T4 ediorb e A > Task :editor-desktop:classes
; - 4 Output directory > Task :editor-desktop:jar
f| = « :editor-deskto 2 m=
H 5 Version Control ~ EM Terminal  “ Build - i= 6 TODO Q) Event Log
(] Git: master

After a few seconds the compilation will succeed and GeoGebra starts properly.

Step 4: Edit the source code and recompile it



By using double (left) Shift, search for the file AlgoDiscover.java. Then, by opening the directory structure on
the left panel like open GeoGebra3D.java with a double-click:

geogebra-discovery-11 [~/workspace/geogebra-discovery-11] - .../desktop/src/main/java/geogebra/GeoGebra3D.java [geogebra.desktop.main] X
File Edit View Navigate Code Analyze Refactor Build Run Tools VCS Window Help
jebra-discovery-11 [ desktop src - g main java geogebra @ GeoGebra3D A geogebra-discovery-11:desktop [run] ~ | b & T Gitt v v @ K 0 Q
g Project ~ € = o —  ®© AlgoDiscover.java & GeoGebra3D.java Gradle g — &
E = common package geogebra; ¥ S o+ & T = e F i
:I = common-jre /<% Wrapper for backward compatibility for auto-updating under Wind geogebra Y
config o Tasks §
2 desktop » public class GeoGebra3D { ar-base =
build ¢ @paran cmdArgs common
config ' command Line args common-jre
src
» public static veid main(string[] cmdArgs) { org.geogebra.desktc deskiop
9! } 7 Source Sets
= main 7 Tasks
Java % application
com.kitfox.svg run
geogebra = build
GeoGebra3D % distribution
€ GeoGebraAppletPreloade = documentation
org = help
resources = ide
= nonfree [main] GeoGebraiD = other
2 Run: geogebra-discovery-11:desktop [run] o —
'§ > geogebra-discovery-11:desktop [run]: si 22:11:38.586 INFO: org.geogebra.common.main.App.initializeRealGeomWS[5371: RealGeomWs is available at http://roi —
¢ B
zl Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.08. £
4 Use '--warning-mode all' to show the individual deprecation warnings.
°© See https://docs.gradle.org/5.4.1/userguide/command line interface.html#sec:command line warnings
w
g = BUTLD SUCCESSFUL in 14s
= » 27 actionable tasks: 2 executed, 25 up-to-date
:I 22:11:42: Task execution finished 'run'.
9 Version Control M Terminal “ Build | ® & Run = & TODO Q) Event Log
O 5:14 LF UTF-8 Tab* Git: master = &

Now close the Gradle tab on the right side. We prepare more space on the screen for programming with this
step.

By using double (left) Shift, type GeoGebra3D and search for another occurrence of GeoGebra3D.java. (This
part of GeoGebra will be used only when running GeoGebra from command line, from a .jar file.) It should be
placed as shown in the next figure. Go ahead and do a minor change on the code, then run it by clicking on
the green Play button, and scroll in the bottom part of the IntelliJ IDEA window to search for your newly added

code:



geogebra-discovery-11 [~/workspace/geogebra-discovery-11] - .../desktop/src/main/java/org/geogebra/desktop/GeoGebra3D.java [geogebra.des.. x

File Edit View Navigate Code Analyze Refactor Build Run Tools VCS Window Help

= desktop src - I'g main java org ~ geogebra-discovery-11:desktop[run] ~ | » & G Git: v + o m B Q
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config initSingletc )
= desktop w
build > public static void main{String[] cmdArgs) { (new GeoGebra3D()).doMain({cmdArgs); }
config
sre @verride
| o protected void startGeoGebra(CommandLineArguments args) {
9P // create and open first GeoGebra window
% main System.out.println("Hello world");
java GeoGebraFrame3D.main(args);
. 1
com.kitfox.svg
geogebra i
¢ GeoGebra3D GeoGebra3D » startGeoGebra()
© Run: geogebra-discovery-11:desktop [run] o -
‘é > geogebra-discovery-11:des 22:11:38.586 INFO: org.geogebra.common.main.App.initializeRealGeomWS[537]: RealGeomWs =
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=] BUILD SUCCESSFUL in 14s
E » 27 actionable tasks: 2 executed, 25 up-to-date
: 22:11:42: Task execution finished 'run'.

K 9: Version Control M Terminal “ Build = » & Run i 6 TODO Q) Event Log
[} 37:40 LF UTF-8 Tab* Git: master W &

Step 5: Debugging

Click on the inserted line, press Ctrl+F8 to set a breakpoint and click the Debug icon (Shift+F9) to start
debugging. Now you can execute the statements line by line when pressing F7 consecutively.

Learn how to control the debugging flow on the left and bottom part of the IntelliJ IDEA main window. You will
want to Resume Program (F9) and Stop (Ctrl+F2).

Further steps

See an earlier version of this document to learn more (note that some steps may be outdated).



https://docs.google.com/document/d/1PvH5wKk5Km0aLynYQJ0k43OkuloS8SSl0Drq3XQ4w74/edit

