R1

ip cef

!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 ip router isis

!

interface Tunnel1

 ip unnumbered Loopback0

 tunnel destination 6.6.6.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng path-option 5 explicit name R1-to-R6-primary

 tunnel mpls traffic-eng path-option 10 dynamic

 no routing dynamic

!

interface FastEthernet0/0

 description to R2

 ip address 10.0.12.1 255.255.255.0

 ip router isis

 mpls traffic-eng tunnels

!

interface FastEthernet0/1

 description to R3

 ip address 10.0.13.1 255.255.255.0

 ip router isis

 mpls traffic-eng tunnels

!

!

router isis

 net 10.0000.0000.0001.00

 metric-style wide

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

!

ip explicit-path name R1-to-R6-primary enable

 next-address 10.0.13.3

 next-address 10.0.34.4

 next-address 10.0.45.5

 next-address 10.0.56.6

=========================

R2

ip cef

!

mpls traffic-eng tunnels

!        

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

 ip router isis

!

interface FastEthernet0/0

 description to R5

 ip address 10.0.25.2 255.255.255.0

 ip router isis

 mpls traffic-eng tunnels

!

interface FastEthernet0/1

 description to R1

 ip address 10.0.12.2 255.255.255.0

 ip router isis

 mpls traffic-eng tunnels

!

!

router isis

 net 10.0000.0000.0002.00

 metric-style wide

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

=========================

R3

ip cef

!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

 ip router isis

!

interface FastEthernet0/0

 description to R1

 ip address 10.0.13.3 255.255.255.0

 ip router isis

 mpls traffic-eng tunnels

!

interface FastEthernet0/1

 description to R4

 ip address 10.0.34.3 255.255.255.0

 ip router isis

 mpls traffic-eng tunnels

!

router isis

 net 10.0000.0000.0003.00

 metric-style wide

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

=========================

R4

ip cef

!

mpls traffic-eng tunnels

!        

interface Loopback0

 ip address 4.4.4.4 255.255.255.255

 ip router isis

!

interface FastEthernet0/0

 description to R3

 ip address 10.0.34.4 255.255.255.0

 ip router isis

 mpls traffic-eng tunnels

!

interface FastEthernet0/1

 description to R5

 ip address 10.0.45.4 255.255.255.0

 ip router isis

 mpls traffic-eng tunnels

!

router isis

 net 10.0000.0000.0004.00

 metric-style wide

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

=========================

R5

ip cef

!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 5.5.5.5 255.255.255.255

 ip router isis

!

interface FastEthernet0/0

 description to R4

 ip address 10.0.45.5 255.255.255.0

 ip router isis

mpls traffic-eng tunnels

!

interface FastEthernet0/1

 description to R2

 ip address 10.0.25.5 255.255.255.0

 ip router isis

mpls traffic-eng tunnels

!

interface FastEthernet1/0

 description to R6

 ip address 10.0.56.5 255.255.255.0

 ip router isis

mpls traffic-eng tunnels

!

router isis

 net 10.0000.0000.0005.00

 metric-style wide

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

=========================

R6

ip cef

!

mpls traffic-eng tunnels

!        

interface Loopback0

 ip address 6.6.6.6 255.255.255.255

 ip router isis

!

interface FastEthernet0/0

 description to R5

 ip address 10.0.56.6 255.255.255.0

 ip router isis

mpls traffic-eng tunnels

!

router isis

 net 10.0000.0000.0006.00

 metric-style wide

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2