Hallo Auswerter,

mit dieser Anleitung wollen wir Euch eine kleine Hilfe geben um selbst einen Bewerb mit FsComp und GpsDump/FsDump  auswerten zu können. Wie jedes Dokument wird dieses nicht alle Fragen klären, wir sind jedoch mehr als optimistisch dass mit ein bisschen Computerverständnis und Eigeninitiative das ohne größere Probleme zu schaffen ist! Unter http://fs.fai.org/trac/wiki/FS%20Guide# findet Ihr zusätzlich eine gute Dokumentation die die eine oder andere Frage klärt.

       

Jörg Drexler und Hans Georg Mitteregger  

Version 1.0        Datum: 20-03-2013

Wo bekomme ich was her?

Bewerb anlegen

Wie bekomme ich Piloten in die die Datenbank?

Erstellen einer Pilotenliste

Wendepunkte auf  GPS hochladen (GpsDump, FsDump), Flüge herunterladen

Ersten Task in FS anlegen

Flüge vom GPS herunterladen

Flüge in FsComp auswerten

Kontrolle des Tracklog

Ergebnislisten erstellen

Manipulation von IGC-Files:

FAQ

  1. Wo bekomme ich was her?

Die aktuellsten Versionen von FsComp bzw. GpsDump findet man:

FsComp: http://fs.fai.org/trac/wiki/CurrentVersion#

GpsDump: http://home.gethome.no/stein.sorensen/body_gpsdump.htm

Ein paar Tools:

Fs Dump        Partizipant.xlt    Sign In/Out

Treiber: (erhebt nicht den Anspruch alle Geräte abzudecken)

Information zu Profilic Treiber (viele USB to Seriell Adapter)

http://www.flytec.ch/de/support/downloads/usb-serial-driver.html

Bräuninger

http://www.brauniger.com/en/support/downloads/usb-serial-driver.html

Flymaster Avionics

http://www.flymaster-avionics.com/Support/Downloads/tabid/187/Default.aspx

Garmin Treiber

www.garmin.com

http://www8.garmin.com/support/download_details.jsp?id=591

FS-Setup-1.3.4.exe installiert FS_Comp auf den Computer

GpsDump473.exe ist bereits ein Programm

FS_Dump ist ein Tool mit dem mehrere Instanzen von GpsDump im Hintergrund verwaltet werden.

Signin_signout.ptl.xsl ist der Stylesheet für Sign In/Out Listen

Participants.zip ist ein Archiv mit einem Excel mit dem man relativ komfortabel Piloten in die Datenbank bekommt.

  1. Bewerb anlegen

Legt einen eigenen Ordner für den Bewerb an.

Installiert FsComp und startet das Programm, es begrüßt Euch folgendes Fenster:

Jetzt erstellen wir einen neuen Bewerb :

Felde befüllen: Name, Location, From, To, offset

Button Set Scoring Formula-> GAP2011 drücken:

Im Bild könnt Ihr die aktuellen Werte welche wir in der Liga-Paragleiten verwenden entnehmen. Vorsicht die Hängegleiter verwenden andere Werte!

Für alle die tiefer in die Thematik GAP eindringen wollen:  http://fs.fai.org/trac/wiki/ScoringFormulas#

Nach dem ersten Task stehen die Minimum Distance, Nominal Distance, Nominal Time sowie Nominal Goalproportion fest.  Wenn die Werte unterschiedlich zu den Defaultparameter sind können die Parameter im Nachhinein jederzeit abgeändert werden.

Ok drücken.

Menü: File -> Save as (in dem Ordner welcher  für den Bewerb angelegt wurde)

Die gespeicherte Datenbank hat als Endung  .fsdb .

Mit Menü: File-> Open Competition den gerade gespeicherten Bewerb neu öffnen

(es werden dadurch div. Templates in den Zielordner kopiert die später benötigt werden)

Generell ist es bei FSComp kein Fehler häufig abzuspeichern.

  1. Wie bekomme ich Piloten in die die Datenbank?

Variante 1:

Wechseln in das Teilnehmerfenster:

Menü: View->Participants

Und dann mit der rechten Maustaste in das Fenster klicken

Auf New dücken:

Dann entweder händisch ausfüllen oder mit dem Knopf Search CIVL dB (Internetverbindung erforderlich und im Namensfeld sollten  mindestens VIER  Buchstaben des zu suchenden Piloten bzw. CIVL ID eingetragen sein) werden die Informationen welche in der CIVL Datenbank gepflegt sind übernommen (etwaige bereits eingetragene Daten werden dabei  überschrieben)

Custom pilot attributes:

Diese werden benötigt um für Teilwertungen (z.B.: Sportklasse oder NÖ-Landesmeisterschaft….) entsprechende Filtermöglichkeiten zu bekommen. Die Attribute stehen beim nächsten neu angelegten Piloten wieder zur Verfügung, die Wertebereiche kann man jederzeit erweitern.

Piloten könne auch im Nachhinein selektiert und bearbeitet werden. Mit rechter Maustaste->Edit bzw. den Piloten doppelklicken.

Es empfiehlt sich die Datenbank regelmäßig zu sichern!

 Menü: File->Save Competition  bzw. Strg S  (wenn man FS-Comp einfach nur schließt werden Änderungen nicht übernommen)

Variante 2:

 Participants.xlt (s. Punkt 1) öffnen, und den Anweisungen darin folgen.

Variante 3:

Menü: Tools-> Usefull Stuff-> Copy Pilotlist from fsdb bzw.  TESTING……

Alle die das angehen brauchen keine detaillierte Erklärung mehr…. ;-))

Jetzt ist der Bewerb angelegt, die Piloten sind in der Datenbank, alles ist hoffentlich gespeichert.

Die Pilotenliste in FsComp schaut dann z.B. so aus:

Allgemeines:

Die Comp Id = Startnummer ist eine eindeutige Zuordnung zum Piloten und darf im Bewerb nur einmal vergeben werden. Sie ist die Verknüpfung von Pilot und seinem GPS!

  1. Erstellen einer Pilotenliste

Wir benötigen noch eine Pilotenliste bzw. eine SignIn-SignOut Liste.

Menü Reports-> Participant List

In FsComp werden Reports über Stylesheets generiert. Participant_list.ptl.xsl auswählen und Öffnen.

Mit diesem Fenster wird der Report „gestaltet“.

OK drücken, es wird ein html-File erzeugt der nach Belieben gespeichert wird.

Achtet darauf dass die Endung .html im Filenamen vorhanden ist!

Für Filterung nach Damen z.B. bei women_only  1 eintippen.

Will man die Sportpiloten selektieren schaut in unserem Fall das Fenster so aus:

Alternativ kann man einen Report auch mit:

Menü: Reports-> Reports_using stylesheets und dann Auswahl des entsprechenden Stylsheets generieren

Für eine SignIn/Out Liste gibt es den entsprechenden Stylesheet unter Punkt 1.

Kopiert den Stylesheet in den Bewerbsordner, dann steht er Euch zur Verfügung










  1. Wendepunkte auf  GPS hochladen (GpsDump, FsDump), Flüge herunterladen

Wegpunkte Upload:

Nach dem Ausführen der gpsdump.exe über den Menupunkt „Misc“ den COM Port einstellen, den „Competition Mode“ aktivieren und die Piloten Liste (Bewerb.fsdb) einlesen.

Es reicht wenn in der FsComp Datenbank ein Dummypilot angelegt ist.

 

Über das Menu „File“ die Wendepunktliste auswählen danach unterMenü „Wpts“ das angeschlossenen Gerät suchen und „Send to XXXX“. Steht neben der GPS-Bezeichnung “(Only Name)” bzw. “(Only ID)” wird nur der Wendepunktname bzw.  nur der Kurzname des Wendepunktes übertragen, andernfalls beides.

 Über die Drop Down Liste den Piloten auswählen oder wenn der Pilot nicht vorhanden ist eine freie ID verwenden (Wenn eine Pilotenliste ausgewählt ist wird die ID dann nur für den Transfer geändert  aber in FsComp nicht überschrieben!)

Wichtig damit nicht einem Piloten zwei Tracks zugewiesen werden.

Um den Upload einfacher zu gestalten können mehrere Instanzen von GpsDump mit unterschiedlichen COM Ports gestartet werden. Die Ports werden im Header angezeigt.

 

Download:

Für den Download wieder COM Port setzen, Pilotenliste auswählen und über die einzelnen Buttons oder Menü: Logs ->Read xxx kann der Download vom GPS gestartet werden.

Da der Pilot bereits eine ID im Gerät eingetragen hat wird beim Auslesen diese dem Namen zugeordnet und eindeutig im noch zu definierenden Ordner abgelegt.

GpsDump zeigt Euch dann an welche PiloteID gerade gelesen wird und wie der Fortschritt beim Track auslesen ist.

Ist der Download beendet kommt automatisch dieses Fenster hoch:

Überprüft den Pilotennamen und die Pilotennummer.

Sind diese Felder leer oder es steht der falsche Pilot darin kann in der Pilotenliste der richtige Pilot ausgewählt werden.

Den Ordner in dem man die Flüge abspeichern will mit Browse auswählen.

Sind falsche Pilotendaten im GPS abgespeichert sind  fragt GpsDump nach ob es die CompId und CivlID ersetzen soll->ja.

Kontrolliert den Tracklogfolder, ihr solltet einen  kml File mit folgender Namensgebung sehen:

      Drexler Joerg.20130315-081227.71.52.kml

      [Pilot name].[Datetime].[CIVLID].[COMPID].kml

Nur mit dieser Namensgebung ist FsComp später in der Lage dem Piloten den richtigen Flug automatisch zuzuordnen!

FsDump Upload/Download von mehreren GPS

Alternativ zu GpsDump kann auch mit FsDump gearbeitet werden.

FsDump ist ein einfaches Interface um mehrere Instanzen von GpsDump zu verwalten.

FsDump nutzt GpsDump um auf die angeschlossenen Logger zuzugreifen. GpsDump

läuft dabei unsichtbar im Hintergrund.

Voraussetzung: FsDump und GpsDump befinden sich im selben Ordner

Nach dem Start von FsDump erscheint dieser Startscreen:

  1. Die Bewerbsdatenbank muss ausgewählt werden
  2. Die Wendepunktliste, die im OZI Format vorliegen muss eintragen
  3. und den Pfad zum Speichern der ausgelesenen Flüge
  4. Upload, übertragen der Wendepunkte und optional der Startnummer oder Download, um die Flüge nach dem Durchgang auszulesen, auswählen
  5. Die Anzahl der Interfaces eintragen, meistens trage ich die Anzahl der angeschlossenen unterschiedlichen Kabel ein. Ab 4 Interfaces kann es ein wenig unübersichtlich werden
  6. Die Differenz zur UTC eintragen
  7. Die restlichen Optionen verwende ich gar nicht bis selten
  8. „Accept“


Nach dem „Accept“ sollte das Popup in etwa so aussehen:

 

Jetzt können die einzelnen Ports und GPS Protokolle eingestellt werden.

Durch drücken von “R” kann die Com-Belegung zurückgesetzt werden.

Mit der Auswahl der „ID“ (10) oder doppelklick auf den gewünschten Piloten wird über „S“ die Piloten ID und Wendepunkte an das GPS übertragen und im Feld Status bestätigt. Eine ID wird zwingend benötigt!

Änderungen können jederzeit über das Menü: Config Menu -> Open Compe“ durchgeführt werden.

Für das Auslesen FS_Dump auf „Download“ umstellen (Menü: Config->OpenCompetition)

Beim Auslesen ist es hilfreich die einzelnen Kabel mit der COM Schnittstelle zu beschriften. Beim Auslesen mehrerer Geräte zur gleichen Zeit ist darauf zu achten das nicht ZWEI gleiche Protokolle verwendet werden. Das Programm kann abstürzen und muss danach neu gestartet werden.

Im angegebenen Tracklogfolder wird ein *.wpt file, ein *.igc und ein *.kml File automatisch nach Beendigung des Downloads eines Piloten gespeichert.

Das Format beim Wegpunktfile ist [CompID].wpt.

Bei den Flugfiles wieder [Pilot name].[Datetime].[CIVLID].[COMPID].kml  (bzw. igc)

Zusätzliche Informationen zum Arbeiten mit GpsDump / FsDump:

*) Die USB Ports für Compeo/Competino + und Flymaster stehen erst nach dem Verbinden des Gerätes zur Verfügung.

*) Top Navigator sollte alleine ausgelesen werden.

*) Sollte es nicht möglich sein aus einem GPS einen Track auszulesen versucht es mit einem anderen Programm wie SeeYou, Maxpunkte….

*) Es kann natürlich auch der Fall sein dass der Rechner komplett neu gestartet werden muss da sich irgendetwas aufgehängt hat.









  1. Ersten Task in FS anlegen

Die beim Briefing vereinbarten GAP-Parameter unter

Menü: File->Edit Competition Details ->Set ScoaringFormula->GAP2011 eintragen.

Damit sind für den gesamten Bewerb die GAP-Parameter fixiert und wenn Ihr einen neuen Task anlegt werden selbige übernommen.

Mit Menü: View->Tasks

Menü: Tasks->new

Name eintragen

Task Type eintragen

Datum und UTC offset prüfen

Open Waypoint file-> Wegpunktliste laden (muss im geografischen wpt File Format von GpsDump vorliegen!!):

Wendepunkt selektieren und mit Add to Turnpoint zum Task hinzufügen, es erscheint bei jedem Wegpunkt dabei folgendes Fenster:

Radius sowie die gültigen Zeiten der einzelnen Wegpunkte entsprechend dem Taskboard pflegen.

In unserem Beispiel legen  wir ein Race mit einer Goalline als Task an.

Mit Up Down und Remove könne die Task Wendepunkte verschoben/gelöscht  werden.

Zum Schluss noch „Start of Speedsection“(SS) und „End of Speedsection“(ES) eintragen (Wegpunkt 2 und 5) und eine Startgatezeit definieren.

 Ok drücken dann schaut das Taskfenster folgendermaßen aus:

  1. Flüge vom GPS herunterladen

s. Punkt 3.

  1. Flüge in FsComp auswerten

Das Taskfenster in FsComp schaut folgendermaßen noch aus:

Mit Browse den Ordner mit den Flügen des ersten Task selektieren (Ordner mit den Flügen welche mit GpsDump heruntergeladen wurden bzw. noch werden)

Aktuell haben alle Piloten den Status NYP (not yet proceed).

Mit der rechten Maustaste->Check Tracklog wird automatisiert im Flugordner geprüft ob für den ausgewählten Piloten ein Flug vorhanden ist und wenn ja ausgewertet.

Das Ergebnis kann dann direkt abgelesen und dem Pilot mitgeteilt werden (Feld: Distance und Finished SS).

Mit rechter Maustaste->Import tracklog for selected Pilot erfolgt diese Zuordnung manuell.

Es gibt weiters die Möglichkeit alle Piloten welche NYP haben automatisiert zu überprüfen.

Der Status kann mit ABS (absent) bzw. DNF (did not fly) ebenfalls gesetzt werden.

Mit DF kann dem Piloten eine beliebige Distanz zugewiesen werden (z.B.: min. Dist)

Sollte das Ergebnis von FsComp und die Meinung des Piloten unterschiedlich sein geht es dann zur Ursachensuche.

Sind alle Piloten eingelesen (keiner hat mehr Status NYP) dann sieht das Ganze in etwa so aus:

Man kann durch Anklicken der jeweiligen Spaltenüberschrift relativ komfortabel sortieren.

Das hilft um etwaige Piloten mit z.B. NYP ausfindig zu machen.

Wenn ein weiterer Task zum Auswerten ist entsprechend dem ersten Task vorgehen.

Im obigen Beispiel wurden 2 Tasks angelegt.  Durch Auswahl des jeweiligen Tasks im Tasks-Fenster kann zwischen selbigen umgeschalten werden.

















  1. Kontrolle des Tracklog

Unter

Menü: Tools->FS-Flight

findet Ihr ein sehr einfaches Werkzeug um den Task sowie Trackaufzeichnungen zu visualisieren.

FS Flight öffnet in einer eigenen Instanz:

(Mittlerweile öffnet sich dieses Fenster auch automatisch wenn man einen Task anlegt bzw. einen Bewerb öffnet und einen Task selektiert.)

Unter

Menü: File->Select Task

Die zugehörige Datenbank aussuchen und dann über:

den gewünschten Task selektieren.

Den Piloten mit Doppelklick auswählen.

Um Flugdetails des Tracklogs zu bekommen mit der Maus zu dem gewünschten Trackpunkt zeigen.

In der zweiten Zeile des Fensters kann man dann die Flugdaten ablesen (Datum Uhrzeit, Höhe, Position).

Zum Hineinzoomen mit der linken Maustaste ein Rechteck aufziehen, um wieder den ganzen Track zu sehen mit der rechten Maustaste auf den Piloten -> Focus on Tracklog.

Mit einem einzelnen linken Mausklick in das Trackfenster zentriert sich der Sichtbereich auf diesen Punkt. So kann man den Flug zu dem Bereich verschieben den man untersuchen will. Mit einem rechten Mausklick zoomt man  wieder heraus.

Penalty bzw. Bonuspunkte können durch Selektion des Piloten im entsprechenden Task und rechte Maustaste-> Set Penalty gesetzt werden:

  1. Ergebnislisten erstellen

Um überhaupt eine Ergebnisliste erstellen zu können muss ein Task gewertet werden:

Menü: View->Tasks den zu wertenden Task auswählen. Dann mit Tasks->Score Task die Punkte vergeben. Erst jetzt kann ein Taskreport erstellt werden!

Für einer Bewerbswertung müssen die einzelnen Tasks gewertet sein.

Egal ob ein Task- Team- oder das Bewerbsergebnis erstellt werden soll, der Ablauf ist ident.

Menu:  Reports-> Task Result (with Filter) bzw. Reports->Competition Result (with Filter) bzw. Reports -> Team Result

Den gewünschten Report auswählen. Man wird aufgefordert den entsprechenden Stylesheet auszuwählen (Vergleiche auch erstellen einer Pilotenliste…..).

Die Stylsheets heißen selbstredend  task_result.tkr.xsl, comp_result.cpr.xsl, team_result.tmr.xsl

Erstellen eines Task reports:

Menu:  Reports-> Task Result:  Task auswählen

(ist man bereits in der “Taskübersicht” und einTask ist selektiert dann entfällt das Task auswählen)

Stylesheet : task_result.tkr.xsl  auswählen.

   

Name und Status eingeben ok drücken und dann unter beliebigen *.html Namen speichern,drucken….

Task with Filter:

Menu:  Reports-> Task Result with filter

Im Unterschied zum “Taskreport” erscheint ein Fenster in dem man nach allen Daten bzw. Attributen welche bei den Piloten aufscheinen gefiltert werden kann. Die Filterung ist selbsterklärend .

Sonst ist der Ablauf wie bei einem Taskreport

Competition result:

Menu: Report->Competition Result

Hier kommt ein Fenster in dem man die Tasks selektieren muss welche zum Bewerb gezählt werden sollen (im Allgemeinen sind das Alle)

Tasks auswählen, ok drücken und dann den entsprechenden Stylesheet (comp_result.cpr.xsl   ) selektieren.In Folge erscheint dieses Fenster

Titel und Status eingeben. Wenn nur die besten x Tasks gewertet werden sollen dann statt top_x_tasks = all die gewünschte Anzahl eingeben.

Ok drücken und dann unter beliebigen *.html Namen speichern,drucken….

Competition result with filter:

Gleich wie bei Competition result, nur muss zuerst die gewünschte Filterung eingegeben werden (s. auch Task mit Filterung)

Ergebnisliste auf der Liga Homepage veröffentlichen:

Um beim Bewerb Ergebnislisten so schnell wie möglich Online zu bringen kann der für den Bewerb zuständige Auswerter das Ergebnis als PDF speichern und an diese Adresse senden.  liga@walkandfly.com  (EMail des Senders muss vom Admin der Ligahompage freigegeben sein) Der Name der Datei sollte immer folgenden Schema folgen:

“Name des Bewerbes”_”Task?”  z.B. Schmittenpokal2013_Task1.pdf

Die Datei wird nach ca. 15 Minuten auf der Webseite unter dem Menüpunkt Ergebnisse gelistet.  Die Betreffzeile der Mail wird als Beitragsüberschrift auf der Webseite verwendet. Der Text in der Mail wird als normaler Text angezeigt.  

  1. Manipulation von IGC-Files:

Muss man einmal ein Tracklogfile abändern findet Ihr anbei das Format eines igc Files.

Liegt der Flug nur als kml vor müsst Ihr ihn mit GpsDump umwandeln:

Menü: File->Convert.kml files to .igc

DAS IST DANN KEIN GÜLTIGER IGC-FILE für den X-CONTEST mehr!!!

Mit einem Texteditor den igc File öffnen, das schaut in etwa so aus:

AXGD111

HFDTE020411

HOPLTPILOT: None

HOGTYGLIDERTYPE: None

HOGIDGLIDERID: None

HODTM100GPSDATUM: WGS-84

HOCIDCOMPETITIONID:

HOCCLCOMPETITION CLASS: None

HOSITSite: None

B1120244749810N01602772EA0081300881

B1120344749810N01602772EA0081300881

B1120444749809N01602774EA0081300881

B1120544749809N01602775EA0081300883

B1121044749809N01602775EA0081300884

….usw

Für uns interessant ist in erster Linie der Bereich der mit B beginnt:

Format:

B  112114  4749809N  01602775E  A  00813  00885

B: record type is a basic tracklog record
112114: <time> tracklog entry was recorded at 11:21:14
4749809N: <lat> i.e. 47 degrees 49.809 minutes North
01602775E: <long> i.e. 016 degrees 02.775 minutes West
A: <alt valid flag> confirming this record has a valid altitude value
00813: <altitude from pressure sensor>
00885: <altitude from GPS>

Zeilen können beliebig hinzugefügt und manipuliert werden,

die zeitliche Reihenfolge muss jedoch eingehalten sein.

Somit kann man zerstückelte Tracklogs zusammenfügen, Tracks verlängern….

Ist man fertig den igc File speichern.

Mit Menü: File->Convert.igc files to .kml bekommt man wieder einen kml File welcher in FsComp importiert und geprüft werden kann

  1. FAQ

Auf einem 2. PC mit alternativer Software auslesen. MaxPunkte, Seeyou… Manche Konfigurationen erlauben das Auslesen aus diversen GPS Geräten nicht. Konnte leider noch nicht auf einen bestimmten Fehler festgelegt werden.


Nur ein Gerät auslesen



Wird laufend ergänzt wenn Probleme auftauchen