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Introduction 

SWAT is initially developed and compiled with Intel Fortran, which is not free. To allow more 
users participate in SWAT development, it’s important that SWAT could be compiled and debug 
in a totally free environment. GFortran plus Eclipse is the toolset perfect for this job. 

This document would show you how to install and configure GFortran and Eclipse Parallel Tools 
Platfrom (PTP) and then compile and debug SWAT with them. 
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Downloading and Installing Eclipse Parallel Tools Platform (PTP) 

PTP is the IDE where SWAT codes will be compiled and debugged. For more features, please 
visit Photran information page http://www.eclipse.org/photran/. 

1.​ Go to http://eclipse.org/downloads/ and select downloads for Eclipse for Parallel 
Application Developers based on Window version (32 bit or 64 bit).  

 

2.​ The download link would be give based on your location. Click the download link to start 
the download process. The name of download file would like 
eclipse-parallel-kepler-SR1-win32-x86_64.zip.  
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3.​ After the download process is done, extract the zip file to a folder. There is a file named 
eclipse.exe in the extracted folder. This is the main program of Eclipse. Create a shortcut 
on the desktop if necessary. Double-click this file to start Eclipse. 

 

6 



 

Note: 

Eclipse requires a Java Runtime Environment (JRE) in order to run. JRE should be already 
installed in most of the Windows system. In case it’s not available, please download it from 
Oracle website 
http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html. 
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Downloading and Installing GFortran and MSYS 

GFortran is the GNU Fortran compiler, part of GCC. It’s developed in Linux. To use it in 
Windows, there are two options: MinGW and  Cygwin. As the program compiled with Cygwin is 
not native Windows program and requires Cygwin installed on the target machine, MinGW is the 
better choice. MinGW, a contraction of “Minimalist GNU for Windows”, is a minimalist 
development environment for native Microsoft Windows application. gfortran is part of MinGW. 

MSYS is a collection of GNU utilities such as bash, make, gawk and grep to allow building of 
applications and programs which depend on traditionally UNIX tools to be present. It is intended 
to supplement MinGW and the deficiencies of the cmd shell. Three of these utilities are used in 
SWAT Makefile: make, rm and mkdir, where make is used to execute the Makefile, rm is used 
to clear the project and mkdir is used to create the subfolder for object (*.o) files. 

There are different versions (32-bit and 64-bit) of MinGW and different ways to install MinGW 
and MSYS. Three methods are demonstrated in this document and we recommend to use 
MinGW, which is easiest way for beginners although it doesn’t support 64-bit build. 

Rtools 

R is a free software environment for statistical computing and graphics. Rtools is the toolset to 
compile R source codes, most of which are C and Fortran. It combines some files from Cygwin, 
MinGW-w64 and MSYS and has everything we need for SWAT compilation.  

1.​ Visit http://cran.r-project.org/bin/windows/Rtools/ to download the latest Rtools. 
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2.​ Run the installation file and select language. 

 

3.​ Click Next to accept all the default settings until the install button comes up. 
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4.​ In the Rtools folder, MSYS is in bin folder and gfortran is located in gcc-4.6.3/bin (the 
folder may be different for other version).  

 

5.​ Add C:\Rtools\bin and C:\Rtools\gcc-4.6.3\bin to PATH. This is optional. It’s only required 
when SWAT is compiled in command line. 
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MinGW-w64 

Mingw-w64 delivers runtime, headers and libs for developing both 64 bit (x64) and 32 bit (x86) 
windows applications using GCC and other free software compilers.  

Please note MinGW and MinGW-w64 are two separated projects and MinGW doesn’t support 
64 bit. 

1.​ Visit 
http://sourceforge.net/projects/mingwbuilds/files/mingw-builds-install/mingw-builds-install
.exe/download to download MinGW Build Installer. 

 

2.​ Run the installer and click next. 
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3.​ In the Settings window, select x32 for Architecture (even if you are working on 64-bit 
machine) ,  win32 for Threads and dwarf for Exception. Click next. 

 

4.​ Change the Destination Folder if necessary. 
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5.​ Click Next to start download and extract selected package. 
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The structure of the installation folder (default is C:\Program Files 
(x86)\mingw-builds\x32-4.8.1-win32-dwarf-rev5\mingw32) is shown in the graph below. 

 

6.​ GFortran is installed and next is MSYS. Visit 
http://sourceforge.net/projects/mingw-w64/files/External%20binary%20packages%20%2
8Win64%20hosted%29/MSYS%20%2832-bit%29/ and download the latest zip file. 
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7.​ Exact the zip file into a folder. It’s highly to extract it to the MinGW-w64 installation folder 
(Default is C:\Program Files (x86)\mingw-builds\x32-4.8.1-win32-dwarf-rev5\mingw32). 

8.​ Add C:\Program Files (x86)\mingw-builds\x32-4.8.1-win32-dwarf-rev5\mingw32\bin 
and C:\Program Files 
(x86)\mingw-builds\x32-4.8.1-win32-dwarf-rev5\mingw32\msys\bin to PATH. This is 
optional. It’s only required when SWAT is compiled in command line. 

MinGW 

Please note MinGW doesn’t support 64-bit. To build SWAT as 64-bit, please use Rtools or 
MinGW-w64.  
 

1.​ Download the automated GUI installer mingw-get-setup.exe at 
https://sourceforge.net/projects/mingw/files/latest/download. 
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2.​  Double-click mingw-get-setup.exe and accept all the default settings. A shortcut for 
MinGW installer would be created on desktop once the process is done. 

Note: 

It’s highly recommended to use the default installation directory C:\MinGW. If it’s not possible, 
make sure the installation directory doesn’t have any space. 
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3.​ Open MinGW Installation Manager on the desktop, select Basic Setup in the left panel 
and choose package mingw32-base, mingw32-gcc-fortran, mingw-developer-toolkit 
and msys-base.  
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4.​ Select menu Installation -> Apply Changes to start installation.  

 

5.​ Click Apply in the coming window to start downloading selected packages and then 
extracting them into the installation folder. 
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6.​ The four packages will be selected after the installation is done. 
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7.​ Go to the installation folder (C:\MinGW\bin) to check mingw32-make.exe and 
gfortran.exe. 

 

8.​ Add C:\MinGW\bin and C:\MinGW\msys\1.0\bin to PATH. This is optional. It’s only 
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required when SWAT is compiled in command line. 
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Downloading SWAT Source Codes 

Visit SWAT website http://swat.tamu.edu/software/swat-executables/ to download the latest 
SWAT source codes.  

 

Get Makefile 

Makefile defines the rules for compiling source codes. The Makefile for SWAT could be 
downloaded directly or generated with Makefile Generator. 

Downloading Makefile 

 
Visit my blog using following link to download the makefile directly. 
http://zhiqiangyu.wordpress.com/2014/02/10/makefile-updated-1-no-need-to-modify-main-f-any-more-2-a-
single-makefile-3-64-bit-build/. 

Generating Makefile with Makefile Generator 

Makefile Generator is a .NET program which will generate the Makefile automatically based on 
the version of SWAT source codes. It supports SWAT 2009 and SWAT 2012. The source code 
of this program is host in Google Code and the executable could be downloaded using following 
link. 
https://swat-eclipse.googlecode.com/svn/trunk/GenerateMakefile/GenerateMakefile/bin/Release
/GenerateMakefile.exe 
Download this program and copy the file into the SWAT source code folder. Double-click to run 
the program and the Makefile will be generated in the same folder. Please note that the existing 
Makefile will be overwritten.  

28 

http://swat.tamu.edu/software/swat-executables/
http://zhiqiangyu.wordpress.com/2014/02/10/makefile-updated-1-no-need-to-modify-main-f-any-more-2-a-single-makefile-3-64-bit-build/
http://zhiqiangyu.wordpress.com/2014/02/10/makefile-updated-1-no-need-to-modify-main-f-any-more-2-a-single-makefile-3-64-bit-build/
https://swat-eclipse.googlecode.com/svn/trunk/GenerateMakefile/GenerateMakefile/bin/Release/GenerateMakefile.exe
https://swat-eclipse.googlecode.com/svn/trunk/GenerateMakefile/GenerateMakefile/bin/Release/GenerateMakefile.exe


Compiling SWAT in Command Line 

With Makefile, the SWAT source codes could be compiled using GFortran in command line. 

1.​ Locate gfortran.exe and make.exe. The default locations would be as following. 
●​ Rtools: C:\Rtools\gcc-4.6.3\bin, C:\Rtools\bin 
●​ MinGW-w64: C:\Program Files 

(x86)\mingw-builds\x32-4.8.1-win32-dwarf-rev5\mingw32\bin, C:\Program Files 
(x86)\mingw-builds\x32-4.8.1-win32-dwarf-rev5\mingw32\msys\bin 

●​ MinGW: C:\MinGW\bin, C:\MinGW\msys\1.0\bin 
2.​ Add locations found in step 1 into system variable PATH. 
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3.​ Open command line by typing cmd in start menu and navigate to SWAT source codes 
folder. Type one of the four commands in following table  to start compiling SWAT. The 
whole compiling process would take around 15 minutes to finish.  

Command 32-bit or 64-bit debug or 
release 

executable 
name Comment 

make debug32 32 debug swat_debug32  

make debug64 64 debug swat_debug64 Doesn’t support 
by MinGW 
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make rel32 32 release swat_rel32  

make rel64 64 release swat_rel64 Doesn’t support 
by MinGW 

 

Note: 

The make command also could be replaced by mingw32-make if MinGW and MinGW-w64 is 
used. 
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Compiling and Debugging SWAT in Eclipse 

To debug SWAT, e.g set breakpoints and check variable values, a project is needed to created 
in Eclipse. 

Create a Fortran Project 

Find Fortran Project… Menu 

The Fortran Project option is not list in menu File -> New when PTP is used the first time.  

 

To add Fortran Project in the menu, follow steps below. 

1.​ select Projects… to open New Project window. 
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2.​ Find Fortran project under Fortran folder. Select it and click Next to create the project.  

 

3.​ When the project is created, you will be asked if you want to open Associated 
perspective. Check Remember my decision and click Yes. The Fortran Project option 
would be list in menu File -> New. 
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Create an Empty Makefile Project 

1.​ Select File -> New -> Fortran Project 

 

2.​ Give the project a name, e.g. SWAT. Select Empty Project under Makefile project in the 
lower left panel and select -- Other Toolchain -- in the lower right panel. Click finish to 
create the project.  
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Setup the Project 

To setup the project, open the Property window through right click on the project and select 
Properties. 
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Build Command 

Select Fortran Build in the left panel, and change the build command if necessary. The default 
build command is make, which would work for all MinGW platforms.  

 

If prefer using mingw32-make, un-check Use default build command and change Build 
Command to mingw32-make. 
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Fortran Build Environment 

If the gfortran and msys folder is not added to the PATH system variable (which is not possible 
for users without administrative access), they needs to be added to the PATH variable in Fortran 
build environment. That’s where Eclipse will search for gfortran, make (or mingw32-make) 
and gdb. 

1.​ Select Fortran Build -> Environment in the left panel, and click Add.. to popup the 
New Variable window. 
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2.​ Input PATH as the variable name and the locations of gfortran and msys as the value. 
Click OK to add this variable. 

 

Note: 

The location of gfortran and msys depends on which MinGW version would be used (Rtools, 
MinGW-w64 or MinGW).  

Binary Parser 

Select Fortran Build -> Setting in the left panel and then select PE Windows Parser for 
Binary Parsers in the right panel. 
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Error Parsers 

Select Photran Error Parser for GNU Fortran (gfortran) for Error Parsers and move it to the 
top. This option is not selected when the project is created. 
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Click OK to close the properties window and save all the settings. 

Copy SWAT Source Codes and Makefile 

Copy SWAT source codes in Windows Explorer and right click the Fortran project and select 
paste to copy all the sources codes files into the project. 
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The source codes would be list in the Project Explorer window. 
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Create Make Target 

1.​ Open Make Target view through menu Window -> Show View -> Make Target. 
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2.​ Click to popup the Create Make Target window. Notice that here the build command 
is used the same build command set in project properties. 
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3.​ Input debug32 in the Target name text box and click OK. 
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4.​ The new Make target would be shown in Make Target window. 

 
5.​ Repeat setp2-3 to create another three make targets using name debug64, rel32 and 

rel64. Noticed that the target name is same as the parameter used in make command 
when SWAT is compiled in the command line. They are corresponding to different 
version of SWAT. 

 

Build Make Target 

Now, it’s ready to compile SWAT, i.e. generate SWAT executable from sources codes. 

1.​ In Make Target view, double-click one of the four targets or select one of the make target 

in Make Target view, e.g. debug32, and then click to start building this target, i.e. 
compile SWAT for specific version. 
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2.​ The building process and possible warnings and errors would be shown in the Console 
window in the bottom.  

 

3.​ When the build finished, the total time used would be shown in the Console window. 
Other three targets could be built using the same methods. At this point, the SWAT 
executables (swat_debug32.exe, swat_debug64.exe, rel32.exe and rel64.exe) are 
generated in the project folder, which will be shown in the Project Explorer view under 
the Binaries folder. It’s ready to run run/debug SWAT. 
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Debug/Run SWAT 

Since the SWAT executables has been generated, it’s time to run and debug SWAT. Some 
settings needs to be changed before SWAT could run successfully in Eclipse. 

Create Run/Debug Settings 

1.​ Select generated SWAT executable in the Project Explorer view under binaries folder, 
e.g. swat_debug32.exe. Right-click and select Run As -> Run Configurations… to 
open Run Configurations window. For debug, select Debug As instead of Run As. 
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2.​ Select Local Fortran Application in the left panel and click to create a new 
configuration. The executable file name would be automatically set as the name of 
Fortran Applications. 
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3.​ Select Arguments tab in the right panel and change the Working Directory to the SWAT 

model folder, which is usually located in Scenarios -> Default -> txtinout folder in a 
ArcSWAT project. 

52 



 

53 



 
Note: 
The working directory would be changed frequently if you are working on several models or 
scenarios. 
 

4.​ Select Debugger tab in the right panel, change the Debugger to MinGW gdb and 
uncheck Stop on startup at:. 
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5.​ For Rtools, the gdb.exe is located at C:\Rtools\gcc-4.6.3\bin32 (for 32-bit) and 
C:\Rtools\gcc-4.6.3\bin64 (for 64-bit). These two folders are not added to the PATH 
variable by default. There is need to change the GDB debugger. Click the Browse.. 
button to find gdb.exe and click OK. 
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6.​ Click Apply button to save the configuration.  
7.​ Repeat step 1-6 to create configurations for other three SWAT executables. 

Debug/Run 

 
After the configurations are created, SWAT could be run/debug though the toolbar 

, where  is debug and  is run. When there are more than one 
executables, click the arrow after the button to select the executables. 
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Click  or  start running or debugging SWAT. The regular SWAT output would be shown 
in the Console window. 

 

 

Break Point 

Breakpoints could be added in the editor by double-click the left edge of the line where the 
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breakpoint would be.  

 

Debug Perspective 

When breakpoint is hit, you would be asked if want to change to Debug Perspective, whose 
layout is designed to help debugging, especially the Variables and Expression view. It’s 
recommended to change to this perspective and check Remember my decisions to go into 
debug perspective next time when a breakpoint is hit. 
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Click Fortran button on the up right corner, Eclipse would go back to Fortran perspective, which 
is designed for coding. 

 

Click the Debug button in the up right corner to return to Debug perspective. 
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Variables and Expression View 

Variables view would show the value of local variables and Expression view would show values 
of any expression. 
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Some Useful Settings 

All these settings are located in Preferences window, which could be opened through menu 
Windows -> Preferences. 

 

Change Text Font 

The default text font is Consolas 10, which may be too small.  

To change the font, select General -> Appearance -> Colors and Fonts in the left panel, and 
then select Basic -> Text Font in the right panel to edit the font. 
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Show Line Number 

The line number is not shown in the editor by default. Showing line number would be useful for 
some cases.  
To show line number, select General -> Editors -> Text Editors in the left panel and then check 
show line number in the right panel. 
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Save automatically before build 

By default, the edit is not save automatically when the project is built. You need to click the save 
or save all button to make the edit works, which is not very convenient.  
To enable automatically saving, click General -> Workspace in the left panel and check Save 
automatically before build in the right panel. 
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Change Keys 

The default keys in Eclipse is different from Visual Studio. For a long time Visual Studio user, it 
would be great to use the same keys. It’s located in General -> Keys. Select MicroSoft Visual 
Studio in the Schema list to change the keys. 
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