
Table of Contents 



 

 

 

 

 

Work Smart with Google Docs 
 

 

A Reference Guide for Advanced Features 

 

 

 

 

 

 



 

Table of Contents 
Introduction​ 2 

How to use this guide​ 2 

What you need to know​ 2 

Content Creation​ 3 

Voice Typing​ 3 

Translate Document​ 4 

Offline Mode​ 5 

Table of Contents​ 6 

Formatting​ 7 

Document Tabs​ 7 

Personal Dictionary​ 8 

Outline​ 9 

Add-ons​ 9 

Keyboard Shortcuts​ 10 

Collaboration​ 11 

Share​ 11 

Google Meet​ 12 

Smart Chips​ 13 

Version History​ 14 

Summing Up​ 15 

 

1 



Introduction 
Whether you are an author, a technical writer, or just someone who uses online 

tools to create documents, you’re probably familiar with Google Docs. A part of 

Google’s suite of free web applications, Google Docs is used to create and edit 

documents. However, calling it a simple authoring tool would be an 

understatement as it provides enhanced capabilities at every step of the 

documentation process. This reference guide highlights a few of Google Docs’ 

advanced features. 

How to use this guide 
This guide explains task-based features of Google Docs with a step-by-step text 

and visual explanation. Thus, it is divided in the following sections: 

1.​ Content Creation 

2.​ Formatting 

3.​ Collaboration 

You can use the Table of Contents for easy navigation throughout the document. 

What you need to know 
Since this is a collection of advanced features of Google Docs, you should know 

the basic editing and formatting features of this tool. Similarly, it helps to be 

familiar with some other applications of the Google Suite like Google Drive, 

Google Sheets, Gmail, and Google Meet. This is necessary as the guide discusses 

integration of these tools in Google Docs, making it a ‘one-stop’ solution for 

creating high-quality documents. 

Now that we have looked at the prerequisites, let’s dive into learning the 

advanced features of Google Docs. 

2 



Content Creation 
Google Docs offers many advanced features to automate time-consuming tasks 

and increase process efficiency: 

 

Voice Typing 
For a writer, typing can be a time consuming and physically tiring task, especially if 

the text is lengthy and requires a lot of mental energy. As a solution, Google Docs 

offers a voice typing (also called dictation or speech-to-text) feature that allows 

you to dictate text into a document. This feature comes in multiple language 

options.  

 

To use voice typing, open a Google Docs document and in the menu bar, click: 

1.​ Tools  ➔ Voice typing ➔ microphone icon; the microphone icon turns red 

(denotes voice typing in progress). 

2.​ Say what you want typed. 

3.​ Select microphone icon once finished speaking. 
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Selecting a language to voice type in:  

1.​ Click the dropdown arrow that appears above the microphone icon. 

2.​ Select the desired language. 

3.​ Click the microphone icon and speak the text you want typed. 

4.​ Select microphone icon once finished speaking. 

5.​ To exit out of the feature, click the X on the microphone icon. 

Things to remember while using voice typing feature: 

●​ Speak slowly and pronounce words clearly. 

●​ Use words like “comma” and “period” to add punctuation to the text. 

●​ Check the microphone settings and internet connection before using 

this feature. 

●​ The voice typing feature is best suited for quieter settings; 

alternately, you can use noise-cancelling microphones to eliminate 

background noises.  

 

Translate Document 
Google Docs has a built in feature that allows you to translate a document into 

more than 100 languages. This is helpful for writers working with documents that 

need to be catered to an international and/or multilingual audience. This feature 

creates a copy of your translated document, ensuring that the original document 

remains unchanged.  
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To use this feature click: 

1.​ Tools  ➔ Translate document.  

2.​ Enter a name for the copy that is 

to be translated. 

3.​ Select the language using the 

dropdown arrow. 

4.​ Click Translate. 

A new tab opens with the translated 

document.  

Note: The Translate Document feature in Google Docs is not 100% accurate. It's 

best to have the translated copy reviewed by a fluent speaker of the language.  

Offline Mode 
As the name suggests, this feature lets you use Google Docs offline. This is an 

excellent option if you want to use Google Docs while travelling, or when internet 

connectivity is poor. The document gets updated once the connection is restored.  

To use Google Docs in Offline mode: 

1.​ Go to Google Drive. 

2.​ Click on the settings gear icon on the top right corner. 

3.​ Scroll down to the Offline option; under this option check the box next to 

“Create, open, and edit your recent Google Docs, Sheets, and Slides files on 

this device while offline.” 

4.​ In Google Docs, click File ➔ Make available offline. 

5.​ At the prompt click “Turn On.” 

6.​ Try to access the document in airplane mode to confirm that offline mode is 

enabled. 
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Table of Contents 
Google Docs lets you build a table of contents with just a few clicks. This is 

especially useful for long documents. This feature also has different styles and 

formatting options to choose from.  

To create a table of contents for your document: 

1.​ Click on the place in the document  where you want to add the table of 

contents. 

2.​ Click on Insert ➔ Table of contents ➔ Select from the options (plain text, 

dotted or links). 

 

 

To format the table of contents: 

1.​ Click on the Table of Contents. 

2.​ Click on the ellipses (three dots) in a small rectangular icon that appears on 

top left. 

3.​ Select your choice of formatting in the pane that appears on the right of the 

document. 
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Formatting 

How a message is conveyed in a document is often as important as the message 

itself. This is because the success of the message depends on how well the 

audience can understand and use it. Here the formatting of a document plays an 

important role. Google Docs offers users many time-saving formatting options for 

optimized productivity. Let’s look at a few of them: 

Document Tabs  
Similar to creating multiple tabs in a web browser, Google Docs allows you to 

create separate sections within a document. This helps to break down large 

chunks of texts into smaller, more manageable sections, and simplifies navigation. 

 

How to use Document Tabs: 

1.​ Google Docs by default assigns a tab to a new document. This appears as 

Tab 1 in a panel to the left of the document. 

2.​ Click on the ellipses for more tab options (like add a subtab, duplicate, 

rename, delete, copy link, etc.). 
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Personal Dictionary 
Google Docs has a feature called personal dictionary that lets you add certain 

words (such as slang or proper names) that might otherwise be highlighted in 

spell check. 

 

To use the personal dictionary, click: 

1.​ Tools  ➔ Spelling and grammar ➔ Personal dictionary. 

2.​ Type the word you want  to add. 

3.​ Click ‘Add.’ 

4.​ The word is added, and appears in a list format in this pop up window.  

5.​ Repeat step 2 and step 3 to add more words to the Personal dictionary. 

6.​ Click OK. 

To delete a word from the personal dictionary click: 

1.​ Tools  ➔ Spelling and grammar ➔ Personal dictionary. 

2.​ Click the trash icon that appears to the right of the word you want to delete. 

3.​ Click OK. 

8 



Outline 
The outline feature uses the headings feature to organize the document. This 

makes it easy to navigate to different sections in the document. 

To use the outline feature, go to:  

1.​ View  ➔ Expand tabs and outlines sidebar; this opens a document tabs 

panel on the left of the document.  

2.​ Format document headings with the Styles drop down list located to the 

left of the Font menu on the toolbar. 

3.​ An outline that is organized by headings will be automatically created in the 

left tabs panel. 

4.​ Click on different sections of the tabs panel to navigate the headings within 

the document.  

5.​ Any changes to the headings will be updated automatically in the outline 

sidebar. 

Add-ons 
If you need features that Google Docs doesn’t provide natively, you can use 

Add-ons. As the name suggests, this tool lets you “add on” to Google Docs’ 

existing features by installing third party applications. Like the Offline feature, this 

works across Google Slides and Sheets. However, since these applications are not 

created by Google, Google is not responsible for the security or performance of 

these add-ons. Thus, it is important to research them thoroughly before installing.  

One way to do this is by looking at an add-on’s publisher, overview, reviews, and 

number of users (usually more reviews and more users means high reliability). 

Researching add-ons is extremely important since they are installed onto your 

Google account and will need access some permissions. Any sensitive information 

that your account contains may be put at risk if the add-on is not from a reliable 

publisher. 
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To install add-ons in Google Docs, go to: 

1.​ Extensions ➔ Add-Ons ➔ Get Add-ons. 

2.​ Google Suite Marketplace window opens; search for add-ons by keywords. 

3.​ Select your preferred add-on and click on it to see more info. 

4.​ Read about add-on - the overview, reviews, number of users etc. 

5.​ Research on the add-on’s source and reliability. 

6.​ When ready, click Install. 

7.​ Read the terms of service and privacy policy in the pop-up window; click 

Continue. 

8.​ Select the Google account to which you want the add-on installed. 

9.​ Read carefully about the permissions the add-on will need to access your 

document.  

10.​ Once ready, click Allow. 

11.​ Another pop up explaining how to use the add-on opens; read and click 

Next. 

12.​ Click Done. 

Note: Remember to read instructions carefully, as some add-ons may ask to 

create an account or subscribe to a payment plan. 

To use add-ons, place the cursor in the document where you want to use it. Then 

go to: 

1.​ Extensions  ➔ Add-ons. 

2.​ Select the installed add-ons. 

3.​ Some add-ons open a new window to the right of the documents. 

 

Keyboard Shortcuts 
Google Docs has a list of keyboard shortcuts that you can use to speed up your 

formatting, editing, and/or navigation process. It is important to note that not all 

shortcuts work for all languages or keyboards.  

To get a list of all Google Docs keyboard shortcuts, go to: 

1.​ Help ➔ Keyboard shortcuts. 

2.​ A list of shortcuts open. 

10 



Collaboration 
People can collaborate in real-time on documents when using Google Docs. As 

long as collaborators have an internet connection, they can access the document 

shared with them. In this section we will talk about some of the different ways to 

collaborate within Google Docs. 

 

Share 
 

 

The first method is the Share button on the top right corner of the tool’s interface.  

To use this feature: 

1.​ Click the blue Share button on the top right corner of Google Docs. 

2.​ In the pop-up box, add the email of people you want to share the document 

with. 

3.​ Choose their levels of access (editor, viewer, or commentor) using the 

dropdown arrow. 

4.​ If you want to send a notification about this document to the intended 

recipients, type the message in the text box that opens. 

5.​ Click Send. 
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You can also share the document in the form of a link: 

1.​ Click  the dropdown arrow on the Share button. 

2.​ Select “Copy link”. 

3.​ This link can be shared through email, messages, or by pasting it in a 

document. 

To change access control on document shared by a link: 

1.​ Click the Share button. 

2.​ Under General access, “Anyone with the link” is checked. 

3.​ Click the dropdown arrow and choose between editor, commenter, or 

viewer. 

4.​ Click Done. 

 

Google Meet  
Google Meet is a video conferencing tool that can be accessed from Google Docs, 

Slides and Sheets. In Google Docs, its icon appears on the top right corner of the 

interface (to the left of the Share button).  

 

With this feature you can either start a video call or use the dropdown arrow to 

join a call with a meeting code. This is an excellent tool for real-time discussions 

on a document between teams in different locations. 
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Smart Chips 
This feature lets you add important details to a document to make it more 

valuable for its users. With Smart Chips you can embed necessary details about 

files, people, dates, and locations within the document so that users can access 

them without exiting Google Docs.  

 

To use Smart Chips, go to: 

1.​ Insert ➔ Smart Chips.  

2.​ From the dropdown menu that appears, choose the option (date, people, 

file calendar event, place) you want to add. 

3.​ Complete the necessary steps as prompted (steps will vary depending on 

the option selected). 

Hover the cursor over these embedded Smart Chips to use them:  

1.​ You can add a person as a Smart Chip to send an email or schedule an event 

in their calendar. You can also join an event, like Google Meet, using the 

SmartChip. 

2.​ You can add a date and select a specific time on that date. 

3.​ You can add a Google Calendar event and access it directly from the 

document. 

4.​ You can add a place to view its location in Google Maps as a pop up. 

5.​ You can add a file as a Smart Chip to open it in a new window, without 

exiting Google Docs. 

However if you do not have details about the Smart Chip while documentation, 

you can add a placeholder chip instead, that can be replaced later with the details: 

Insert ➔ Smart Chips ➔ Placeholder chips ➔ choose type of placeholder. 
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Version History 
This is an important feature that helps to track changes made by people 

collaborating on a document in real-time. It also shows who made the changes 

and when, and even allows you to name a version. Users can also revert to an 

earlier version of the document if needed.  

 

To use this feature: 

1.​ Click File ➔ Version history. 

2.​ Select between ‘Name current version’ or ‘See version history’. 

3.​ The first option opens a pop up window to give the version a name. The 

second option opens the version history tab to the right of the document. 

4.​ Scroll down to see all versions of the document. 

5.​ Alternatively, click the ellipses on the right of a version for more options like 

making a copy of the version or naming it. 

6.​ Click the arrow appearing top left to exit version history mode and return to 

the main document. 
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Summing Up 
Now that you have a good understanding of Google Docs’ tools for authoring and 

real-time collaboration, it’s time to try some of these features for yourself. So go 

ahead, explore, and take your documentation skills to the next level! 
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