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DOWNLOAD AND INSTALL IMAGE PLOT 
 

1.​ Install the current version of Java  
 

2.​ Download ImageJ (alternatively use browser version here (not very stable) 
 
INSTALL & USE TIKTOK SCRAPER   
 

1.​ Install the current version of Node.js 
 

2.​ Open Terminal  
 

3.​ Open https://github.com/drawrowfly/tiktok-scraper   
 

4.​ Run sudo npm install -g npm@8.12.1 to install the scraper from NPM 
 

5.​ Run sudo npm i -g tiktok-scraper in your Terminal to install the scraper  
 

 
 

6.​ Enter your password  
 

7.​ To check the options, consult https://github.com/drawrowfly/tiktok-scraper USAGE 
 

8.​ Note that some requests might have been deprecated 
 

9.​ E.g., to scrape _10_ videos + metadata from a hashtag query, type this command 
 
tiktok-scraper hashtag boredinthehouse -n 10 -d -z -t all   
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https://www.java.com/en/download/
https://imagej.nih.gov/ij/download.html
https://ij.imjoy.io/
https://nodejs.org/en/
https://github.com/drawrowfly/tiktok-scraper
https://github.com/drawrowfly/tiktok-scraper


 
10.​The output .zip (video files) .csv (spreadsheet file with metadata) + .json should look like  

 

 
 

11.​To scrape _all_ videos + metadata from a hashtag query, type this command  
 
tiktok-scraper hashtag boredinthehouse -n 0 -d -z -t all  
 
 

12.​Try _not_ to use all too popular hashtags such as #fyp 
 

13.​To get help, type tiktok-scraper --help  
 

14.​Alternatively, use Phantombuster TikTok phantoms to extract data  
 
 

 

 
 
DOWNLOAD IMAGES FROM A LIST OF TIKTOK VIDEO THUMBNAILS  
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https://phantombuster.com/phantombuster


1.​ Install Downthemall extension in Google Chrome 
 

2.​ Import and open the scraper output (.csv file) in Google Drive 
 

3.​ Arrange your data in a preferred order using _Sort Sheet from A to Z_ (e.g., by the time 
of posting using the column “createtime”). Use the Epoch Batch Conversion Tool to 
convert timestamps to ‘human time’ if needed. Find the column containing image URLs 
(“covers.default” or “covers.origin” for TikTok). Copy and paste image URLs into a .txt file 
(use a simple text editor, format the file in Format -> Use plain text before pasting the 
data). Save this text file in a local folder.  
 
 

 
 
 

4.​ Open Downthemall Manager  
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https://chrome.google.com/webstore/detail/downthemall/nljkibfhlpcnanjgbnlnbjecgicbjkge?hl=en
https://www.epochconverter.com/batch


 
 

5.​ Right-click in the empty field -> IMPORT FROM FILE  
 

6.​ Import the text file you just created to open “DownThemAll - Select your Downloads”  
 

7.​ Opt for “all files” 
 

8.​ Specify the mask to download the images in numeric order by typing *idx*.*ext*  
 

9.​ Click “Download”  
 

 
 

10.​Find the images downloaded to a local folder in “Downloads” (by default) 
 

11.​You will need this folder to work with ImageJ   
 

12.​In DownThemAll Manager, right-click & select _Remove download_  
 

13.​Create a new column in the spreadsheet file and name it e.g., image_num_time 
 

14.​Select all images from the folder, copy the file names and paste in the spreadsheet  
 

15.​Watch this YouTube tutorial if you use Windows (on Mac, just copy & paste) 
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https://www.youtube.com/watch?v=AI5gx3QKt8M


16.​The result is a column with the image filenames  
 

17.​You will need this column to work with ImageJ 
 
 

 
USING IMAGEJ: IMAGE PLOT AND IMAGE MONTAGE MACROS 
 
Running Image Measurements (hue, saturation, brightness) and preparing the .tsv file 

 
1.​ Open ImageJ -> Plugins ->Macros ->Run 

 
2.​ Select the folder ImagePlot Master -> ImageMeasure.txt ->Open  

 
3.​ Select the folder of images you want to analyze ->Open -> 

 
4.​ A measurements.txt file will be saved in the same folder  

 
5.​ Rename measurements.txt in measurements.tab 

 
6.​ Return to the .csv file containing image URLs + metadata in Google Spreadsheets  

 
7.​ Add new sheet by clicking + in the bottom left corner  

 
8.​ Import measurements.tab by opting for File->Import->Upload->Drag&Drop 

 
9.​ Replace current sheet -> import data  

 
10.​Make sure that the numeric order of the image column is correct 

 
11.​Copy the column filename to a new column and rename it in e.g., image_num_time 

 
12.​Delete the .jpg ending of the image file names by using Find & Replace  

 
13.​Rearrange the data in numeric order by sorting the column from A to Z  

 
14.​Copy paste the columns timestamp and digg_count next to the measurements  

 
15.​Download the sheet as .tsv file and save the file in the image order  

 
Plotting the images with ImagePlot.txt according to the time of posting and visual style  

 
16.​Open ImageJ -> Plugins ->Macros ->Run 

 
17.​Select the folder ImagePlot Master -> ImagePlot.txt ->Open  

 
18.​Opt out of “polar”, select Options in the ImagePlot menu and click OK 

 
19.​Select the .tsv file with image measurements and metadata you just created -> Open  
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20.​Select the folder of images -> Open  
 

21.​Choose data columns from the dropdown menu as follows  
 

 
 
 

22.​Select options to configure: canvas and images  
 

  
 

23.​Set the canvas size and background color as follows  
 

6 



  
24.​Format the size of image thumbnails as follows  

 

  
 

25.​Visualize & Analyze (see the slides)  
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Visualizing image data as points using the same layout  

 
1.​ Open ImageJ -> Plugins ->Macros ->Run 

 
2.​ Select the folder ImagePlot Master -> ImagePlot.txt ->Open  

 
3.​ Select Data and Options in the ImagePlot menu. Select “none” for images.  
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4.​ Choose data columns as follows*** OR opt for diggCount (like count) on the Y axis  
 

  
 

5.​ Select options as follows  
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6.​ Set the canvas size and color as follows  
 

 
7.​ Select the size and color of data points as follows  
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8.​ Select the image thumbnail width as follows  
 

 
 

9.​ Visualize & Analyze (see the slides)!  
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time VS average hue 

 
 
time VS digg count (likes count)  
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Plotting the images with ImageMontage.txt according to time frames/color similarity 

 
1.​ Return to the .csv file containing image URLs + metadata in Google Spreadsheets  

 
2.​ Next to the column “createtime” create a new column and call it e.g., “human time”  

 
3.​ Copy your timestamp list from the column “createtime” in EpochConverter 

 
4.​ Convert timestamps in human-readable dates and download as .csv file  

 
5.​ Copy the resulting list of dates to the column “human time”  

 
6.​ Create a new column, call it “Month” and specify the time frame (e.g., March, April, May)  

 
 

 
7.​ Create three separate new sheets for March, April, and May  

 
8.​ Filter your data by month and copy it into separate sheets  

 
9.​ Within each sheet, select the column hue_median and sort your data from A to Z 

 
10.​Create another sheet and merge the data (keep the same order) 

 
11.​Download the sheet as .tsv file and save the file in the image order  

 
12.​Open ImageJ -> Plugins -> Macros -> Run -> ImageJ -> Macros -> Image_Montage.txt 

 
13.​Image Source -> Data File  

 
14.​Select the options for a montage as follows  
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https://www.epochconverter.com/batch


 
15.​Select the  folder of images  

 
16.​Select the .tsv file you just created  

 
17.​Choose the column with the filenames  
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18.​Visualize (the same technique can be used with AI-enriched data, e.g., Google Vision) 
 

 
 

 
19.​Run the images through Google Vision API using MemeSpector GUI (Chao, 2021)  

 
20.​Copy the column “label description” in your TikTok data spreadsheet  

 
21.​Make sure that the order of images is correct and that the labels correspond  

 
22.​To create a montage, repeat the steps 7-15, but use the column “label description”  
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https://github.com/jason-chao/memespector-gui/releases/


 
 

 
 
BONUS1: Extract video frames from a list of videos and visualize 
them sequentially  
 

1.​ Install ffmpeg by following the updated guides on YouTube  
 
1.1 Video Guide for Mac (RickMakes 2020; works for both Catalina and Monterey) 
1.2 Video Guide for Windows (TroubleChute 2020) 
 

2.​ Structure TikTok metadata by the count of likes (digg_count) 
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https://ffmpeg.org/download.html
https://www.youtube.com/watch?v=H1o6MWnmwpY
https://www.youtube.com/watch?v=IECI72XEox0


 
3.​ Filter top 10 videos sharing a sound  

 
4.​ Download TikTok videos e.g.., using TikPac Downloader Extention for Chrome  

 
5.​ Merge videos in Clideo: https://clideo.com/merge-video  

 
6.​ Save the video file in a folder, rename the file in video.mp4  

 
7.​ Use ffmpeg python script to ‘deconstruct’ the video in a series of frames  

 
8.​ Open terminal  

 
9.​ Change directory to the folder containing the video file you just saved -> 

 
10.​Type cd, drag&drop the folder in terminal, hit enter  

 
11.​Type ffmpeg -i video.mp4 thumb%04d.jpg -hide_banner  and hit enter to get every frame  

 
12.​OR type ffmpeg -i video.mp4 -r 1 thumb%04d.jpg -hide_banner  to get every 25th frame 

 
13.​For multiple files in a folder use   

for f in *.mp4; do ffmpeg -i "$f" -r 1 "${f%mp4}thumb%04d.jpg";done  
 

14.​All individual frames will be saved in the same folder as the original video file   
 

15.​Select all images from the folder, copy the file names and paste in the spreadsheet  
 

16.​Watch this YouTube tutorial if you use Windows (on Mac, just copy & paste) 
 

17.​The result is a column with the image filenames  
 

18.​(Optional) To select, e.g.,  every 10th image frame, use this formula in Google sheets  
 

19.​Filter by condition -> custom formula is =mod(row(A1),10)=0 
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https://chrome.google.com/webstore/detail/tikpak-downloader/mgpfdecanbjnfbnkndpcpapjlhdgmlcf?hl=en
https://clideo.com/merge-video
https://www.youtube.com/watch?v=AI5gx3QKt8M


 
 

20.​Copy & paste the result in a new sheet 
 

21.​Download the sheet as .tsv file and save the file in the image order  
 

22.​Open ImageJ -> Plugins -> Macros -> Run -> ImageJ -> Macros -> Image_Montage.txt 
 

23.​Explore the results -> rethink the vis in terms of ethical fabrication (Markham 2012) 
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https://www.tandfonline.com/doi/abs/10.1080/1369118X.2011.641993


BONUS2: Visualise relations of ♪BOREDINTHEHOUSE co-hashtags 
and image content using GV API labels and RAWGRAPHS 
 
 

1.​ Open a spreadsheet containing TikTok #boredinthehouse data  
 

2.​ Download TikTok video thumbnails to a local folder (see how-to here) 
 

3.​ Copy and paste the filenames to a new column (see how-to here) 
 

4.​ Run the images through Google Vision API using MemeSpector GUI (Chao, 2021)  
 

5.​ More on Memespector GUI: Enriching Image Data with AI here (Chao & Omena, 2021) 
 

6.​ Copy the column “label description” in your TikTok data spreadsheet  
 

7.​ Make sure that the order of images is correct and that the labels correspond  
 

8.​ Filter the sheet by “boredinthehouse” sound-meme using the column “music meta” 
 

9.​ Copy data in a separate sheet  
 

10.​Extract hashtags from the column “text” -> 
 

11.​Use the formula =trim(regexreplace(A2, "(^|\s)[^#]\S*", ""))  
 

12.​Copy hashtags and “paste special” to a new column by using “values only”  
 

13.​Copy the hashtag column to TagCrowd  
 

14.​Select three #boredinthehouse co-hashtags (e.g., quarantine, comedy, dance) 
 

15.​Filter the sheet using the first hashtag #quarantine 
  

16.​Copy & paste the filtered hashtag column to TagCrowd & calculate the frequencies  
 

17.​Make sure to use quarantine, comedy, dance, boredinthehouse as stopwords  
 

18.​Copy & paste the frequencies to a new sheet  
 

19.​Use Data -> Split text to columns -> custom. Type “) “ 
 

20.​Paste transposed  
 

21.​Use Data -> Split text to columns -> custom. Type “ (“ 
 

22.​This should result in this type of hierarchy (top 10 #quarantine co-hashtags + count)  
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https://docs.google.com/document/d/14sMuAOwAwYwPJP4P2tpLdjm_t-_eKY_GQVUys1k46t0/edit
https://docs.google.com/document/d/14sMuAOwAwYwPJP4P2tpLdjm_t-_eKY_GQVUys1k46t0/edit
https://github.com/jason-chao/memespector-gui/releases/
https://docs.google.com/presentation/d/119g8GYHJOlETOSpVAyuyLoSU-SqrcR7YpH1fKMuuexw/edit#slide=id.ge1e178e89c_0_0
https://tagcrowd.com/
https://tagcrowd.com/


 
 

23.​Repeat the steps 14-21 using the column “label description”  
 

24.​This should result in this type of hierarchy (top 10 labels related to #quarantine) 
 

  
 

25.​Merge all columns in the same sheet  
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26.​Repeat the same procedure for #comedy and #dance OR (if familiar with Gephi, build a 
bi-partite hashtag-image label network and export ego-networks for each hashtag as a 
spreadsheet). 
 

27.​Merge everything in one sheet and copy to RawGraphs  
 

28.​Select “Alluvial Diagram” 
 

29.​Map the chart variables as follows  
 

 
 

30.​Customize the artboard  
 

31.​Define the color scheme -> spectral discrete  
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https://rawgraphs.io/


32.​Sort nodes by -> minimize overlaps  
 

33.​Flows alignment -> bottom  
 

34.​Adjust link opacity  
 

35.​This should result in a visualization like this  
 

 
 

36.​Export or make a screenshot  
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