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Introduction 
 

Electronic designs aren’t always created in one single EDA package, for example Schematic 
Designs could be created in xDxDesigner but the PCB Designs in PADS Layout. If this was 
the case, then to import the complete design into Altium two separate imports are going to 
have to be made. 

This short guide will show you how to link the separately imported files into a complete PCB 
Project within Altium Designer and carry out important synchronisation techniques. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Bringing Together Imported Schematic and PCB Designs ​ ​ Page 3 of 16 
 



 
 
 

 Table of Contents 
​ ​  

 

Getting Started 
 

After importing you will be left with two separate PCB projects, one containing the PCB 
Design and the other containing the Schematic documents. 

 

In this example I have imported a PCB design from Allegro and the schematics from OrCAD 
Capture.  
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 Merging Projects 
 

Add Existing to Project 
 

Close either project, I’m going to close the project containing the single PCB document to 
make less work later. 

 Before you close the project, you may wish to right click the PCB file and go to Explore 
so you know where the file is saved. 

Right click on the remaining project and go to Add Existing to Project. 

 

Navigate to PCB File we just closed and add it to our project. 
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We have now brought a complete design into Altium Designer and successfully linked them 
into a single PCB Project. However, we aren’t finished yet. 

 

 

 

If the PCB document is not in the same project folder as the 
destination project, you will see a small arrow on the file in 

the projects tab . Ideally, you would move the project 
files in the same folder directory, i.e. use File » Save As on 
the document to create a copy in the same location, however 
it won’t cause any issues if they’re not. 

 

 

 

 

 

 

 

 

You should now compile your project by going to Project » Compile PCB Project this will 
generate a list of errors and warnings (if there are any) which you might need to rectify. See 
Post Import Tidy Up section for more information on Error Checking your Schematics. 

When you select Project » Compile Project this will determine the connectivity between the 
sheets. Once complied you will be able to carry out post-compilation activities, such as 
comparing and showing differences between schematics, parameter managing, parametric 
navigation of your design, and cross probing back and forth between the schematics and 
PCB. 
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 Post Import Tidy Up 
 

Referring to the migration guides again, you will remember a section on post import actions. 
This might be a good time to carry those out, I’ve included them below. How to carry some of 
these checks can be found later in the document. 

❑​ Physical check 
❑​ View » Fit Document 
❑​ Board shape and cut outs 

❑​ Electrical check 
❑​ Netlist 

❑​ Rules 
❑​ Have all rules been imported 
❑​ DRC check 
❑​ Check settings for polygons - Island removal, min primitive size 
❑​ Thermal reliefs, direct connect 
❑​ Check power plane settings 
❑​ Power plane Pull-back 
❑​ Solder mask, Paste mask rules 
❑​ Via Tenting 
❑​ Testpoint assignments 

❑​ Power check 
❑​ Nets 
❑​ Planes 
❑​ Polygons 

❑​ Documentation check 
❑​ Layers 
❑​ Text/Strings 
❑​ Legends 

❑​ PCB reports 
❑​ Number of components/nets 
❑​ All nets routed 
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 Component Links 
 

In Altium Designer, Unique ID (UID) values allow schematic and PCB objects to remain 
associated with one another even when their component designators have been modified in 
one editor. 

However, you will find that all links between schematic and PCB components are removed 
when you import from another software. Re-establishing the UID linking is easy, but it must 
be done based on the designators. 

First, reset all Unique ID values on the schematic side, by 
selecting Tools » Convert » Reset Component Unique IDs from the schematic editor 
menus. Ensure that you reset the Unique ID’s for All schematic documents in the current 
project. 

 

 

 

 

 

Open the PCB editor and navigate to the Component Links dialog (Project » Component 
Links).  
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First, add pairs by matching designators (the default correlation). 

 

Then perform the update. 

 

An underlying difference between Altium Designer and other EDA software packages is that 
establishing links is not a prerequisite to synchronization. If, for example, you skip the 
sequence described above and simply try running update/import commands on a PCB 
design you brought into Altium Designer, you will be informed that, although synchronization 
by Unique IDs has failed, you may still proceed to match by designators. Doing so will not 
have any effect upon the Unique ID fields in your design, meaning that if you repeat the 
process, the same status will be reported. Assigning the same Unique ID values to 
schematic components and PCB footprints is the only way to create persistent links between 
them. 
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 Error Checking your Schematic 
 

Earlier we ran the compile process to build the sheet to sheet connectivity of our imported 
project. Running this compile process will also run error checking on the project, which will 
inform you of any drafting or electrical rule check errors. 

Error Checking options can be set under Project » Project Options » Error Checking and 
largely covers your drafting errors. 

 

Each violation can be set to the following levels of reporting and so customised to suite your 
needs 

 
Provides no feedback about the violation 

 Listed as a warning in the messages panel, useful information but 
doesn’t necessarily need fixing 

 Listed in the Messages Panel, panel will open, if closed, if you 
have an error.  

 Listed in the Messages Panel, panel will open, if closed, if you 
have an error.  
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Electrical Rule Checking can be found under Project » Project Options » Connection 
Matrix. Clicking on the coloured blocks allows you to set the reporting severity. 

 

Resolving Schematic Errors 
 

Common errors/warnings you may find. 

●​ Nets with multiple names 
-​ Often caused by an improper placement of a net label onto another net 
-​ Use the Details area of the Messages panel to determine the net label and 

location 
-​ Double-click the Detail entries to navigate to that item 
 

●​ Nets with no driving source 
-​ Can be caused by passive pins diving input pins for example a connector or 

series passive component 
-​ Edit the connector/passive component pin to the appropriate electrical types  
-​ Can be disabled in Project Options » Error Reporting or by placing “No ERC” 

markers 
 

●​ Nets containing floating input pins 
-​ If the pin is not used either tie it to the appropriate power line (e.g. GND) or place 

a No ERC directive on it. 
 

Documentation and help on finding and resolving errors can be found here 
Compiling and Verifying the Design 
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 Design Synchronization 
 

Design Synchronization is integrated in Altium Designer without the need for passing a net 
list. Synchronization in Altium Designer is also bi-directional, allowing you to make 
annotation changes and component property updates in both directions between your 
schematic and PCB, in a single operation. 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 1. Flow of the synchronization process in Altium Designer 
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Engineering Change Order (ECO) 
 

Once you’ve compiled your project, linked Unique ID’s and rectified any errors that you can, 
you should undergo an Engineering Change Order. 

 

The Engineering Change Order dialog lists all modifications required to implement changes 
to one or more design documents, to satisfy the synchronization action requested. For 
example, you may be synchronizing the PCB document with its source schematics, or 
updating the parameters of placed components source schematics, with parameter 
information stored in source libraries or a company database. Whatever the specific action 
requested, the Engineering Change Order dialog allows you to browse, verify and execute 
the necessary modifications that comprise the ECO. 

You should validate the changes first, this validates the ECO before executing it. When an 
ECO is invalid (a red cross in the Status column of the dialog), it means the required ECO is 
not possible, for example, a component or a footprint could not be found because the 
required library is not loaded. 

 

In the ECO above, I have some invalid changes which won’t be carried out when the ECO is 
executed. Rectify these errors before executing the ECO.  
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Resolving Synchronization Errors 
 

Most problems with synchronizing a design generally fall into two categories: 

 

Missing component footprints.  
●​ Common causes: 

-​ A footprint model is missing from the component information in the schematic. 
-​ You have forgotten to add the required PCB libraries to the currently available 

libraries. 
-​ The component in the schematic does not match any PCB library component. 

 
Footprint pin numbers not matched to schematic pin numbers.  

●​ Common cause: 
-​ Altium Designer supports user-definable pin-to-pad mapping, the default 

behaviour is to expect the same number/letter on both sides. Pin-to-pad mapping 
is defined in the PCB Model dialog (edit the schematic symbol, select the footprint 
in the Models region of the dialog, and click Edit). 

 

If you get any of these errors, check to see if any of the common issues are a fix for your 
design. 

 

Carrying Out a Design Rule Check 
 
Once you are happy that your schematic and PCB designs are fully synchronised you can 
continue to carry out a Design Rule Check.  

 

Design Rule Checking (DRC) is a tool that checks both the logical and physical integrity of 
your design. Checks are made against any or all enabled design rules and can be made 
online, as you work, and/or as a batch check, with results listed in the Messages panel and 
a generated report. This feature should be used on every routed board to confirm that 
minimum clearance rules have been maintained and that there are no other design 
violations. It is particularly recommended that you perform a design rule check after 
importing a design into Altium from other EDA packages in case any design rules are 
conflicting.  

Some translations my not support the import of your existing design rules, in which case you 
may need to set new constraints for the imported board. For information on creating design 
rules please take a look at Constraining the Design - Design Rules  

To carry out a DRC, switch to your PCB Document and go to Tools » Design Rule Check. 
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The design rule checker dialog will open, here you can configure the DRC and decide on 
which rules you would like to be checked. 

Click the Run Design Rule Check when you are happy with the configuration. 

If you checked the ‘Create Report File’ option when configuring your DRC, then a 
verification report will be generated listing all rule violations in your design. 

For more information on performing a DRC look at the Design Rule Checking documentation 

If you have a lot of Un-Routed Net Constraint errors, try running Design » Netlist » 
Update Free Primitives from Component Pads This command is used to 
resynchronize the net name of the routing primitives to the net name on the pads they 
connect to. 

 

After resolving any rule violations, your design has now been successfully imported into 
Altium Designer! 
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 See Also 
 

Below are references to other articles and tutorials in the Altium Designer Documentation 
Library that talk more about the conceptual information as well as walking you through 
specific tasks. Remember, you can also browse through the Help contents, and use F1 at 
any time in a dialog for more details. 

 

•​ If you are new to Altium Designer this tutorial takes you through the entire design 
process, from idea to outputting your manufacturing files. From Idea to 
Manufacture - Driving a PCB Design through Altium Designer. 

 

•​ A look at how connectively in handled in Altium Designer. Creating Connectivity.  
 
•​ For a tutorial that steps you through all the basics of creating components, read A 

Look at Creating Library Components 
 

•​ For a tutorial that steps you through all the basics of editing multiple objects, read 
Schematic Placement and Editing Techniques and Placing and Editing PCB 
Objects. 
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