Конфигурация других устройств базовая.

msk-arbat-gw1

hostname msk-arbat-gw1

!

interface Loopback0

 ip address 100.0.0.1 255.255.255.255

!

interface FastEthernet0/0

 description Balagan_Telecom_Internet

 ip address 101.0.0.2 255.255.255.252

 duplex auto

 speed auto

!

interface FastEthernet0/1

 description Philkin_Certificate_Internet

 ip address 102.0.0.2 255.255.255.252

 speed 100

 full-duplex

!

!

router bgp 64500

 no synchronization

 bgp log-neighbor-changes

 network 100.0.0.0 mask 255.255.254.0

 neighbor 101.0.0.1 remote-as 64501

 neighbor 101.0.0.1 route-map BGP2_IN in

 neighbor 102.0.0.1 remote-as 64502

 neighbor 102.0.0.1 route-map BGP1_IN in

 no auto-summary

!

ip route 100.0.0.0 255.255.254.0 Null0

!

ip prefix-list TEST1_IN seq 5 permit 120.0.0.0/24

!

ip prefix-list TEST2_IN seq 5 permit 103.0.0.0/22

!

route-map BGP1_IN permit 10

 match ip address prefix-list TEST1_IN

 set local-preference 50

!

route-map BGP1_IN permit 20

 set local-preference 100

!

route-map BGP2_IN permit 10

 match ip address prefix-list TEST2_IN

 set local-preference 50

!        

route-map BGP2_IN permit 20

 set local-preference 100

!