Procedural Guide for Business Systems @ NEFEC Educational Technology Services

Excel Power Query for Skyward Data Mining

Power Query is a data transformation tool built into Microsoft Excel and Microsoft Power BI. It allows users to connect
directly to a data source and then extract, transform, and load data into a spreadsheet, table, pivot chart, or data model.
Excel’s Power Query allows district users to create reusable spreadsheets that can be refreshed with an updated data file.

Although this process takes time to setup, once the initial setup is complete, data files can easily be refreshed.

Skyward Data Mining Report

The following is an example of a summary data mining report from Skyward referencing expense accounts only. This
same process can be applied to other accounts as well.

* Report Parameters Edit Report Parameters

Print Totals: Mo

Notes:
Consolidate Funds: No Report Access for Other Users: Read-only
Budget Status: All accounts Additional Printing Prompts: None
Print Details: Yes Date Created: 11/24/2020
Detail Spacing: Single Created By:

FFEMRE ID: 11391

Suppress fero Amounts: Mo
Accounts Excluded: None

Do not use breaks. This report will produce no totals. Excel will handle the analysis.

w Breaks Edit Breaks

Sequence: R - Regular account sequence

Mo break has been defined.

w Account Ranges Edit Account Ranges

Ranges: Groups/Category Low High
Level 1 i
Level 2 s

7777

Limited to expense accounts. e

Account Status: Both Active and Inactive

Operatina Statement (0/8)
"Expense
“Low Account. 0000 * 0000 0000 0000 00000 00000 00000
High Account: 9999 * 9999 9999 7777 77777 77777 77777
Include Filters
No Include filters defined
Exclude Filters
Mo Exclude filters defined
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w Field Selection Edit Field Selection
Description Heading Heading2 Column
Account Number FundTFunc Obj Fac Proj Subpr Prog 1
Fund Fund 2
Fund Fund 3
Function Func 4
Function Func 5
EXPENSE Object
EXPENSE Object Repeating account dimensions
i follow this pattern:
Facility OBJECT Number
b OBJECT Description

roject

Subproject M ————
Subproject Subpr 13
Program Frog 14
Frogram Frog 15
Criginal Budget Criginal Budget 16
Fevized Budget Revised Budget 17
Fiscal Year Credits FY Credits 18
Fiscal Year Debits FY Debits 19
Fiscal Year Activity FY Activity 20
Fiscal Year Unencumbered Bal Unencumbered Balance - FY Act 21
Fiscal Year Unexpended Bal Unexpended Balance - FY Act 22
Encumbrered Amount Encumbered Amount 23
Available Funds Available Funds 24

Once the data mining report is configured, run the report as an Excel file. Save the file to the local machine.
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Power Query

Create a desktop folder and move the Excel file into that folder. Next, open Excel, (1) click on the Data tab and select (2)
Get Data > (3) From File > (4) From Folder. Replace the report in this folder each time the data mining report is run to
keep the data visuals in Excel up-to-date.

View Help

B3 I

Organization St

File Horme Insert Draw Page Layout Formulas

o Text/CSV [8) Recent Sources T Queries & Connections
I

Existing Connections g i
EEI g Refresh D Properties

All~ [ Edit Links

nections Data Type!
D From File m Workbook
EF:? From Database z I:E From Text/CSV H [ J
[?= From Azure > From XML
I,
From Power Bl (nefec.org) From JSON
[T

[Ej From Online Services > [Por] From PDF

ﬁ . Other S D ; Fold From Folder
rom er Sourc
g*c‘ - 1 AULDLsLLE Import metadata and links about
T

% files in a folder.

% Combine Queries > [E From SharePoint Folder

From within the browse window, select the folder containing the data mining file.

X Browse
<« v 4 BN > This PC Desktop

Organize « Mew folder

W This PC Mame Date modified
."' 3D Objects I! phifilesource$ (dataxferprmii

M Deskiop = NEFEC-Public (nricdc.orgx-dri

E Documents
-

l MyDataMiningReports File folder
r 1 File folder
B Pictures /19/2021 10:24 A File folder

Downloads

Music

File folder
File folder

= Windov

File folder
£ pbifilesources ataxferprm01) |
£ skyward (\\172.16.3.123) (P:)
£ NEFEC Metwork Share (X:)
oo

Folder name:| MyDataMiningReports
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Click Combine & Transform Data to launch the Power Query Editor.

\\nricdc.org\home-drive\HDrives\SaylerA\Desktop\MyDataMiningReports

Content Name Extension Date accessed Date modified Date created Attributes
Binary SKR203654E50508E911490.csv | cov 8/26/2021 2:01:47 PM | 5/26/2021 1:48:05 PM | 8/26/2021 2:01:47 PAM | Record V\nricdc.org\ha

< >

Transform Data Cancel

ombine & Transtorm [ata
Combine & Load

Combine & Load To...
Click OK to continue.
o X
Combine Files
Specify the settings for each file. Learn more
Sample File:
| First file -
File Crigin Delimiter Data Type Detection
| 1252: Western European (Windows) ~ | | Comma M | | Based on first 200 rows - [3
Columnl Column2 Column3 Columng Column5 Columnb Column7? Columng
Account Number Fund Fund Desc Func Func Desc Ohbj Obj Desc Fac

1000E5100 1120 5010 99990 00000 00000 | 1000 GENERAL FUND | 5100 BASIC (FEFP K-12) 11 RECTORS 9010

a - . - N
1000E5100 1200 0042 92020 00000 00000 | 1000 GENERAL FUND | 51w BASIC (FEFP K-12) | 1204 CLASSROOM . _~.nERS 0042 v
1000E5100 1200 0042 92070 F2020 00000 | 1000 GEMERAL FUND | 5100 BASIC (FEFP K-12) | 1200 CLASSROOM TEACHERS 0042

< >

[ Skip files with errors Cancel
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In the Applied Steps box on the right of the screen, click the “x” next to “Change Type”. Next, right click on the column
labeled “Source.Name” and select Remove.

Home Transform Add Column View

,)’_j D :e5 Properties LI Y s 2

s | =
E = [=} Advanced Editor X EEEI EEE' || [
Close & Refresh Choose  Remove Keep Remove St
Load~  Preview - [ Manage ~ Columns = Columns = Rows~ Rows ™ Colu
Close Query Manage Columns Reduce Rows Sort

:"‘ﬂ”"“‘—< = Table.TransformColumnTypes (#"E
4 Transform File fro...
< Helper Queries [3]
El Sample File
SKR203654ES

e
B Parameter (Sa.. SKR203654E5

fx Transform File SKRI03654ES Duplicate Column
PR Transform Sampl... SKR203654E5| [ Add Column From Examples...

4 M Other Queries [ SKR203654E5 Remove Duplicates
SKR203654E5 D s e e

From the Home tab, select Remove Rows > Remove Top Rows and enter “1” to remove the top row.

File Transform Add Column View

> E‘P:lPrnperties L4

= e - x
Dﬁdvanced Editor

Close & Refresh Choose  Remove

Load~  Preview= ] Manage ~

Tald P

Query Ma

<

Remove Alternate Rows

B
EE- A Colu Remove Duplicates

4 M Helper Queries [3]

E 5 le Fil l_?.; Remove Blank Rows
ample File

AccountN |~ pemove Errors pd
1000E5100 TT20 9010 99990 00000 00000 1000

B Parameteri (5a...

One the Home tab, click Use First Row as Headers.
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Transform Add Column View

ETranspnse Data Type: Text - {,2

Detect Data Type @
E:Ij Rename EEH

Click on the column heading “Account Number.” Please press Shift and click on the program description column to select
all the columns between the two. Next, click Transform > Data Type > Text.

File Home Add Column View

% @ B Transpose Data Type: Any 7| %, , Replace Values = 5, Unpivat Columns * ] IM/(; /] Merge Columns o D0E 102 ] Trigonometry - T ,-T:I i Expand
[ £
2 Re Decimal Number pe [T] Fill = I move ~ i 455 Extract ~ = [=]x] " Rounding ~ — o FR2 agaregate
Group Use First Row N o o Split  Format be Statistics Standard Scientific — . Date Time Duration )
By  as Headers~ JC¢ Currengy 5L Pivot Column [ convert to List Column~ = 55 Parse - . B Information - = = o S extract Values |
‘Whole Number Any Column Text Column Mumber Column Date & Time Column Structured Col

Percentage

Date/Time
Date

020-21 Original Budget [l

Time o
0.00
Date/Time/Timezone Select all these columns between 000
Duration Account Number and Program 000
Text :
0.00
Ti |
rue/False No Program 0.00
Binary 0.00

Select all columns from “Original budget” to “Available funds”. Next, click Transform > Data Type > Decimal Number.

Home I Transform I Add Column View

% @ 28 Transpose Data Type: Any = 1, Replace Values ~ 5 Unpivet Columns ~ i A/(; 1+i Merge Columns Xo OoE 102 £ Trigonometry - B
— Bl -
GERe Decimal Number ype Fill = ¥ Move - i 55 Extract ~ z =1 % Rounding - i3
Group Use First Row = Split  Format b Statistics Standard Scientific — . Date Time Duration s
By as Headers ~ ;E Ce Currency 3 Pivot Column |:| Convert to List Column = - E,é Parse = - - - Informatlon - - - - B
Table Whaole Number Any Column Text Column Number Column Date & Time Column
Percentage
4« M Transform File fro. Date/Time — — — — _—
o e Date Jebits 155 2020-21 FYTD Activity  [Bll 135 UnencumberedBal [l 135 Unexpended Bal B 155 Encumbered B 135 Available Funds
elp
. - Time 0.00 0.00 0.00 0.00 0.00
El Sample File
E - . Date/Time/Timezone 0.00 0.00 0.00 0.00 0.00
‘arameter] (Sa
= Duration 0.00 0.00 0.00 0.00 0.00
Jx Tra n File I 0.00 T00 o100 o0 o0
Tawt

If there are any remaining blank columns, select those columns, right click and choose Remove.

08/26/2021 Excel Power Query Data Mining Page | 6



Procedural Guide for Business Systems @ NEFEC Educational Technology Services

Sl == =7 "7 T 7T a1y pc

L Time Column Structured Column

Tiery Saettinas
Query >ettings
Copy
Remove
Remove Other Columns
Duplicate Column

Bl Add Column From Examples...

Remove Duplicates

Remove Errors

n __ —
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Label columns as desired. Click Home > Close & Load (arrow down) > Close & Load To....

File Transform Add Column Wiew

,)'_j D e Properties L
= LT Advanced Editor X

lose & Refresh Choose Eemove
Load~ | Preview~ [ Manage ~ Columns = Columns =
ﬁ'j Close & Load ¥ Manage Columns

T
O — H
E fr B = Tanis

Excel provides several options for importing the data, please select Table and check the “Add this to the Data Model”
box.

Import Data

Select how vouwant to view thisdata in your workbook.

@Tabe:

O PivotTable Report

) PivotChart

() Only Create Connection

Where d:Eu want to put the data?
l:::l Existing worksheet:

Bl

|

=5A51
@ Mew worksheet

Add this data to the Data Model

Properties... - Cancel
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Pivot Table

Select Insert > PivotTable > PivotTable.

PivotTable

|f[| Frorn Power Bl (nefec.org)

Click OK for the default options.

Create PivotTable

Choose the data that you want to analyze
@ Select a table or range
Table/Range: | MyDataMiningReports
ID Use an external data source
Choose Connection...

Connection name:
ID Use this workbook's Data Model

Choose where you want the PivoiTable report to be placed
(®) Mew Worksheet
(::l Existing Worksheet

Location:

Choose whether you want to analyze multiple tables

|:| Add this data to the Data Model

I

i 4

Cancel

A

@ NEFEC Educational Technology Services
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Drag and drop fields into the appropriate boxes to design the pivot table. The “Filters” box is especially helpful to create
an interactive pivot table.

1000E5300 1200 0011 92090 00000 00000 <

Drag and drop fields into "Filters", "Rows",
"Columns", and "Values" as needed to create
pivot table.

ow Labe | Sum of 2020-21 Original Budget Sum of 2020-21 FYTD Activity Sum of Available Funds

= GENERAL FUND 3650635.19 2823346.9 1020508.76
1000E5300 1200 0011 92090 00000 00000 | 0 0
1000E5300 1200 0011 99790 F2020 00000) 0 0
1000E5300 1200 0011 99790 F2021 00000) 0 0
1000E5300 1200 0012 50160 00000 00000 119803.28
1000E5300 1200 0012 50170 00000 00000 625
1000E5300 1200 0012 92090 00000 00000 1597.76
1000E5300 1200 0012 97770 00000 00000) 836603.18
1000E5300 1200 0012 98100 00000 00000
1000E5300 1200 0012 98200 00000 00000
1000E5300 1200 0012 98300 00000 00000 Drag fi
1000E5300 1200 0012 99790 F2020 00000)
1000E5300 1200 0012 99790 F2021 00000} Y Fiters L) Catmre
1000E5300 1200 0012 99990 00000 00000 5565 2 Values hd
1000E5300 1200 0043 50170 00000 00000 4400
1000E5300 1200 0043 92020 00000 00000 0
1000E5300 1200 0043 92050 00000 00000) 0 0
1000E5300 1200 0043 52090 00000 190.82 1493.18\
1000E5300 1200 0043 97770 00000 353873.28 12920.72 . = Values
1000E5300 1200 0043 59790 F2020 rr— Sum of 202021 Origine. =

100085300 1200 0043 59790 F2021 Account Number Sum of 2020-21 FYID .. ~
1000ES300 1200 0043 59990 00000
Sum of Available Funds

1000E5300 1200 0051 90170 00000
1000E5300 1200 0051 92090 00000
1000E5300 1200 0051 95540 00000

Sheetl MyDataMiningReports ® E 2 =
Ready L& Display Settings g -——%—+ 100%

For each of the items in the “Values” box, click the down arrow and then select Value Field Settings.
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Move Up
Mowve Down

Move to Beginning

| Fund - Mowve to End
| Func - ]

: T Move to Report Filter
[ obj -

- Il Moveto Row Labels
| Proj "

> | = Moveto Column Labels
X Move to Values

| Fund Desc | X Remove Field
[AccountNumber L@ Value Field Settings..

Update

Update the field name, if desired. Click the Number Format button in order to change to currency or accounting.

Ly L1

L]

Format Cells

Sum of 2020-21 Original Budget Sum of 2020-21 FYTD Ag

3650635.19]

282

000000 00000 o
0 F2020 00000 1]

0F2
000
000
000
000
000
000
000
0F2
0F2
000
000
000
000
000

000

Value Field Settings ? >

Source Mame: Available Funds

LCustom Mame: | Available Funds

Summarize Values By  Show Values As

Summarize value field by

Choaose the type of calculation that you want to use to summarize
data from the selected field

MNumber Format oK Cancel

0 F2020 00000 a

0 F2021 00000

=1

0 OO0 00000 0

119

836

353

Mumber

Category

Sample

$3,650,635.19

Accountin

Decimal places: |2 =
> Decimal p 52

Time Symbol: |5 >
Percentage

Fraction Negative numbers:

scientific
Text §1,234.1

Special (51,234.10)

Custom (51,234.10)

Currency formats are used for general monetary values, Use Accounting formats to align decimal
points in a column,

The data is now in the form of an interactive pivot table, which allows the user to filter the data. The process detail here
needs to be done once and then the file can be saved. When the data needs to be updated, run the data mining report in
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Skyward with updated dates (the report must stay in this exact format — only the data changes). That Excel version of the
data mining report can be downloaded from Skyward and then REPLACE the file in the folder. Once the file has been
replaced, simply click the “Refresh” button to bring new data into the Excel data model.
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