A brief journey to the unknown (MaslowCNC software on Win$ 10)
(This is intended for users fresh to Arduino and/or Win$ 10 and/or Zip. {very/too detailed})

Intro ({reading optional} This is part satirical and part true ;-)):

A Maslowian running Win$ 10 needed help and in future there will be more.

Maslowians stick together and help each other. Globally, without borders of countries, race,
skin colour, operating systems, religion or political and personal views.

Turning solid pieces of woods, aluminiums and plastics into chips and products is a common
goal that fuses us together.

Although earning a living with Win$ for ~20 years, it was my personal decision to kick it out
of my personal life (~ forever) 11 years back.

To help our Maslowian friend | took a hard step (temporary) right back (from XP) into
Windows 10 to create this tutorial. | love watching horror movies, but being a part of it is a
different thing.

Anyhow, | asked my girlfriend and partner in life for a cross, put it around my neck and
requested her Win$ 10 laptop. Thank you Jackie!

Then | layed out a pentagram with garlic on my desk (I did not have access to a chicken,
otherwise | would wave used the foot to sprinkle the pentagram with the chicken blood).

| placed the laptop in the middle and had some whisky to gain courage.

A few sprinkles of holy whiskey on the keyboard, another drink and | convinced myself that
now evil could obsess me during this journey.

The journey (The Arduino IDE was installed with our friend, so this part is missing):

1) Navigate with your favorite browser to https://github.com/MaslowCNC
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<« e ® ® @ https//www.google.com/search?client=firefox-b&qg=github+maslow-+cnc&spell=1&s O % noHAp A =
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About 11,500 results (0.24 seconds)

MaslowCNC - GitHub @

https://github.com/MaslowCNC v

GitHub is where people build software. More than 28 million people use GitHub to discover, fork, and
contribute to over 85 million projects.

MaslowCNC/Mechanics @ Releases @
GitHub is where people build There have not been many changes
software. More than 28 million ... to Ground Control ...

MaslowCNC/GroundControl @ Wwiki @

MaslowCNC/GroundControl - Code MaslowCNC/GroundControl -
Issues 67 Pull requests 1 ... Raspberry Pi- CAM - ...
MaslowCNC/Firmware @ Electronics @

MaslowCNC/Firmware - Code Issues Electronics Setup.
20 Pull requests 0 ... OliverGonzalezlLeon edited this ..

More results from github.com »

How to Edit the Wiki - Maslow CNC

www.maslowenc.com/howtoeditthewiki/ ¥

How to Contribute to the Wiki. The Wiki is our community repository of information. It's where we keep
our documentation, share resources, and put information ...

Maslow CNC



https://github.com/MaslowCNC

2) Click on ‘Firmware’

&« C @® @& GitHub, Inc. (US)

https://github.com/MaslowCNC

H o O Microsoft is acquiring GitHub! Read our blog and Satya Nadella's post to learn more.

O Features Business Explore Marketplace Pricing

This organization
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Sign in o1 Sign up

111 MaslowCNC

[ Repositories 4 People 1

Pinned repositories

Firmware

Maslow Firmware

®c++ K133 ¥70

Electronics

Projects 0

This is the main control board for the Maslow CNC
router. It is designed to mate with an Arduino Mega

2560

e

GroundControl

This is the Ground Control software used to control
the Maslow CNC Machine
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Digital Design Files
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3) Click on ‘releases’
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https://github.com/MaslowCNC/Firmware

E ar O Microsoft is acquiring GitHub! Read our blog and Satya Nadella's post to learn more.

O Features Business Explore Marketplace Pricing

This repository
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Sign in o1 Sign up

MaslowCNC / Firmware © Watch 44 & Star 133 YFork 70
<> Code Issues 20 Pull requests 1 Projects 0 Wiki Insights
[
E:l Join GitHub today Dl
GitHub is home to over 20 million developers working together to host and
review code, manage projects, and build software together.
[Sanw |
Maslow Firmware
{1,708 commits ¥ 2 branches © 54 releases 22 26 contributors sfs GPL-3.0
Latest commit ce31205 5 days ago o

https://github.com/MaslowCNC/Firmware/releases 1P Version number




On top you will find the latest release.
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H o O Microsoft is acquiring GitHub! Read our blog and Satya Nadella's post to learn more.

O Features Business Explore Marketplace Pricing This repository Sign in o1 Sign up
MaslowCNC / Firmware OWatch 44 Kstar 133 YFork 70
<> Code Issues 20 Pull requests 1 Projects 0 Wiki Insights

Maslow Firmware 1.14

Vi
© 13fag0a o BarbourSmith released this 6 days ago - 2 commits to master since this release

Verified
Assets
[D) Source code (zip)
[@) Source code (tar.gz)
Firmware 1.14 adds better support for VERY large arcs, adds support for the TLE5206 board, and
improves and clarifies some warning messages.

https://github.com/MaslowCNC/Firmware/releases/latest v

With Firmware and GroundControl it is advisable to always have the latest and matching
version numbers. Bugs discovered in previous releases are fixed. Do this every 2 weeks
(current update interval) to stay up to date.

4) For Win$ 10 click on ‘Source Code (zip)’ and save the file to a location where you will find
it.
It it advisable to have a folder created beforehand, like ‘Maslow’ to keep things together.



Q Enter name of file to save to...

A 5 This PC » UserName (C1)> downloads > Maslow > v O Search Maslow

Organize ~ New folder

= Documents “ Name Date madified Type Size

= Pict ..
ctures i" Firmware-1.14.zip 05-Jun-18 11:22 PM Compressed (zipped)... 1,121 KB
™ downloads

*u
.

-

& OneDrive

= This PC
m Desktop
5 Documents
& Downloads
b Music
= Pictures

B Videos

£ Local Disk (C:)

v

File name: | [FIENEI M EFls) ~

Save as type: Compressed (zipped) Folder (*.zip)

~ Hide Folders Cancel

5) (Since you are already on GitHub, navigate to GroundControl and download the latest
release from there as well).

Navigate with the file browser to the downloaded firmware file.

Click once on the file with the zipper icon.

On the top of the filemanager there should be an option to extract the compressed file.
(Optional, ‘right click’ on the file and choose ‘Extract All...")



| Compressed Folder Tools aslow _ 0

v X
=P

Home Share Viey Extract
.
v ¥ This PC > ‘rrebeostorr—cowmoad Maslow » v U | Search Maslow
~
~ Name Date modified Type Size
7 Quick access
= Desktop ?‘ Firmware-1.14.zip 05-Jun-18 11:22 PM Compressed (zipped)... 1,121 KB
£ GroundControl-Windows Portable.v1.14.zip 05-Jun-18 11:30 PM Compressed (zipped)... 26,158 KB
& Downloads

Documents

e e

= Pictures

* downloads
™ Imra

™ LMRA requireme
" REQ LMRA

& OneDrive

= This PC
m Desktop
Documents
& Downloads
D Music
= Pictures
B Videos

.. Local Disk (C)

lieba08 (N A

2 items 1 item selected 1.09 MB =

Select a destination for the extracted files.

E Extract Compressed (Zipped) Folders

Select a Destination and Extract Files

Files will be extracted to this folder:

Browse...

Show extracted files when complete

act Cancel

You should now have a folder with the extracted firmware (folder symbol without the zipper).
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. H s
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" downloads

™ Imra
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& Downloads
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3 items 1 item selected

~
Date modified Type Size
" Firmware-1.14 05-Jun-18 11:38 PM File folder
i Firmware-1.14.z1p 05-Jun-18 11:22 PM Compressed (zipped)... 1121 KB
Iy GroundControl-Windows.Portable.v1.14.zip 05-Jun-18 11:30 PM Compressed (zipped)... 26,158 KB

L]

Time to fire up the Arduino software.

6) Open the firmware and upload it to the Arduino Mega
In the Arduino software click on ->File ->Open and navigate to the extracted firmware folder.

sketch_jun08a | Arduino 1.8.5 (Windows Store 1.8.10.0)
File £dit Sketch Tools Help
New Ctil+N
Open... Ctl+0

Sketchbook >

Examples >|here, to run once:
Close Ctrl+wW

Save Ctrl+S

Save As... Ctrl+Shift+S

here, to run repeatedly:
Page Setup  Ctrl+Shift+P

Print Ctrl+P

Preferences  Ctrl+Comma

Quit Ctrl+Q

Arduina/Genuin



In the firmware folder open the ‘cnc_ctrl_v1 folder’ and find the ‘cnc_ctrl_v1.ino’ to open in
the Arduino software.
sketch_jun08a

File Edit Sketch Tools Help

Arduino 1.8.5 (Windows Store 1.8.10.0)

sketch_jun08a

|£] Open an Arduino sketch... X
P

void setup() {
// put your setup code here, to run TR ‘ * Firmware-1.14 v @F P HE~
1 = Name - Date modified ~
. * *enc_ctrl_v1 05-Jun-18 11:38 PM
VO;C; loip 0 S § Quick access * pocymentation 05-Jun-18 11:38 PM
PHE youz main code here, to A 7 " platformio 05-Jun-18 11:38 PM
! " simduino 05-Jun-18 11:39 PM
Desktop 't .gitignore 05-Jun-18 11:38 PM
: 't travisyml 05-Jun-18 11:38 PM
_ I'I _tBOM.md 05-Jun-18 11:38 PM
Libraries | 1 CODE_OF_CONDUCT.md 05-Jun-18 11:38 PM
~ I guestBook.txt 05-Jun-18 11:38 PM
i _HINSTRUCTIONS.md 05-Jun-18 11:38 PM
fhi=he [T LICENSE 05-Jun-18 11:38 PM
6 @Imainpicture.jpg 05-Jun-18 11:38 PM
= m‘platfcrmio.ini 05-Jun-18 11:38 PM v
Network = >
Object name: | ™ | Open
Obijects of type: All Files (* ) he Cancel
|£] Open an Arduino sketch... X
Look in: ‘ ™ enc_ctrl_v1 v @2 rmE
_—] Name a Date modified ~
"utility 05-Jun-18 11:38 PM
Quick access |t Axis.cpp 05-Jun-18 11:38 PM
- ETAxis.h 05-Jun-18 11:38 PM
écnc_drl_v1.in0 05-Jun-18 11:38 PM
Desktop | TConfig.h 05-Jun-18 11:38 PM
- | TEncoder.cpp 05-Jun-18 11:38 PM
M | TEncoder.h 05-Jun-18 11:38 PM
Libraries | TGCode.cpp 05-Jun-18 11:38 PM
‘ ETGCode.h 05-Jun-18 11:38 PM
3 D Kinematics.cpp 05-Jun-18 11:38 PM
iz =L "t Kinematics.h 05-Jun-18 11:38 PM
6 | T Maslow.h 05-Jun-18 11:38 PM
— D Motion.cpp 05-Jun-18 11:38 PM W
Network < >
Object name: ‘cnc_ctrl_ﬂ ino ~ ‘ Open
Objects of type: All Files (*.%) M Cancel




The Arduino software will now have 2 windows open. Close the one in the background
(empty sketch and only one tab) and only keep the one with ‘cnc_ctrl_v1’ in the top bar

open.

File Edit Sketch Tools Help

enc_ctrlv1 | Arduino 1.85 (Windows St..  — O X

File Edit Sketch Tools Help

sketch_jun05a

void setup() {
// put your setup code here, to run once: cnc_ctrl_v1
1

id loop() (
// put your main code here, to run repeatedly:

Arduino/Genuino Uno on COM1

If you have not already, now is a good time to connect your Arduino Mega to a USB port on
your PC. (give it ~3 seconds before proceeding)

Next you click on -> Tools -> Board and select the option ‘Arduino/Genuino Mega or Mega
2560’

cnc_ctrl v 8.5 (Windows Store 1.8.10.0) - X
File Edit Sketfh Tools Hdp

Aud Format Crl+T
Archive Sketch
Fix Encoding & Reload

cnc_ctrl_v1

Serial Monitor Ctrl+Shift+M ~
Serial Plotter Ctrl+Shift+L
WiFi101 Firmware Updater
Board: “Arduino/Genuino Mega or Mega 2560° 3 | 2
Boards Manager...
PTOCES ST R T2 S0 e 25507

Arduino AVR Boards

Port: "COM3 (Arduino/Genuino Mega or Mega 2560)" >
Arduino Yan

Get Board Info

Arduino/Genuino Uno
Programmer: "AVRISP mkiI" > Arduino Duemilanove or Diecimila

Burn Bootloader

| ®  Arduino/Genuino Mega or Mega 2560

ATcTO e ADA
Arduino Leonardo
Arduino Leonardo ETH
Arduino/Genuino Micro
Arduino Esplora
Arduino Mini

Arduino Ethemet
Arduino Fio

Arduino BT

LilyPad Arduino USB
LilyPad Arduino
Arduino Pro or Pro Mini
Arduino NG or older
Arduino Robot Control
Arduino Robot Motor
Arduino Gemma

Adafruit Circuit Playground
v



Then you click on -> Tools -> Port and should find a port that has a ‘checkmark’ (in my case
COM3 but the number might vary depending on your PC).

cenc_ctrl_v1 | Arduino 1.8.5 (Windows Store 1.8.10.0) - X
File Edit Sketch Tools Help
° ° m Auto Format Ctrl+T
Archive Sketch
cnc_ctrl_v1 Fix Encoding & Reload 5Code.cpp | GCodeh | Kinematics.cpp | Kinematicsh | Maslowh | Motion.cpp | Motionh | Motor.cpp | Motorh | N¥orG
Serial Monitor Ctrl+Shift+M ~
Serial Plotter Ctrl+Shift+L

WiFi101 Firmware Updater

Board: "Arduino/Genuino Mega or Mega 2560" >

Processor: "ATmega2560 (Mega 2560)" >

Port: "COM3 (Arduino/Genuino Mega or Mega 2560)" | Serial ports
Get Board Info COM1

v . ;
P ——— ,I¥ coms (Arduino/Genuino Mega or Mega 2560)

Burn Bootloader

Arduino/Genuino Mega or Mega 256!

You have 2 options now to verify that your Mega is connected.
- Click -> Tools -> Get Board Info and if you are presented with a window including a
serial number you are ready to proceed
- Click somewhere in the white space to close the tools menu and disconnect the
Mega from the USB. Click on -> Tools -> Port and should now only have (a) port(s)
without a ‘checkmark’. Plug in the Mega again and repeat the process and if you find
a port with a ‘checkmark’ added you are ready to proceed.
If none of this 2 options work additional troubleshooting is required. The amazing community
on the https://forums.maslowcnc.com will be more than happy to help.

But you have followed the steps precisely and have a port with a ‘checkmark’? Let’s get the
firmware loaded.


https://forums.maslowcnc.com

Click on the ‘right arrow circle’ to upload the firmware

cenc_ctrl_v1 | Arduino 1.8.5 (Windows Store 1.8.10.0) - X
File_Edit Sketch Tools Help

c'o m g Upload

cnc_ctrl_v1 Axis.cpp Axis.h Config.h Encoder.cpp Encoder.h GCode.cpp GCode.h Kinematics.cpp Kinematics.h Maslow.h Motion.cpp Motion.h Motor.cpp Motor.h N Y OrGl

Arduino/Genuino Mega or M

Keep an eye on the black window and the green bar above. In the green bar you should see
Compiling sketch... ‘, Uploading... ‘ and wait for the ‘Done uploading.’.

(If there are errors during the upload, they will show in the black window and the ‘Done
uploading.” will not appear. To effectively troubleshoot errors, the information in the black
window is essential for the community to help. You can increase the size of the black window
by hovering between the down light green bar and the white and make the black window
bigger and scroll and now would be a good time to take a screenshot.)

But everything went well, right?

If you wish to check if the firmware is running in the Mega, you have the option to see if it
talks back to you from within the Arduino software. The is a symbol of a magnifying glass in
the top right corner, called the serial called the ‘Serial Monitor’. It will show you the feedback
of the Maslow firmware once successfully uploaded.

It shows cryptic symbols?

COM3 (Arduino/Genuino Mega or Mega 2560) — O X
Send

S S O S S S S P N S SRR SN R OTR

RcRaSS_CIHIM-4AST CITHIM4ATIOON0 ~

([$SRSVS@C ( [TSRQVS@WKYHIPrcR §§'KYHrQRCRASSC (OHSRsVS™ CIOYHIM-SATSOOOMRSRSRA “F< [$SRQOOBInJI%, §545 % (M
TIBAGS 051095nT', 9945 % (MInJd', 5945 % (MISC ([TSRQVIWF ([TSRQRIpTE, §¢ O % (OTSDOOMRSR=R4 j "OYHRQRCRA ™ "OYHE

BYSwKSOTY3n@inJs, 1945 % (MI9J%, $945 % (MSYC (OHSRSVY ;' O+MRQRCR4¢Jb, 99 O 1099TIBAN

,9945 % (M99 O%HrQReR4SS CSTHIMS4ATS0000
% (MSSOOOMRQRSR4 § ' OSHIQRCR4SSF< [SRRQUOBISF< [SRrQOORSnT ', $945 3 (MSnJ%, 945 2 (MSYC (OHSRSVS C (OHSRsvhS ¥
< >

Autoscroll No line ending 9600 baud ~| | Clear output




Change the baud to 57600 and now you should see reporting positions like this:

COM3 (Arduino/Genuino Mega or Mega 2560) — | X
| Send
[PE:0.00,0.00,127] ~
<Idle,MPos:-244.08,-166.89,5.08,WPos:0.000,0.000,0.000>
[FE:0.00,0.00,127]
<Idle,MPo=:-244.08,-166.89,5.08,WPo=:0.000,0.000,0.000>
[FE:0.00,0.00,127]
|<Idle,MPos:-244.08,-166.89,5.08,WPos:0.000,0.000,0.000>
[FE:0.00,0.00,127]
<Idle,MPos:-244.08,-166.89,5.08, WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPos:-244.08,-166.89,5.08,WPos:0.000,0.000,0.000>
[PE:0.00,0.00,127]
<Idle,MPo=:-244.08,-166.89,5.08,WPo=:0.000,0.000,0.000>
[FE:0.00,0.00,127]
<Idle,MPos:-244.08,-166.85,5.08, WPo=:0.000,0.000,0.000>
[FE:0.00,0.00,127]
v
< >
Autoscroll No line ending ~] 57600 baud  ~ | Clear output

Now that you have thoroughly confirmed that the firmware is on the Mega and running, it's
time to close the ‘Serial Monitor’ and the Arduino software (always make sure the Arduino
software is closed before starting GroundControl).

7) Time to cut amazing things, GroundControl.
Let’s assume you followed my advice on 5) and have already downloaded the latest
GroundControl-Windows.Portable.v(x.xx0.zip.
Extract the compressed file to it's own folder the same way as you did with the firmware.

= |

I I

Home

= Pictures

*Imra

& OneDrive

4 This PC

m Desktop

b Music
= Pictures

B Videos

. Liebe08 (D)

3 items

|2 Documents

. Liebe08 (D:

Compressed Folder Tools

Share View

Extract To

" GroundControl-Windows.Portable.v

™ downloads

* LMRA requireme
™ REQ LMRA

|4 Documents

& Downloads

# . Local Disk (C)
)

v

1 item selected 25.5 MB

Extract

j\ Firmware-1.14.zip

Maslow

Extract
all

Extract all

Extract all items in this folder.

Compressed (zipped)...
Compressed (zipped)...

1121 KB
26,158 KB




You should now have a folder of GroundControl without the zipper symbol.

™ < | Maslow — O
Home Share View
«~ v A ™ > ThisPC » Liebe08 (D:) > downloads » Maslow v U  Search Maslow
m Desktop A A Name Date modified Type Size
& Dovmloads " Firmware-1.14 05-Jun-18 11:38 PM___File folder
Documents  # I ™ GroundControl-Windows.Portable.v1.14 06-Jun-18 12:33 AM File folder I
= Pictures o ¢" Firmware-1.14.zip 05-Jun-18 11:22 PM Compressed (zipped)... 1,121 KB
™ downloads £ GroundControl-Windows.Portable.v1.14.zip 05-Jun-18 11:30 PM Compressed (zipped)... 26,158 KB
™ lmra
™ LMRA requireme
™ REQ LMRA
&= OneDrive
= This PC
m Desktop
Documents
# Downloads
b Music
= Pictures
B Videos
% . Local Disk (C:)
- Liebe08 (D)
w Liebe08 (D) v
4 items
Double click on it to launch to enter the GroundControl folder and launch
Here you will be presented with a security warning.
Click ‘Install anyway’.
i o = | AL Ll P ——— - O
' .
File Home Share View
The app you're trying to install isn't a verified
&« v 4 ™« Maslow » Grg learch GroundControl-Windo...
app from the Store |
m Desktop » A Name b
% Downloads  # * geod Installing apps only from the Store helps protect your PC and keep it
Documents ™ Grou running smoothly.
= Pictures * Laun 1KB

* downloads

™ Imra

™ LMRA requireme
" REQ LMRA

& OneDrive

S This PC
m Desktop
Documents
& Downloads
J» Music
i Pictures
B Videos

Local Disk (C3)

‘ -

l mo" .-

N o+,
] ﬁ;,_
A!o?i‘;

Don't want to be warned in the future? Open settings

= Liebe08 (D7)

w Liebe08 (D) v

| 3items  1item selected 33 bytes




You should now see a screen like this and click on ‘Actions’

GroundControl
Actions

Settings

&

- X

n o
n A n o
u o

P st To 100 MM Define
Move: Home

X: 0mm Percent Complete/Line:

Y: Omm 0.0%
Z: O0mm 0
Vel :0 mm/m 0 mm/m

Not Connected

In the next window choose the same port that you have used with the Arduino software to

upload the firmware.

© GroundControl

View
Open File
Update Gcode
View Gcode
Clear Geode

Reset View

Test Motors/Encoders

Manual Calibration

Quit Ground Control

Return To Center

Diagnostic features

Calibrate

Connect

Connect

Available Ports

COM1

COM3

Set Chain Length - Automatic

Advanced

Not sure here if you need to click the ‘Connect’ button after. | missed it, sorry, but it can’t

harm.



Clicking the ‘Close’ button at the bottom, you should now see in the right/down screen that
you are connected and the Firmware/GroundControl version you are using.

© GroundControl - X

Actions Settings Macro 1

Macro 2

Z-Axis
Dist To Define
Move: ey AL Home

z > 2
X:-24412 Percent Complete/Line:

Y: -167.23 0.0%
Y4 -5.08 0
Vel 0.00 0 mm/m

Connected
position loaded at
-244.08
X -166.89
BOS
Ground Control 1.14
Firmware Version 1.14

G21

position loaded at
-244.09

-166.90

position loaded at
-244.12

-167.23

You are ready to proceed with the calibration. ->Actions -> Calibrate

Don’t forget to share the amazing things you cut in the forum https://forums.maslowcnc.com
and the Maslow community garden http://maslowcommunitygarden.org/



https://forums.maslowcnc.com
http://maslowcommunitygarden.org/

