
BG3 Armor Modding Workflow Summary 

Chart made by: mod.io@BerrySemifreddo 

Step 1: Create An Organized Folder Structure 

Folder 1: Blender Files 

· For storing work files that include texture preview. 

Folder 1.1: (OPTIONAL) Vanilla Meshes 

· For storing models from official assets in their original form. 
· Sub-types: 

o Standard (HUM/HEL/ELF/TIF…) 

o Strong (DGB/HRC…) 

o Short (DWR/GNO/HFL…) 

Folder 1.2: (OPTIONAL) Vanilla Textures 

· For storing textures from official assets in their original form. 

· Includes: Texture for Mesh 1, Texture for Mesh 2… (BM, PM, NM, MSK). 

Folder 1.3: (OPTIONAL) Reference Images 

· If you're modeling it after something, put them here. 

Folder 2: Edited Meshes 

· For storing the head GR2 files after your edit. 

· Sub-types: Standard, Strong, Short. 

Folder 3: Exported Textures 

· For storing the textures exported from SP (Substance Painter) or edited from 
image editing software. 

· Includes: BM, PM, NM, MSK. 

Folder 4: Icons 

· For storing icons you made in multiple sizes. 
· 64 x 64 PNG 



· 144 x 144 Controller UI PNG 

· 380 x 380 Tooltip PNG 

Loose Files: 

· SP/PS project files, OBJ/FBX files. 

 

BG3 Official Asset Organization Structure 

(Example) 

(Before moving to Step 2, read this part regarding file structure) 

UPDATE 12/19/2025: 

This is a chart that explaines how BG3 organize their massive amount of files. From 
top to down, each 'layer' is a 'parent' to the layer below, and this is very important 
when you're navigating inside the BG3 Search Engine webpage in Step 2 (next page in 
tutorial). 

Each category of page can lead you to a deeper level, you can find visual page inside 
the item template page, material resource in the visual page, so on and so forth. 

Hierarchy Example: 

1. Item Template: (e.g., ARM_Camp_Body_Astarion) 

2. Visual: (e.g., HUM_M_CLT_Camp_Outfit_Astarion_Body): This tells you what 3D 
model is this item using, and what materials are used 

3. Material Resource: (e.g., (HUM_M_CLT_Camp_Outfit_Astarion):​
This tells you what shader is this material is using, and what's the exact specs of 
this shader, and the DDS texture files used in this material 

o MSK Cloth: (e.g., ...MSKCloth)  

o Virtual Texture: (e.g., ...VirtualTexture) 

4. Textures (might be inside virtual textures): 

o Base Map (BM) 

o Normal Map (NM) 

o Physical Map (PM) 

Note: Not all materials use virtual textures. If it didn't, the material resource will include BM, 
NM, PM files separately, instead of as a packaged virtual texture file. 

 



Step 2: Extract resources from official assets 

(Updated 12/19/2025) 

1.​ Install BG3 Modder's Multitool 

o Go to the 'releases' page and click the zip to download it. 

o (Or directly search in Toolkit Resource Manager). 

o Search for Baldur's Gate 3 Toolkit Data in Steam and install. 

2.​ Index the Assets 

o Index the whole game asset (in Modder's Multitool), then read the 
wiki article about how each armor/clothing/accessory looks like 
in-game: https://bg3.wiki/wiki/Items 

3.​ Find and Extract Files 

o After finding your item, click the underscored word 'File' in properties, 
and then copy the item file name (like 
'CLT_Camp_Outfit_Astarion_Body') for later use. 

o Combine Prefix: Each race has its own fit (Like HUM_M or DGB_F). 
Combine this race/gender prefix with the File Name you just copied 
(e.g., HUM_M_CLT_Camp_Outfit_Astarion_Body). 

o Search Engine: Go to BG3 Search Engine 
(https://bg3.norbyte.dev/search), paste the combined text, and find the 
text that has the suffix '.GR2'. Copy the whole source file name. 

o Extract Model: Go back to Modder's Multitool and 'Search Index', use 
this text to find your model file. Click the folder icon on the top right 
side and open it in folder, copy paste it in your mod's Vanilla Meshes 
folder. 

(If you're not planning to modify the vanilla textures at all, skip the 
following steps and go to PAGE Step 3) 

Find Textures: In that same page in BG3 Search Engine, scroll down after the .GR2 
row and look for rows like <MaterialID>. Click on the underscored MaterialID number 
and click view object to be directed to the material resource page. 

3.1. Method A (Virtual Textures / VT): 

o Scroll to the bottom of the material resource page, find the UUID just 
two rows above the line <ParameterName>virtualtexture</ParameterName>. 

o (If this doesn't exist, jump to 3.2 B section). 



o Click on that UUID and open, and copy the <GTexFileName> codes, 
and paste them into the search box in 'Search Index' in Modder's 
Multitool. 

o Hover your cursor on the (GTex Codes).gtp file, and use the folder 
icon to open it up in file explorer. Copy those 3 files and paste them 
into your mod's texture folder. 

o For MSK Cloth: In the same page in BG3 Search Engine, find a line 
that has the text _MSKCloth in it, use those text (including the text 
just before _MSKCloth) to find it in Multitool > open folder, copy paste 
it to your Vanilla Textures folder. 

3.2. Method B (Non-VT): 

o In that Material Resource page, look for something that looks like 
HUM_F_CLT_Headwear_F_BMA or _BM, and same with _NM, _PM, 
_MSKCloth. 

o Use the text before _BMA…etc to search in the 'Search Index' 
window, open each of them in folder and save them to your Vanilla 
Textures folder. 

 

Step 3: Set Up Blender and Other Tools 

1. Install the newest Blender. 

2. Install the BG3/DOS2 Collada Exporter. 

o Read the 'README' in the repo on how to install the add-on. 

o Install the LSLib to make it work with the collada exporter above: 
Make sure it's the latest version! 

3. Download Volno's Texture Toolbox. 

o Download BG3 Lazy Tailor/Robust Weight Transfer add-ons and drop 
all the zip files directly in Blender viewport. 

4. Prepare Blender File. 

o Copy the Blender file from Volno's toolbox to your organized folder 
('Blender Files') and organize the windows to your liking, and save 
the Blender file for future use. 

5. Optional Installations: 

o 5.1. (OPTIONAL) Install Substance 3D Painter. Also install BG3 
Shaders For Substance Painter and Substance Painter DDS 
Exporter. 



o 5.2. (OPTIONAL) Install GIMP or Photoshop for further editing. 

o 5.3. (OPTIONAL) If you're unable to use SP, see 
https://bg3.wiki/wiki/Modding:Texture_formatting on how to export DDS files 
in GIMP. 

 

Step 4: Import + Model-Making + Export Finished 

Model 

Import the Vanilla Armors / Clean up collection 

1. Open Volno's Texture Toolbox Blender file, import the vanilla GR2 files 
using File > Import > DOS2/BG3 via Collada.​
※If you are importing a GR2 that contains physics, usually, using glTF 
import option will be a better choice. 

2. Delete the meshes that you do not need (like LODs, accessories included 
in the vanilla armors that you did not want, and the head and clothes etc. 
from the original Blender file). 

3. Import the BM, PM, NM and MSK DDS texture files into Blender shader 
nodes ('Material' > 'Tintable Armour' > 'Image Texture' node), and match 
textures with corresponding meshes. 

Sculpting / Mesh Editing 

4. Initialise BG3 Lazy Tailor add-on, and import a body reference and GR2 
armature you want to work with. Decide if you want to make brand new 
outfits from scratch, or reuse vanilla assets. 

o 4.1. If reusing vanilla assets: Prepare multiple versions of the same 
vanilla models of different body types that you wanted to support 
(so you don't have to manually refit them). 

o 4.2. If making brand new outfits: Do it in any way you like. You can 
read the guide on docs.baldursgate3.game. Personally I'd suggest you 
directly take some 'skin' from the standard body, which will give you 
much less trouble. 

5. Add weight paint to all of your meshes, so that the armor can move with the 
skeleton properly. 

o If it's a headwear: Setup a Head_M vertex group that includes all 
vertices, and give them 100% weight paint. 

o If it's something else that stays close to skin, use the 'Robust Weight 
Transfer' add-on that we downloaded before, for simple torso parts, 



default values are fine. For thighs/legs, sometimes 0.5m of max 
distance and 60° max normal difference works better. 

o If it's a long dress or cloak, you will need to add physics, you can 
watch Lynia's YouTube tutorial: 'Modding BG3: How to add cloth 
physics manually' 

Finishing Up 

6. Parent your meshes to the new armature (that you imported in #4 from 
LazyTailor) using 'Armature Deform' option, and make sure all the meshes 
have only one armature modifier. ​
(I suggest using the new armature instead of the vanilla armature 'cause 
sometimes a GR2 may be imported wrong and there will be bones 
missing, there should either be 80 or 82 bones) 

7. Go to Object tab > BG3 Settings > and find export order and LOD settings 
below: 

     Make sure every mesh has its own unique export order number (like 
1,2,3...and it has to be sequential), make sure all the LOD levels are set to 
0 (If you're using other LOD levels, remember to set the most detailed 
version of your mesh's LOD level to 0). 

8. Rename all meshes so all the object names/data names/UV map names 
can be unified as 
(RACE)_(BODYTYPE)_(YourOutfitName)_(ClothingPartsName)_Mesh (not a 
necessity, but recommended), and make sure UV map has a -uvs0 at the 
end. 

9. Parent the body reference to the armature too. Press A to select everything 
in viewport and Ctrl+A to apply all transforms. Choose your armature and 
go into Pose Mode, check if the outfit is moving with the body properly. If 
confirmed, unparent the body reference from your armature. 

Export Edited Meshes 

10. Right click on the armature and choose 'Select hierarchy', go to File > Export 
> DOS2/BG3 via Collada. Check the 'Selected Only' and uncheck the 'Flip 
Meshes on X axis' (it's in 'Show GR2 options'). Name it the way you name 
your meshes (Like (RACE)_(BODYTYPE)_(YourOutfitName)), then export. 

11. Select the meshes you want to create custom textures of (one by one) and 
export them into OBJ or FBX format, so it can be imported to SP. 

12. (OPTIONAL) Use Lazy Tailor to make refit of this outfit, so that it can be 
used on other body types/races too. Remember to re-assign weights for all 
your meshes. 

 



Step 5: Making Textures and Icons 

1. Convert Textures: Install chaiNNer and download Volno's chaiNNer 
templates. Convert all vanilla DDS files into TGA (so that SP can read it). 

2. Import to SP: Import the model and textures into SP (Or make your own). 

o Important: Make sure the base map (which will be the 'color' layer in 
SP) is light-grey-ish white, so that it can be dyed easily and 
correctly. (But if it doesn't have to be dyeable, do as you please.) 

o 2.1. (OPTIONAL) Custom MSK Map: Make custom MSK map (an 
image to decide how your armor should be dyed) following the 
instruction in Volno's 'BG3 Substance Painter Shaders Guide'. 
Directly import it into SP's U0 MSK layer to preview how it looks 
under different dyeing conditions. 

3. Export: Set an export path and choose the armor template in SP, and 
export the DDS files into your previously prepared texture folders. 

o 3.1. (OPTIONAL) Further editing with PS or GIMP, if needed (e.g., 
swapping out some textures on separate channels). 

4. Organize: Organize them properly. If many meshes are involved, it is 
recommended to keep the names unified and make a separate folder for a 
different mesh. 

o 4.1. (OPTIONAL) Make Icons: Only 3 sizes are necessary. Put all the 
icons you made in these 3 folders respectively: 

 64 x 64: Tiny icon for inventory. 

 144 x 144: Controller UI icons. 

 380 x 380: Larger preview for cursor hover. 

 

Step 6: Packing the armor inside Toolkit (Part 1) 

Create Project and Import Assets 

1. Create a folder in Baldur's Gate 3 root folder (something like ...\Baldur's Gate 
3\Data\) named 'ASSET' for future use. Create a folder inside it that stores 
all your assets, with any name you like. You can also create subfolders 
including: Meshes, Textures, Icons. 

2. Create a new project inside Toolkit, give it a name, load in the Base_Level_A 
level. 

3. Find the yellow box inside your project folder in Resource Manager in 
Toolkit. From there, import your models into your project (click the tiny 'Add 



resource…' button on top left corner of resource manager outliner, filter out 
file type by GR2). 

4. Use the same 'Add resource…' button, import all your texture DDS files. 

o Important!!! Only use sRGB on BM (base map). For all other maps 
(PM, NM, MSK), click 'No' when the pop-up window asks if it's in 
sRGB. 

Material Set-Up 

5. For each material, there should be at least a BM, PM, NM texture. Choose 
your method: 

o 5.1. Brand new models/textures: Due to the fact that VT can cause 
crashing problems to a lot of BG3 players, it is preferred to use a 
Non-VT texture instead. If you need glow effect but also need it to 
be dyeable, search for CHAR_BASE_GM.lsf in BG3 Search Engine to 
find material templates to use. After choosing a material template 
with your selected shader, search for it in Toolkit, and right click to 
'Create New from Selected'. 

o 5.2. Vanilla assets with modified texture: Depending on whether you 
choose to use VT, you can search for the material template for that 
specific armor and 'create new from selected', importing your 
BM/PM/NM files as VT instead. Or just use the previous way 
(Non-VT). 

o 5.3. Un-modified vanilla texture: You don't have to set up a new 
texture for this, you can directly find the vanilla material for this 
model, and reference it in the model's Edit Visual page. 

6. Double-click on the newly created material template, scroll to the bottom, 
and select each one of your imported textures (either single maps or VT), 
use the double arrows on the right to plug each of them in the respective 
place. 

Model Set-Up 

7. Inside the property tab below the preview window (when you click each 
item), fill in the necessary info first. Choose the 'SlotID' 'Support Vertex 
Color' 'Tags' 'VertexColorMaskSlots' according to what kind of armor it is, 
what body part do you want it to automatically hide when it is equipped. 

o See this article for details: https://mod.io/g/baldursgate3/r/adding-an-armor 

8. Double-click on each of your models, and choose materials for the 
corresponding meshes one by one (by clicking the arrows next to your 
meshes). You can also add VFX as material or VFX as attachment. 

 



Step 7: Packing the armor inside Toolkit (Part 2) 

Create Root Templates 

1. In the toolkit interface, find a window called 'Root Template'.  ​
First find a container, simple one like 
'LOOT_GEN_Backpack_A_Posed_A', put it in search box and right click, 
choose 'Create new from selected' and give it a new name. (You don't 
have to do this if you only got one item in total without any modular, but 
you might add some later, so it's strongly suggested) 

2. Find a piece of vanilla armor/clothing that is most similar to the category of 
this item you created. You can browse through the BG3 wiki and choose 
anything that has stats you like and can be equipped at the same body 
location (breast plate, cloak, gloves, etc.), so it's easier to edit later. Right 
click, choose 'Create new from selected'. Also give it a new name. 

Edit Details in Root Template 

3. Scroll down on the left side of the root template window, find your mod, and 
click each newly created item on the right side; Go to the 'Side Bar' 
window; At this point, only change the following fields: 

o Display Name: Name in actual game. 

o Description(Lore): Description under the name and icon. 

o Equipment Data: Assign which clothing should each race's character 
wear. Remove vanilla ones, add your own armors, and assign 
default colors. Save. 

STOP HERE AND JUMP TO #4 IN NEXT PAGE)! Come back later. 

(…After completing #4, 5, 6…) 

7. Now let's put in 'Stats' - Choose which stats entry you'll use for this item. 

Go to the 'Side Bar', scroll down to find a field called 'Stats', click the down 
arrow next to it, use your item's stat name to filter out and select the 
corresponding stat. 

o Important info!!! The stats entry you choose here will directly 
influence whether you can put this armor on in Equipment Data or 
not. If you later delete this entry in Stats table but still want to keep 
this root template, remember to assign new stats to it first. 

8. And then finally we can put in 'Treasure Table'. Your armor themselves 
don't need a treasure table, only your containers need one. Just like 
previously, inside 'Side Bar', scroll further down to 'Treasure', click the 
three dots, enter your treasure table name in filter box, double click to add, 



and then choose the default treasure table on the right side, and double 
click to remove it. Save. 

o Move on to #9 in the last chapter. 

 

Step 8: Packing the armor inside Toolkit (Part 3) 

Create Stats and Treasure Table 

4. Look for 'Stats Editor' on top of the program. Find your mod project at the 
bottom left, expand stats > + > object. 

o Double click the newly created object stats sheet, to create a new 
stats for your container first. 

o Right click on the container root template you created, copy GUID to 
clipboard and paste it inside the 'Root Template' field in this chart. 
Change other stats as you like. Save. 

5. In the same way, choose stats > + > armor, double click the newly created 
armor stats sheet, copy the GUID of your newly created armor templates 
as well, and choose a parent template. Fill in 'Slot', 'Weight', 
'ValueOverride' etc. Make sure 'AQ Unique' is set to 0 instead of 1. Save. 

6. Now go to treasure table > + > treasure table, double click. 

o Fill in the name TUT_Chest_Potions so that it can appear in tutorial 
chest. Select 'Yes' to 'AppendNotOverride'. 

o As for 'Treasure' field, it has to be in the format of 
I_YourItemNameInStatsChart. 

o Note: Because we have a container, we should put the bag inside the 
tutorial chest first, and then put in what's inside our bag. 

o After the 'TUT_Chest_Potions' entry, start another line with 
something like TT_Sharraith_Armor_Bag (your bag's name), so that you 
can search for this easily. Add sub-stats to that entry so that it'll 
know what items should be inside that bag. 

o Using Modding:TreasureTables References, you can find the 
TreasureTableName for vendors in game. 

o Now you can come back to #7 in Step 7. 

(…After completing Step 7 items #7 & #8…) 

Create Icon Atlas and Finish 



1. Find 'Texture Atlas Editor' on top and enter, use File > New to create a new 
Atlas, rename it as you like. Save, and choose Edit > Add Entries, import all 
of the 64 x 64 PNG icons you prepared here. Save. 

2. Go to Project > Convert UI Assets. 

o Through 'Add files', add your 144 x 144 icons here first, and write 
ControllerUIIcons/items_png, click 'OK'. 

o In the same way, 'Add files', choose your 380 x 380 icons here, and 
write Tooltips/ItemIcons, click 'OK'. 

3. Finally, go inside each item's root template detail window again, scroll down 
to the 'Icon' field, and select our newly created Atlas, and select the 
corresponding icon we made. Save. 

Step 9: Testing and Tweaking 

1. Switch to 'game mode' (the controller icon on top left), use hotkeys to test 
out if the armors look fine on the characters. Use Ctrl+Shift+F11 to open 
debug console, and use command like givetreasure or spawnitem to summon 
tutorial chest. 

MISSION COMPLETE We are ready to pack it and go. Fill in the final mod name, 
author, thumbnail and short description in Project settings, and choose 'Publish 
Local' to use it locally. 
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