
THIRD TERM SS 1 DATA PROCESSING 
 

Inserting Formulas and Using Functions in Excel 
 

Assignment: 1. What is the use of AutoFill or fill handle in spreadsheet? 2. What are the Total 
Rows and Columns in Excel? 
 
Formula is an expression which calculates the value of a cell.  
Functions in Excel are built-in formulas used to perform calculations quickly and easily. 

Use the following  as sample table to demonstrate the following Simple and built in Formulas 
(Functions) in excel 

 A B C D E F G H I 
Simple and Built in Formulas (Functions)  

1  Name Score1 Score2 Total Average Total 
Max 

Total 
Min 

5 % of 
Total 

Total Product 
of Score1 and 

Score2 
2 Usman            
3 Moses            
4 Joy            
5 Zainab            
6 Aza            
7 Total         
8 Count         

Writing Simple Formulas 

You can write formulas in Excel to perform basic calculations like: 

1.​ Addition (+)​
=A1 + B1 

2.​ Subtraction (-)​
=A1 - B1 

3.​ Multiplication (*)​
=A1 * B1 

4.​ Division (/)​
=A1 / B1 

5.​ Percentage (%)​
=(A1 / B1) * 100 

In-Built Formulas in Excel 
In-built formulas, also called functions, are ready-made formulas in Excel used to perform 
common tasks quickly. 

Examples: 
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1.​ AutoSum – Quickly adds a range of numbers​
Formula: =SUM(A1:A5)or =SUM(A1, A5) (this is what AutoSum inserts automatically)​
Use: Adds all the numbers in cells A1 to A5 without typing the full formula. You just 
click the AutoSum button, and Excel fills in the formula for you. 

2.​ AVERAGE – Finds the average (mean)​
Formula: =AVERAGE(A1:A5)​
Use: Calculates the average of the numbers in cells A1 to A5. 

3.​ MAX – Finds the highest number​
Formula: =MAX(A1:A5)​
Use: Returns the largest number in the range A1 to A5. 

4.​ MIN – Finds the lowest number​
Formula: =MIN(A1:A5)​
Use: Returns the smallest number in the range A1 to A5. 

5.​ COUNT – Counts numeric entries​
Formula: =COUNT(F1:F3)​
Use: Counts how many cells in F1 to F3 contain numbers. 

6.​ PRODUCT – Multiplies numbers​
Formula: =PRODUCT(B1:B4)​
Use: Multiplies all the values in cells B1 to B4. 

7.​ QUOTIENT – Returns the whole number part of a division​
Formula: =QUOTIENT(A1, B1)​
Use: Divides A1 by B1 and returns only the whole number part, ignoring the remainder. 

8.​ MOD – Returns the remainder after division​
Formula: =MOD(A1, B1)​
Use: Divides A1 by B1 and returns the remainder. 

Differences between the Formulas: 
1.​ =SUM(A1:A5) 

●​ Adds all numbers in the range A1 through A5 (cells A1, A2, A3, A4, and A5). 

●​ Easy and quick to use when you want to add a continuous range of cells. 

2.​ =SUM(A1, A5) 

●​ Adds only the values in cells A1 and A5, ignoring anything between them. 

●​ It’s like listing specific cells you want to add, not a whole range. 

3.​ =A1 + A2 + A3 

●​ Adds values in only the individual cells listed (A1, A2, and A3). 

●​ Works well for a few cells but gets long and tiring if you have many cells. 

Understanding Total that Implies Addition or Multiplication in Excel 
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Example 1:​
If you want to add the values of three cells in a row or column, you simply add the numbers 
together. 

Example 2:​
If you want to find the total product or cost in a given data set, you multiply the quantity column 
available by the price column of each product. 

If functions formula to find Letter grade and remark 

Assignment: Write an IF function formula to return either "Pass" or "Fail" based on a given 

score. 

 IF function checks whether a condition is TRUE or FALSE, then returns one value if it’s true and 

another if it’s false. 

 A B C 
1 Score Range    Letter Grade Remark 
2 80 and above    A Excellent 
3 70 – 79    B Good 
4 60 – 69    C Average 
5 50 – 59    D Poor 
6 Below 50    F Fail 
 
Example: Assign Letter Grade & Remark Using IF Function 
 

 A B C D 
1 Student Name    Score Grade Remark 
2 Usman    68   
3 Moses    73   
4 Joy    55   
5 Zainab    82   
6 Aza    49   
 

Student scores in Column B starting from cell B2. 

Formula for Letter Grade (in C2): 

=IF(B2>=80, "A", IF(B2>=70, "B", IF(B2>=60, "C", IF(B2>=50, "D", "F")))) 

Formula for Remark (in D2): 
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=IF(B2>=80, "Excellent", IF(B2>=70, "Good", IF(B2>=60, "Average", IF(B2>=50, "Poor", 

"Fail")))) 

How to apply: 
●​ Enter the formula for Letter Grade in C2. 

●​ Enter the formula for Remark in D2. 

●​ Press enter key and use the fill handle to copy the formulas down for all students in each 
column 

Formatting the Worksheet in Excel 
Formatting helps make your worksheet easy to read and look neat. 

1. Align Cells 

●​ What it means: Aligning cells changes how the text or numbers appear inside a cell — 
left, center, or right. 

●​ How to do it: 

o​ Select the cells you want to align. 

o​ Go to the Home tab. 

o​ Click on the alignment buttons: Align Left, Center, or Align Right. 

●​ Why it’s useful: For example, numbers are often aligned right, and text is usually 
aligned left or centered. 

2. Selecting Columns, Rows, and the Entire Worksheet 

●​ Select a column: Click the letter at the top of the column (e.g., A, B, C). 

●​ Select a row: Click the number on the left side of the row (e.g., 1, 2, 3). 

●​ Select the entire worksheet: Click the small square between the “A” column and “1” 
row headers (top-left corner). 

●​ Why it’s useful: You can format, delete, or copy entire rows or columns quickly. 

3. Inserting and Deleting Rows and Columns 

●​ Insert a row: 

o​ Select the row below where you want the new row. 

o​ Right-click and choose Insert. 

●​ Insert a column: 

o​ Select the column to the right of where you want the new column. 

o​ Right-click and choose Insert. 
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●​ Delete a row or column: 

o​ Select the row or column. 

o​ Right-click and choose Delete. 

●​ Why it’s useful: To add or remove data without disturbing the rest of your worksheet. 

4. Adjust Column Width and Row Height 

●​ Change column width: 

o​ Move your mouse to the line between two column letters (e.g., between A and B). 

o​ When the cursor changes to a double arrow, click and drag to adjust width. 

●​ Change row height: 

o​ Move your mouse to the line between two row numbers (e.g., between 1 and 2). 

o​ When the cursor changes to a double arrow, click and drag to adjust height. 

●​ Why it’s useful: To make sure all your data fits inside the cells and is easy to read. 

Changing Vertical Alignment and Rotating Content in Excel 
1.​ Change Vertical Alignment: 

●​ Changes text position inside a cell vertically (top, middle, bottom). 

●​ How: Select cells → Home tab → Alignment group → click Top Align, Middle Align, 
or Bottom Align. 

●​ Why: Makes worksheet neat, especially with tall cells. 

2.​ Rotate Content: 

●​ Turns text inside cells at an angle or sideways. 

●​ How: Select cells → Home tab → in Alignment group, click the “ab” icon with an 
arrow (Orientation) → choose a rotation option like Angle Clockwise or Rotate Text 
Up. 

●​ Why: Saves space and improves readability in narrow columns. 

Formatting the Worksheet 
1.​ Transferring Data:​

Copy or move data from one place to another using Copy (Ctrl+C) and Paste (Ctrl+V) 
or Cut (Ctrl+X) and Paste. 

How to Transfer Data from One Worksheet to Another Workbook or worksheet 
●​Open both workbooks: The one with the data and the one where you want to transfer it. 

●​Select the data: Click and drag to highlight the cells you want to transfer. 

●​Copy the data: Press Ctrl + C or right-click and select Copy. 
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●​Switch to the other workbook: Click its window or tab. 

●​Select the destination cell: Click the cell where you want the data to start. 

●​Paste the data: Press Ctrl + V or right-click and select Paste. 

2.​ Merging Cells:​
Combine two or more cells into one by selecting them, then clicking Merge & Center in 
the Home tab. 

3.​ Inserting and Removing Borders:​
Add borders to cells by selecting cells and choosing Borders from the Home tab. 
Remove borders by selecting No Border. 

4.​ Gridlines:​
Gridlines show cell borders on the screen. You can hide or show gridlines in the View tab 
by checking or unchecking Gridlines. 

Gridlines and Row & Column Headings in Page Setup 
a.​ Gridlines:​

These are the faint lines that show the edges of each cell on the screen. 

o​ In Page Setup, under the Sheet tab, you can choose to Print Gridlines so these 
lines appear when you print your worksheet. 

b.​ Row and Column Headings:​
These are the labels like A, B, C (columns) and 1, 2, 3 (rows) that help you identify cells. 

o​ In Page Setup, under the Sheet tab, you can check Print Row and Column 
Headings if you want these labels to show when printing. 

Managing data in spreadsheet 

Create Cell References:​

A cell reference is when you use the value of another cell in a formula. For example, typing =A1 

+ B1 tells Excel to add the values in cells A1 and B1. This helps you calculate quickly without 

retyping numbers. 

Types of Cell References: 

●​ Relative Reference (e.g., A1): Changes when copied to another cell. 

●​ Absolute Reference (e.g., $A$1): Stays the same even if copied. 

●​ Mixed Reference (e.g., A$1 or $A1): Only part of it stays fixed. 
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 A B C D E F G 

1 Item Quantity Price Total Cost 
(Relative) 

Total Cost 
(Absolute) 

Total Cost 
(Mixed 

Row Fixed) 

Total Cost 
(Mixed Col 

Fixed) 
2 Apple 3 100 300 300 300 300 

3 Banana 5 100 500 500 500 500 

4 Orange 4 100 400 400 400 400 

5 Mango 2 100 200 200 200 200 

    =B2*C2 =B2*$C$2 =B2*C$2 =B2*$C2 

Explanation of Each Formula: 
1.​ Relative Reference (=B2*C2): 

o​ When copied to the next row, it becomes =B3*C3. 

o​ Both the row and column change. 

2.​ Absolute Reference (=B3*$C$2): 

o​ $C$2 always points to the price in C2 (₦100), even when copied. 

o​ Used when the price is fixed for all items. 

3.​ Mixed Reference (Row Fixed) (=B4*C$2): 

o​ Row 2 is locked, so if copied down, it stays C$2. 

o​ Column can change. 

4.​ Mixed Reference (Column Fixed) (=B5*$C2): 

o​ Column C is locked, so if copied across, it stays column C. 

o​ Row can change. 

Sort Data in Ascending or Descending Order:​
To sort data: 

1.​ Select the cells you want to sort. 

2.​ Go to the Data tab on the Excel ribbon. 

3.​ Click Sort A to Z for ascending order (small to large or A to Z). 

4.​ Click Sort Z to A for descending order (large to small or Z to A). 

Filter Data Using Auto Filter  

To filter data: 

1.​ Click on all or any column header cell in your data table. 

2.​ Go to the Data tab and click Filter. 

3.​ You’ll see small arrows on each column header. 
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4.​ Click an arrow to filter values 

●​ Below the sorting options, there’s a list of values with checkboxes  
●​ To see only specific scores, uncheck the values you don’t want, those rows will be 

hidden from view. or 

5.​ Click Number Filters to set special rules. 

6.​ Example: Choose “Greater Than” and enter 50 to see only scores above 50. 

7.​ Click OK to apply the filter. 

Creating charts on spreadsheet 

Assignment: Using the Table given as example, Add a column and label it Name before 
subject, Input any name of your choice. 2. Create a chart between Name and Score 

Charts help to visually represent data, making it easier to understand patterns, trends, and 
comparisons. 

Types of Chart 
 

1.​ Column 2. Line 3. Pie 4. Bar 5. Area 6. X Y (Scatter) 7. Stock 8. 
Surface 9. Doughnut 10. Bubble 11. Radar 

Use the following table to create a chart 
 

 

 
 
 
 
 

Chart 1: Column Chart (to compare subject scores) 
This chart shows how a student performed in different subjects. 

Steps in Excel: 

1.​ Enter the data in A1:B6 above 

2.​ Highlight the data. 

3.​ Click Insert > Select Column Chart > Click Clustered Column. 

4.​ Title: "Student Scores by Subject". 

This gives a clear visual comparison of how the student performed in each subject. 
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1 Subject Score 
2 Math 85 
3 English 78 
4 Science 92 
5 History 70 
6 Computer 95 
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Chart 2: Pie Chart (to show score distribution) 
This chart shows the percentage share of each subject in the student's overall score. 

Steps in Excel: 

1.​ Use the same data. 

2.​ Highlight only the Subject and Score columns. 

3.​ Click Insert > Select Pie Chart > Click 2-D Pie. 

4.​ Title: "Score Distribution by Subject". 

5.​ Right-click the chart and choose "Add Data Labels" for percentages. 

Exercise: Teacher should direct student on how to complete this task 

●​ Using the provided table as an example, add a new column labeled "Name" before the 
"Subject" column. Enter any name of your choice in this column. 

●​ Create a 2D Line Chart using the Name and Score columns. 
●​ Select the chart, and then click on design tab under Chart Tools. 
●​ Choose Layout 5 from the Chart Layouts group. 
●​ Under Chart Tools, select the Layout tab. 
●​ Add the following chart elements: Chart Title | Axis Titles | Legend | Data Labels | Axes | 

Gridlines 
 

Introduction to Database Management System (DBMS) 
Assignment: State the advantage and disadvantage of database 

Define Database and Database Management System (DBMS) 

●​ Database: A collection of organized data that can be easily accessed, managed, and 
updated. 

●​ DBMS: Software that helps to create, manage, and use databases (e.g., storing and 
retrieving data). 

Uses or Applications of Databases: 
●​ Education: Store student records, grades, and attendance 

●​ Library: Track books, borrowers, and due dates 

●​ Healthcare: Keep patient history, appointments, and bills 

●​ Banking: Manage accounts, transactions, and loans 

●​ E-commerce: Store product info, orders, and payments 

●​ Social Media: Save user profiles, posts, and messages 

●​ Government: Manage voter ID, passports, and taxes 

●​ Business: Track inventory, sales, and suppliers 
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●​ Transportation: Store flight details and bookings 

Components of DBMS 

1.​ Software – The DBMS program that manages the database. 

2.​ Hardware – Physical devices like computers and servers. 

3.​ Data – Information stored in the database. 

4.​ Procedure – Rules and instructions for using the DBMS. 

5.​ Access Language – Special language (like SQL) to interact with the database. 

6.​ Users – People who use the database (e.g., admins, programmers, end-users). 

Examples of Database Management Systems 

●​ Oracle 

●​ Microsoft Access 

●​ SQL Server 

●​ MySQL 

●​ PostgreSQL 

Database working environment 
Assignment: What is Access object or object in a database? 

Steps to Load MS Access: 
1.​ Open MS Access: 

o​ Click on the Start menu (Windows icon). 

o​ Type “Access” in the search bar. 

o​ Double click on Microsoft Access from the results. 

2.​ Start a New Database: 

o​ When Access opens: 

o​ Click “Blank Database” to create a new database. 

o​ Give your database a name (e.g., “StudentRecords”) in the box on the right. 

o​ Click “Create”. 

3.​ Access Interface Loads: 

o​ Now you see the main MS Access window with a new blank table open, ready to 
add data. 

Navigating MS Access Environment: Main Components 
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●​ Ribbon: The top menu with tools to create and manage database objects. 
●​ Navigation Pane: On the left, shows all tables, queries, forms, and reports. 
●​ Work Area: The main screen where you see and edit data or design objects. 
●​ Status Bar: At the bottom, shows info about what’s happening. 
●​ Quick Access Toolbar: Small shortcuts for Save, Undo, etc., above the Ribbon. 
●​ Title Bar: Shows the name of your open database at the very top. 

MS Access Menu Tabs 
1.​ File — For opening, saving, printing, and managing databases 

2.​ Home — Basic tools like adding, editing, formatting data 

3.​ Create — To create new tables, queries, forms, and reports 

4.​ External Data — Import or export data from other sources 

5.​ Database Tools — Advanced tools like relationships, macros, and utilities 

MS Access Data Types  
1.​ Text 

a.​ Stores short text or numbers (up to 255 characters). 

b.​ Used for names, IDs, or codes. 

2.​ Memo (Long Text) 

a.​ Stores long text (more than 255 characters). 

b.​ Used for detailed notes or descriptions. 

3.​ Number 

a.​ Stores numeric values for calculations. 

b.​ Used for marks, quantities, or ages. 

4.​ Date/Time 

a.​ Stores dates and times. 

b.​ Used for birthdates, exam dates. 

5.​ Currency 

a.​ Stores money values accurately. 

b.​ Used for fees, prices. 

6.​ AutoNumber 

a.​ Automatically gives a unique number to each record. 

b.​ Used for unique IDs like student numbers. 

7.​ Yes/No 

11 
 



THIRD TERM SS 1 DATA PROCESSING 
 

a.​ Stores only Yes (True) or No (False). 

b.​ Used for pass/fail or active/inactive status. 

8.​ Hyperlink 

a.​ Stores links to websites or files. 

b.​ Used for online portfolios or reference links. 

9.​ Attachment 

a.​ Stores files like photos or documents. 

b.​ Used to add student photos or reports. 

Steps to Exit MS Access 

1.​ Click the X button at the top-right corner of the MS Access window. 

Or go to File and click Exit. 

2.​ Alternatively, Press Alt + F4 
3.​  If prompted to save changes: click Yes to save any unsaved changes before closing. 

Database objects 

MS Access Objects 
1.​ Table 

●​ Stores data in rows and columns (like a spreadsheet). 

●​ Example: Student records with ID, name, and grades _point. 

2.​ Query 

●​ Retrieves and filters data from tables. 

●​ Example: Find students with grades below 40. 

3.​ Form 

●​ Easy-to-use screen for entering or viewing data. 

●​ Example: Student registration form. 

4.​ Report 

●​ Formats data summaries for printing or presentation. 

●​ Example: Grade report for a class. 

Create a Table “StudentGrades” in Design View in MS Access 
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1.​ Go to the “Create” tab on the Ribbon. 

2.​ Click “Table Design” — this opens the Design View for a new table. 

3.​ Insert Fields and Declare Data Types: 

4.​ In the Field Name column, type the name of each field (column). 

5.​ In the Data Type column, choose the type for each field from the dropdown menu. 

6.​ Set Primary Key (optional): 

o​ Right-click a field (like StudentID) and click "Primary Key" to set a unique 
identifier. 

7.​ Save the Table: 

o​ Click the Save icon on the top left (or press Ctrl + S). 

o​ Enter a name for the table (e.g., StudentGrades) and click OK. 

8.​ Click the "View" button (top-left) and choose "Datasheet View" to start entering data. 

9.​ To go back and make changes to fields or data types:​
– Click the “View” button again.​
– Choose “Design View” to edit field names or change data types. 

Use the following table component 

Field Name Data Type Description 
StudentID AutoNumber Unique ID for each student 
StudentName Text Name of the student 
Grade Number Student’s total average grade or score  
ExamDate Date/Time Date of the exam 
Comments Memo Additional notes or comments 
Passed Yes/No Pass or fail status 
 

Assignment 
You have been asked to assist in organizing patient records for a small hospital using Microsoft 
Access. Your task is to create a table that stores basic information about each patient for easy 
tracking and reference. 

Using Design View, create a table named PatientRecords with the following fields: 

●​ PatientID (AutoNumber) – a unique identifier automatically assigned to each patient 

●​ FullName (Short Text) – the full name of the patient 

●​ Gender (Short Text) – the patient’s gender 

●​ DateOfBirth (Date/Time) – the patient's date of birth 
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●​ PhoneNumber (Short Text) – the patient's contact number 

●​ Diagnosis (Long Text) – a brief description of the medical condition 

●​ Admitted (Yes/No) – whether the patient is currently admitted to the hospital 

Set PatientID as the Primary Key to ensure each patient has a unique record. 

Once your table is designed, save it as PatientRecords, switch to Datasheet View, and enter at 
least three sample patient records. 

Computer Ethics 

Computer Room Management Ethics refers to the set of rules, responsibilities, and good 
behavior that students must follow when using a computer lab. These ethics help ensure that the 
computers are used safely, responsibly, and respectfully, to protect equipment, maintain a clean 
environment, and support learning for everyone. 

Computer Laboratory Rules and Regulations 
1.​ Enter Only with Permission​

– Always get permission from the teacher before using the lab. 

2.​ No Food or Drinks​
– Eating or drinking near computers can cause spills and damage. 

3.​ Handle Equipment Carefully​
– Do not hit, unplug, or remove computer parts. Use all equipment gently. 

4.​ Keep the Lab Clean and Organized​
– Clean up your area before leaving. Push in your chair and throw away trash. 

5.​ Use Computers for School Purposes Only​
– Don’t play games or visit non-educational websites during class. 

6.​ Do Not Change Settings or Install Programs​
– Changing settings or installing apps without permission can damage the system. 

7.​ Respect Others​
– Work quietly and avoid disturbing your classmates. 

8.​ Report Any Problems Immediately​
– If a computer isn’t working or something breaks, inform the teacher right away. 

9.​ Log Out or Shut Down Properly​
– Always save your work and log out when done. Shut down only if told. 

10.​No Unauthorized Devices​
– Don’t connect USBs or personal devices unless allowed by the teacher. 

Safety Measures 
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The following safety measures help prevent accidents and protect both users and equipment in 

the computer lab. 

1.​ Sitting Arrangement​
– Chairs and tables should be comfortable and at the right height.​
– Sit upright with feet flat on the floor to avoid back and neck pain. 

2.​ Positioning of Monitor Base​
– The monitor should be at eye level and about an arm’s length away.​
– This reduces eye strain and helps maintain good posture. 

3.​ Illuminating the Computer Room​
– The room should have enough light (not too bright or too dark).​
– Good lighting reduces eye strain and headaches. 

4.​ Maintaining a Dust-Free Environment​
– Keep the room clean and free from dust.​
– Dust can damage computer parts and reduce air quality. 

5.​ Keep Liquids Away from Computers​
– Never place water, juice, or any liquid near computers.​
– Spills can cause short circuits and damage equipment. 
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