Evaluate.Day 2.0 Beta test
Please note, Evaluate.Day 2.0 is used only on devices running under iOS 9.0
and higher.
First name
Your answer
Last name
Your answer
Email (Your Apple ID)
Your answer
Please tell us a little bit more
It is not necessary but very desirable to get answers to these questions.
This won’t take much of your time.
Which iOS devices do you use?
What iOS versions are installed at your devices?
Have you used the first version of Evaluate.Day?
Submit
Never submit passwords through Google Forms.
This form was created inside of Chipp Studio. Report Abuse - Terms of Service - Additional Terms