Docs

Chapter 3: Documents

Table of Contents

Docs in the classroom

Work with documents

Start a new document

Find and open documents

Rename a document

Save documents

Copy and paste in documents

The web clipboard menu

Drawings

Presentations

Charts

Manage documents with multiple editors

Benefits of collaboration

View and edit together

View and revert to previous version

Add and reply to comments

Built-in chat

Email collaborators

Basic formatting

Text formatting

Paint format tool

Paragraph formatting

Pagination

Add images

Insert links

Add drawings

Insert equations

Advanced formatting

Table of contents

Bookmarks

Headers and footers

Citations with footnotes

Rulers and margins

Customize titles, subtitles, headings and text style

Create and share document templates

About document templates

Create a template

Submit a template for your school domain

Update or remove a template

Share your template with others

Improve the writing process with Docs

Access anywhere

Feedback and revision

Track progress

Publish work

Create a central archive with Docs

Types of document archives

Organize an archive

Run a paperless classroom with Docs

Docs in the classroom

The real-time collaboration of documents in Google Docs makes it ideal for group assignments, revision cycles, and shared notes. Built-in tools like autosave and revision history, comments, and an equation editor are useful for students and teachers alike.

Some examples of how teachers can use online documents:

Some examples of how students can use online documents:

Work with documents

Start a new document

There are different ways of getting started using Google documents: you can create a new online document, you can upload an existing one, or you can use a template from our templates gallery.

From your Docs list

To create a new document, go to your Docs list, click the Create drop-down menu, and select Document.

From an existing Doc

You can also create a new document while in an existing document, spreadsheet, presentation, or drawing. Simply click the File menu, select New and choose Document.

Upload and convert

You can also upload a variety of file types into Google Docs and have it automatically convert into a document. Review accepted imported data types » 

When you upload a file, a box that indicates the progress of the upload appears in the bottom right of your screen. You can minimize the box or move it to the left or right of the screen. When you’re done, you can click the document title to open the uploaded file or close the box by clicking the x in the upper right of the box.

To add items to your docs list, you have a few options.

Drag and Drop

You can drag-and-drop your files directly from your computer into your Documents List, and even straight into a collection. This feature is available only in the latest versions of Chrome, Safari, and Firefox. If you aren’t working in the latest version of one of those browsers, you can click the Upload button and select Files from the drop-down menu.

File upload

To manually select files from your computer to upload to Google Docs, follow these steps:

  1. In your Documents List, click the Upload button and select Files from the drop-down menu.
  2. Select the file you’d like to upload to Google Docs. To select multiple files, press Shift or Ctrl and click all the files to upload.
  3. Your file will appear in your Documents List.

Find and open documents

Documents that you have created will always be saved in your Docs list.

You can easily search for documents by starting to type a search term, Google Docs will start to suggest documents from your list.

If you do not see the document you’re looking for in the suggestions, click the Search Docs button to see a full list of results.

There are also sections of the Docs list that can help you find your documents based on how you view the document, such as which documents are Owned by me, Shared with me, Not in collections and so forth. Some documents may exist in more than one section, such as a document someone shared with you that you have opened.

You can also browse documents in your Docs list by file type or other saved searches. Because Google Docs allows you to store any digital media, you can also browse for images and video in your docs list and collections.

Finally, you can additional filters in your doc list to locate your documents. You can sort by when it was last modified, when you last opened it, title of the document, and more.

Rename a document

When you create a new document, Google Docs will start saving it as either Untitled or will create a title from the first few words entered in the document.

To choose a name other than Untitled, click the File tab from your doc, and select Rename. From here you can choose and confirm your document's title.

You can also edit the name by clicking the title displayed at the top of the page, and making your changes in the dialog that appears.

Finally, you can access the More menu when select a doc from your docs list From there, you can rename the document.

Please note: titles can be up to 255 characters long.

Save documents

Because Google Docs saves to a secure, online storage facility, you can create documents, spreadsheets and presentations without the need to save to your local hard drive. You can also access your documents from any computer. In the event of a local hard drive crash, you won't lose your saved content.

If your browser or computer crashes, your document has been automatically saved and you will still be able to recover it – on any computer. Google Docs also keeps a complete revision history of your document, so you can revert to any version at any time.

You’ll see the status of your save up in the top right corner of your document, near the share button.

While we can't give you exact figures, please be assured that we back up data almost as often as you can change it.

Copy and paste in documents

Google Docs is designed to let you copy and paste text and images between all of your online documents – even if you're going from one document type to another.

This can be useful for collecting information across a variety of media or the process of outlining and drafting in a document, while moving content over to a presentation.

And since the copying and pasting takes place online, you can copy on one computer, then sign in and paste on another one. Here are some examples of things you can do:

There are two ways to copy and paste: keyboard shortcuts and the server clipboard menu.

Keyboard shortcuts: Ctrl-C and Ctrl-V For most copying and pasting, you can use the familiar keyboard shortcuts, Ctrl-C(Copy) and Ctrl-V (Paste). This even works when going from one doc type to another. But there are a couple of exceptions in which keyboard shortcuts don't work as well (yet). In these cases, you should use the server clipboard menu:

The web clipboard menu

There are a few specific cases in which the best way to copy and paste is using the web clipboard menu. When you copy a selection using this menu, the content you copy is stored and associated with your school Apps Account. That means you can copy more than one selection and then choose which one to paste later; it also means you can copy something on one computer and then paste it on another.

The web clipboard menu

There are a few specific cases in which the best way to copy and paste is using the web clipboard menu. When you copy a selection using this menu, the content you copy is stored and associated with your Google Account. That means you can copy more than one selection and then choose which one to paste later; it also allows you to copy something on one computer and then paste it on another. To copy a selection using the web clipboard menu, follow these steps:

  1. Select what you'd like to copy.
  2. Click the Web clipboard menu that appears in the toolbar of your doc.
  3. Click Copy selection to web clipboard.
  4. In the destination document, click the web clipboard menu; you'll see the selection that you previously copied. If you copied multiple things, you'll see a list of the items you've recently copied.
  5. Place the cursor where you want to paste the content.
  6. Click the Web clipboard menu.
  7. Select what you want to paste. Depending on your selection, you'll see different formats that you can choose from to paste what you've copied (for example, HTML or plain text).
  8. Select a format.

Drawings

You can use the web clipboard to copy shapes from drawings and paste shapes into drawings embedded in Google spreadsheets, documents and presentations, or to copy and paste a drawing from a doc into the standalone drawing editor.

Click the web clipboard icon and select Copy shapes to web clipboard. Then, open the doc that you want to paste the drawing into. Click the web clipboard icon and select the drawing you want to paste from the menu.

Presentations

You can't use the web clipboard to copy and paste regular text and images in Google Docs presentations yet. You can select entire shapes on a single slide, and if the shape is a text shape, then the text will be copied to the server clipboard.

Charts

You can use the web clipboard to copy and paste charts from a spreadsheet into a document or drawing.

How content on the web clipboard is stored and protected

You can access the content copied to the web clipboard only by signing in to the same Google Account you used to copy the content originally.

Content you copy to the web clipboard is stored on Google's servers and remains there until 30 days have passed since you last took action on (for example, copied) a given content selection. Even if a document is deleted, anything you copied from that document to the web clipboard will still exist on Google's servers for that 30-day period. You can delete all items stored on the server clipboard by clicking the drop-down menu and selecting Clear all items.

Manage documents with multiple editors

Benefits of collaboration

Google Docs enables multiple people in different locations to collaborate simultaneously on the same doc from any computer with Internet access.

For example, teachers can work together on a single document to develop curriculum plans for the year. No one has to compile all the edits together, since everyone is making changes to a single doc. Because the document is online, teachers can collaborate beyond the school and start sharing with others in the district. With everyone contributing ideas and comments, everyone benefits from a more collaborative curriculum.

Another example is for students paired with another class for a group assignment. While the students may never have class together, they can start a document and edit it at any time. After class, they can even open the document and write together, chatting about the project directly in the doc. They can then share the document with a few classmates for peer editing. When they complete the project, they can share the final version or create a copy to share with the teacher, who can also provide the grade and feedback directly in the document.

With everyone working on the same doc, there’s no back and forth of versions and edits. This can also accelerate the feedback and revision process, allowing teachers to provide quick comments and students to incorporate changes as they’re writing.

View and edit together

To learn how to share documents with individuals or groups, review previous chapter on sharing »

If you and another collaborator are editing the same document at the same time, a box with the number of collaborators appears at the top of the screen.  If you hover your cursor over one of the boxes, the name of the collaborator will be displayed.


If other people are editing a document simultaneously with you, you will see their edits in real time. You can also see
the text that other editors are highlighting as they select it. If someone is about to delete something on your screen or drag text somewhere else, you’ll see them highlight that text before anything changes.

You also have the ability to see their names listed at the top of a document. Click the arrow to the right of the names to open a tab where you can chat with other editors within the document.

Please note: Up to 50 people can edit a document at the same time. You can share a document with up to 200 people.

View and revert to previous version

Working in groups makes the autosave and revision history feature especially helpful.

Since copies of your document are saved anytime a collaborator makes edits, it’s easy to check and see who made what edits and when.

To browse previous versions of a shared document, follow these steps:

  1. From your document, click File > See revision history.
  2. Changes are color-coded based on each collaborator, making it easy to tell what has been added or deleted. This is perfect for evaluating group projects, participation, and more.
  3. While viewing the revision history, you can show more detailed revisions by selecting Show more detailed revisions.

If you change your mind about the most recent edits you or your collaborators made to the document, simply revert to an older version by following these steps:

  1. Click down through the edits until you find the version you want.
  2. Click Restore this revision.

Your document is reset to the version you selected. Now, when your collaborators view this document, they'll see the version you selected.

Add and reply to comments

Comments are a convenient way of adding notes to your regular document text and are visible to viewers and collaborators. These can be invaluable for communicating with collaborators about specific parts of the document, as well as making notes about changes you've made or would like to make.

Comments are useful for the feedback and revision process, as teachers or peer editors can add ideas or questions without disrupting the contents of the document. You can highlight as many or as few words you want to begin a comment.

Because a comment often leads to explanations or additional comments, Google Docs makes it easy to reply to a comment in the same format, allowing you to read a “conversation” of comments or have a discussion.

Inserting Comments

Comments are a handy way of adding notes to your regular document text and are visible to viewers and collaborators. These can be invaluable for communicating with collaborators about specific parts of the document, as well as making notes about changes you've made or would like to make.

To add a comment to your document, follow these instructions:

  1. Place your cursor or highlight the text where you'd like your comment to appear.
  2. From the Insert menu, select Comment.
  3. You can also use the keyboard shortcut Ctrl+Alt+ M (Cmd+Option+M for Mac) to insert a comment.
  4. Type your comment in the box that appears to the right of the document.

 

Working with Comments

After inserting a comment, there are two main places you can work with it inside the document: within the comment or in the comment stream, accessible from the Comments drop-down menu in the top right of your document.

You can reply to a comment with a new post, edit or delete a previous comment you’ve inserted, and resolve the discussion when you’re ready to remove it from the document. Resolving a discussion removes the discussion from the document, but resolved threads will always be available under the Comments drop-down menu.

Document comments

From the Comment drop-down menu in the top right of your document, you can review all comments, including those comments that have been resolved. From this menu, you can also change the notification settings for comments.

Sometimes it can be cumbersome to have to scan through your document to view all comments. If you select the Show comment stream menu option, you can keep track of all comments throughout the document, including those that have already been resolved. In this view, you can also make comments about the entire document.

Notifications and engaging with others

Comments are most useful when you leave them for others to review. You can easily target your comments at particular students, respond to comments from within email, and easily keep track of the comments people leave in your document without having to continuously return to the document.

Adding others to a comment

You can easily add others to a comment by typing '+' followed by a contact’s name or email address into a comment. For example, I would type +johndoe if my contact was johndoe@myschool.org. Your contacts will auto-populate when you start typing.

Adding someone to a comment will email them a notification containing the comment thread. If that collaborator doesn’t want email notifications, they can always mute or change their notification settings by selecting Mute updates from this comment at the bottom of the email or by selecting Discussion notification settings... from the Discussions drop-down. If you have been added to a comment and aren't receiving email notifications, you may want to check your email spam folder.

Changing discussion notification settings

You can control your comment notifications. From the Comments drop-down menu, select Notification settings... A dialog will open, and you can select if you’d like to receive email notifications. If you opt to receive email notifications, you can also select what type of notifications you’d like to receive.

Built-in chat

Google Docs supports chat directly in the document without interfering with the contents of the document itself.

Chats are not saved with the document like comments or regular edits, but are primarily used for discussing a document among editors. Chats and real-time editing combined together can allow groups to work and communicate together without meeting face to face.

To start chatting with collaborators in a document, follow these steps:

  1. Find the number of viewers at the top of the document – if there are no viewers, then no one else is viewing or editing the document and you cannot begin a chat.
  2. Click the arrow to the left of the number of viewers to open a tab.
  3. The names of those editing the document will appear in the chat window.
  4. Begin typing and chatting!

Email collaborators

Communicating with other collaborators is useful when you want to notify others of changes you made or send a message about the document.

You can easily email other collaborators directly in the document, just follow these steps:

  1. Click the down arrow on the right side of the File button in your document.
  2. Select Email collaborators... from the drop down menu.
  3. Choose the collaborators you wish to notify using the checkbox next to their name. There are also shortcuts to select or deselect all.
  4. You can modify the subject (by default it is the name of the document) and enter a message to the collaborators.
  5. Click the Send button.

Basic formatting

Text formatting

Editing text in Google Docs is similar to using editors of other word processing software.

The Styles toolbar menu at the top of your document displays the style of your text selection in a document, and lets you change the style or clear the formatting of your text.

To change the font or text size, simply select the text that you'd like to change and click either the font menu, which lists Arial as the default font, or the text-size drop-down menu, set to 11pt by default. Choose a new font or text size and the changes are applied to the selected text.

Please note: Arial and Times New Roman only appear as options in the font menu if you have these fonts installed on your computer.

To view a list of heading available, click the menu that appears right before the Font drop-down menu, or click Format and select Paragraph styles. Then, choose one of the styles, which range from 'Heading 1,' the biggest, to 'Heading 6,' the smallest.

 The styles toolbar also lets you choose a text color or highlight color:

  1. Highlight the text.
  2. Click the 'A' drop-down menu and choose a color for text color, or click the drop-down menu with the highlighter pen (it's next to the text color menu) and choose a color.

To see which menu option corresponds to the text you're using, simply click the text in your document. The color on the text color and highlighted color menus will reflect the color you're using. If you click the drop-down menus, the color in use will have a check mark next to it.

Paint format tool

Google documents lets you copy the formatting you’ve applied to a specific section of text to another section using the paint format tool. If you’re familiar with the paint format tool in Google spreadsheets, this works in a similar manner.

To use this tool, select the text that's formatted in the way that you want to copy. Then, click the paintbrush icon in your toolbar, and select the text to which you want to apply the formatting. The formatting from the original text will be copied to the selected text.

To change the formatting in multiple places within your document, double-click the paintbrush icon. You'll enter a mode that lets you highlight multiple text selections, and apply the same formatting to each selection. When you're done applying formatting to these selections, click the paintbrush icon again.

You can also use the paint format tool with keyboard shortcuts. Ctrl+Option+C will copy the formatting of the text you've selected, and Ctrl+Option+V will apply any copy that formatting to a different text selection.

Paragraph formatting

Google Docs has standard selections for line spacing, paragraph alignment, and lists.

If you'd like to change the spacing of the document, follow these steps:

  1. Click the line spacing button on the far right of the toolbar
  2. Select an option from the menu.

If you’d like to change the alignment of a paragraph, place your cursor somewhere in the paragraph and click one of the alignment buttons.

Start a numbered or bulleted list by clicking on one of the list icons.

Pagination

Pagination adds visual page breaks while you’re editing your documents, so you can see how many pages of that report you’ve actually finished. With pagination, you’re able to see headers at the top of each page in your document, manual page breaks move text onto a new page, and footnotes appear at the bottom of the page automatically.

Hide page breaks

If you prefer editing documents with a continuous layout, you can hide page breaks by going to the View menu and selecting the Compact from the Document view option.

Add images

You can enhance your document by inserting images. Google Docs also lets you choose to display the image inline or fixed.

To insert an image, follow these steps:

  1. Click the Insert drop-down menu from the toolbar and select Image.
  2. Depending on what image you'd like to add to the document, click Upload, URL, Google Image Search, Picasa Web Album, or Stock photos and follow these instructions:

Drag and Drop Images

Images can also be inserted into Documents directly from your desktop through drag and drop. This feature is a great time saver! For now, you can use image drag and drop with the latest versions of Google Chrome, Firefox, and Safari.

Insert links

Auto-Linking

When you type something that documents recognizes as a link, it will become a link automatically. Try typing “docs.google.com”, “www.google.com,” or an email address in a document to try it out.

If you don’t want your text to be a link, you can undo the auto-linking by pressing Ctrl Z (Cmd Z on a Mac). And if you think you’ll never want automatic link detection, you can disable it by opening the Preferences dialog from the Tools menu.

If you want to insert a link to a website or an online document as a reference, follow these steps:

  1. Click anywhere in your document where you'd like the link to appear.
  2. Click the Insert drop-down menu and select Link..., or click the link icon in the toolbar. The 'Edit Link' window appears.
  3. Type the text you'd like to be displayed as the link (if you selected specific text, it will already appear in the 'Text to display' field). Leave this field blank if you want the full link to be displayed in your document.
  4. Select either 'Web address', 'Email address’, or ‘Bookmark’.
  5. Enter a URL (or an email address if you selected 'Email address') in the second text box.
  6. Click OK.

Add drawings

Drawings can also be added to your document to support brainstorming, mind maps, and more.


To add a drawing, follow these steps:

  1. Click the Insert drop-down menu from the toolbar and select Drawing.
  2. Create your drawing using the shapes and options in the toolbar.

  3. Add the image to your document, spreadsheet or presentation by selecting Save and Close

There is also the ability to copy an existing Google drawing into a document. From inside drawings click on the web clipboard icon and select Copy entire drawing to web clipboard.

Insert equations

You can easily insert mathematical equations into your documents, and collaborate on a single equation at once with multiple people. Follow these steps to add an equation to your doc:

  1. Click the Insert drop-down menu and select Equation.
  2. Select the mathematical symbol you want to add from one of these menus:
  1. Greek letters
  2. General operators
  3. Comparison and inclusion operators
  4. Operators with variables
  5. Arrows
  1. Click the symbol you'd like to include, and add numbers or substitute variables in the box. If you delete the box by mistake, simply click New equation, and then select an option from one of the menus
  2. If you'd like to edit the equation afterwards, simply click the equation within the document and change it. If you don't see the equation toolbar, click View and select Show equation toolbar.

Using automatic equation shortcuts

LaTeX is a document markup language that’s often used by academics to quickly type out complex formulas. In Google Docs, when you’re inside an equation you can type '\sqrt' followed by a space or a parenthesis to automatically convert the text into a square root sign √. Other examples of useful shortcuts are '\frac' for a fraction and shorthands like '\epsilon' for Greek symbols. A full list of equation shortcuts can be found here.

Advanced formatting

Table of contents

The table of contents in Google Docs can be generated to help keep the information in your document organized and easy to navigate. The table of contents automatically links to different parts of your documents and also works if you have your document published.

Please note: The formatting and contents of a table of contents are based on the headings in your document. To change the text of the table of contents, you will need to edit the headings. If you make changes to the formatting of your document, you may need to update your table of contents to reflect the latest organization.

To create a table of contents, follow these steps:

  1. Add headings to your document by clicking Format > Paragraph styles in the toolbar, and selecting a heading, or by selecting from the dropdown in the Styles toolbar.


  2. Place your cursor where you would like the Table of contents to appear.
  3. Click Table of contents from the Insert menu.

If you need to move the table of contents, select it as you would select text and either move it with your cursor or cut it and paste it.

You can continue to add headings to your document or change current headings. However, if you'd like a change to become part of the table of contents, you need to click first the table and then the Update now button.

Each item in your table of contents links to the titled sections of your document that use the heading styles (that you added in step 1 above).

Bookmarks

Bookmarks are shortcuts to specific places within a document, acting like hyperlinks.

They can be very useful when you need to make a table of contents that’s not based on paragraph heading styles, or when you want to jump from one part of a long document to another without scrolling.

For example, if you have a running document of notes, you could bookmark the date or agenda for each section or specific important parts and have them prominently displayed at the top of the document. You would not have to alter the font style as you would for a table of contents.

To create a bookmark in your document, follow these steps:

  1. Click where you want to place the bookmark in your document.
  2. Click the Insert drop-down menu.
  3. Select Bookmark.

A bookmark is only useful when you can link to it, otherwise there’s no way for anyone to jump to your bookmarked section.

To create a link to a bookmark in your document, follow these steps:

  1. Highlight the text you'd like to link from. You can also just click anywhere in your document to create a link there.
  2. Click the Insert drop-down menu and select Link..., or click the link icon in the toolbar.
  3. In the 'Edit Link' window, select the 'Bookmark' option to see the bookmarks you've created.
  4. Click the bookmark you'd like to link to.
  5. Click OK.

If you need to edit or remove the link, click on the bookmark link and the 'Go to link' window appears. In this window, you can see the bookmark you're linking to, and the Change and Remove links.

Headers and footers

To insert headers and footers in your doc, click the Insert drop-down menu and select Header or Footer.

Type the text for your header or footer in the area with dotted lines.

To exit the header or footer, click anywhere else in your document.

To remove your header or footer, simply delete the text within the header or footer and then click anywhere in the main document editing space.

Citations with footnotes

Citations are commonplace in the classroom – in Google Docs, you can use footnotes to capture references.

Footnotes are a little like comments in that while you’re in the browser, they appear on the side of the document. Comments appear in yellow on the right, while footnotes show up in grey on the left. When printed, footnotes will appear at the bottom of the page. There will also be a footnote marker within the actual document designated by numeral. Example: 2 

To insert footnotes in your document, follow these steps:

  1. In the place you want to insert a footnote, click the Insert menu and select Footnote.
  2. Type your footnote in the text box that appears in the document margin. When you're finished, click inside the main document.

To edit the footnote, simply edit the text in the footer..

To move a footnote, select, copy, and drop the footnote numeral anywhere you'd like in the document.

To delete a footnote, put your cursor just past the footnote numeral and then use your Delete or Backspace key.

Footnotes in downloaded or exported docs:

Rulers and margins

With Google documents, you can have full control of the location of your text. The ruler at the top of the document editing space is the starting point to control where your text appears. From the ruler you can adjust margins, indents, and tabs.

Margins

Margins affect the formatting of an entire document. You can adjust them by dragging the gray area on either side of the ruler, or by adjusting the margins by selecting File > Page setup from the toolbar.

Indents

You can change indentations at the paragraph level. To adjust indentations across several paragraphs, select the relevant text and adjust the specific indent.

Tab stops

Like indents, tab stops affect documents at the specific paragraph level. Each tab stop determines how text is aligned relative to it: a left tab stop left aligns particular text to the tab stop, a center tab stop center-aligns it, and a right tab stop right aligns that text.

To add a tab stop, just click anywhere in the ruler and select a tab stop. You can move text between tab stops affecting the same line by pressing the Tab key on your keyboard.

Customize titles, subtitles, headings and text style

With styles, you can quickly customize the look of text in a Google document. Use the new styles toolbar menu to format text in your document.

  1. Highlight a selection of text with the font size and style that you'd like to use for normal text or a particular heading.
  2. Go to the styles toolbar menu, and click the arrow next to Normal text or Heading 1-6.
  3. Select Update Heading X to match selection.
  4. All of the text in your document with the same text type, such as Heading 4 or Normal text, will be updated to match the font and font size of your initial selection.

Create and share document templates

About document templates

Google Docs allows you to save any document, spreadsheet, presentation, drawing, or form as a template for others to use. Templates are available in the template gallery, linked in Google Docs, and can be found by searching, browsing categories or clicking directly to the template preview.

With Google Apps Education Edition, you can create templates specifically for use at your school Apps domain. Your school Apps domain has its own template gallery that is separate from the general public gallery. You cannot submit a template to the public gallery with your school Apps account, just the gallery for your school. If you'd like to submit a template to the public gallery, first sign in to your personal Google Account.

When you use a template, you create your own copy, so it doesn't matter if the template owner changes or deletes the original template; your copy remains unchanged.

Classes often have several common formats that can take advantage of shared templates for any student or teacher to use. For example, a teacher could allow students to easily create a predetermined format for bibliographies, book reports, research papers, presentations, or any other type of assignment. Student government could create common documents for club budgets or newsletters. Administrators could create a standard format for reporting absences, grades, or behavior logs. If there’s a document format that can be used by multiple people, it may be helpful to save it as a template.

Create a template

Creating a template is no different from creating a regular document. You may want to keep the information anonymous or unidentifiable, since it will be available to your domain (or the world, depending on how you choose to submit the template). Including instructions can be helpful for those who use the template, to provide cues for how the document flows or is formatted.

Please note: When someone uses your template, they are creating a copy of the document into their own Docs account. If you make changes later, they will not see those changes since they already made the copy.

Submit a template for your school domain

Once you have created the document you wish to use as a template, you can submit it to the template gallery for your school domain.

Please note: You cannot submit a template for public use with your school Apps account. If you'd like to submit a template to the public gallery, first sign in to your personal Google Account.

You can submit your template either from the main template gallery page or from your Docs list.

To submit a template from the template gallery page, follow these steps:

  1. Go to your Docs list home (http://docs.google.com/a/myschool.org where myschool.org is your school Apps domain)
  2. Click the Create link and select From Template... to access your school Apps domain template gallery. You should be in the tab labeled “My School Templates” - where My School is the name of your Apps domain.
  3. Click Submit a template on the top right of the templates main page.
  4. Click Choose from your Google Docs and select the document from your Google Docs that you'd like to submit as a template.
  5. Click Select.
  6. Enter a short description, pick one or two categories for the template, and select a language.
  7. Click Submit template.

To submit a template from your Docs list, follow these steps:

  1. Go to your Docs list home (http://docs.google.com/a/myschool.org where myschool.org is your school Apps domain)
  2. To do this, select the document in your doc list by clicking on it, then select More then Submit to template gallery.
  3. This will take you to the submission page where you can enter a short description, pick one or two categories, and select a language.
  4. If you wish to change the document you are submitting, you can click the Choose a different item link near the top of the page.
  5. Click Submit template.

Your submitted template will appear within your domain tab and the My Templates tab.

Note that it may take up to several minutes for the template to appear.

Please note: When you submit a template to the gallery within your domain, the name on your Google Apps account should be displayed.

Update or remove a template

You can make changes or remove templates you have submitted to your school Docs template gallery at any time.

Please note: If you make changes to your template, those that have already used your template will not see those changes, only those that use the template after you have made the modifications.

To delete or edit a template that you've submitted to your domain template gallery, follow these steps:

  1. Go to your Docs list home (http://docs.google.com/a/myschool.org where myschool.org is your school Apps domain)
  2. Click the Create link and select From Template... to access your school Apps domain template gallery. You should be in the tab labeled “My School Templates” - where My School is the name of your Apps domain.
  3. Now click on the My Templates tab.
  4. To edit a template, click the Edit details link to the right of 'Owner options' and make your edits. You can also change the content of your template by clicking Edit this document. Once you make changes to the actual document, save and close it to return to the Edit menu. Your changes will appear within the template in the gallery.

  5. To delete a particular template, click the Remove from gallery link to the right of 'Owner options,' and then you'll be able to remove the template from the gallery.

After you delete a template, no user can preview or use the template. However, those that have already copied the template to their own Docs account will still have access to those documents.

Share your template with others

To share the template you have made with your students or others at your school, you can provide the direct link where a user can preview the template and select to use it.

To find the link for your templates, follow these steps:

  1. Go to your Docs list home (http://docs.google.com/a/myschool.org where myschool.org is your school Apps domain)
  2. Click the Create link and select From Template... to access your school Apps domain template gallery. You should be in the tab labeled “My School Templates” - where My School is the name of your Apps domain.
  3. You should be in the tab labeled “My School Templates” - where My School is the name of your Apps domain.
  4. Click on the My Templates tab.
  5. In the list of templates, click on the Preview link next to the Use this template button. You can also click on the thumbnail of the template.
  6. Copy the URL of this page, it is the direct URL to the preview of your template.

Others can also find your template by searching the template gallery or browsing the gallery categories.

To use a template, click the Use this template button, either in the template gallery or on the template preview page, and a copy of the template is created and added to your Docs list.

Users will then start editing their own copy of the document directly in Google Docs and can share with others just as they would any other document.

Improve the writing process with Docs

Access anywhere

With Google Docs, files are accessible from any computer connected to the Internet. This opens up many possibilities for starting and continuing the writing process.

Online documents take out the hassle of remembering thumb drives or having to use the same computer to access a file. There’s no risk of forgetting or losing the document, because everything is stored online.

With access to your files readily available wherever you are, it’s easy to find time to create or revise documents and share it with others. It doesn’t matter if your collaborators are in the same room or the same country, everyone can edit at his or her convenience.

Feedback and revision

The ease of sharing and ability to view comments and feedback on a single version of a document makes Google Docs an ideal platform for peer reviews and revision cycles.

Instead of arranging set days for peer reviews and edits, students can share early drafts with others when they’re ready for feedback. Writers can also start making changes before the reviewer has finished editing – as comments and changes appear in real-time, students can begin incorporating the feedback immediately.

Learn how to provide comments »

Because sharing a document means everyone views a single version, Google Docs makes it easy to have multiple peer reviews without having to consolidate feedback over different copies. With more review cycles and ongoing feedback, students can continue to fine-tune their drafts.

Learn how to share documents with others »

An advantage for teachers is to jump in the writing process earlier. When a document is shared, teachers can provide feedback whenever it's important in the revision cycle – not just at designated due dates.


Track progress

Comprehensive document revision history – made possible by nearly continuous autosave – is helpful for both teachers and students.

When a student shares a document with a teacher, the teacher can look at a document and understand how the document has evolved from early drafts or how peer reviews and comments were incorporated into the final product.

Learn how to view a dodcument’s revision history »

Students themselves can compare different versions to reflect on the changes and lessons learned throughout the process that they can apply to future assignments.

Publish work

Sharing your final written work with the school has much more weight than simply printing out a paper that is submitted in class.

Teachers might encourage students to publish their work, so that anyone in the school can find and read it, to provide external motivation beyond an assignment grade.

Learn how to publish a document » 

Create a central archive with Docs

Types of document archives

Documents that repeat the same format and are used on a regular basis can benefit from a central document archive created in Google Docs.

Learn how to create a new document in Google Docs »

For example, meeting notes taken weekly or monthly can all exist in a single document, making it easy to review past notes and top issues. It’s much easier to keep track of a single document then to hunt for emails or search for one of many files.

Daily or weekly journal entries can also be saved in a single document, making it easy for others to review the latest work but still have the option of viewing previous entries. If the document is being assessed on a regular basis, a single document archive simplifies the process. Teachers can always open the same document to go in and review the latest contents.

Learn how to share documents in Google Docs »

Other types of documents that could be kept in a single doc:

Organize an archive

Google Docs has bookmarks and paragraph headings that can help keep your single document archive organized and easy to navigate.

For example, if you were keeping meetings notes in a document, you could add bookmarks for each entry, or for specific times (the beginning of the month/semester/quarter). You could then add links to these bookmarks at the top of the document so others could jump to areas of interest.

If you had a progress report, you could generate a table of contents based on heading styles for each of the different grading periods, and then segmented into the areas of evaluation. A parent, shared as a viewer on the document, could then easily jump to various parts of the report and be able to track progress over time.

Learn how to create a table of contents »

Learn how to add a bookmark »

Run a paperless classroom with Docs

You can use a fully online process to post assignments, and accept student work using Google Docs.

Below is a sample workflow for a teacher using an assignment flow in Google Docs:

Share assignment

A teacher could create and edit the assignment in a document (or a presentation) and share it with the class either as a group with view access, embed it into the class site, or publish it to the school domain and provide students a link to the assignment.

Learn how to share and publish documents »

Copy assignment/template

If the document was a standard format for students to use, the teacher could publish it as a template and include the link to the template in the assignment document.

Learn how to create and submit templates »

Complete assignment

Students would be able to read the assignment online and start their work in Google Docs. If the teacher provided a template, they could copy the template and begin adding their work in the correct format.

Submit assignment

When students are ready to submit the assignment, they can share the document with the teacher. For organization purposes, the teacher could require a standard document naming format (i.e. LastnameFirstnam_period_assignmentnumber). Alternatively, students can drag the file into a shared ‘Completed Assignments’ folder with the teacher.

Learn how to add documents to a shared folder »

Grade assignments

The teacher can then begin grading documents as they are shared by the students, providing comments directly into the document. The teacher knows a file is ready to be graded only when the document is shared with the proper name format, or when it is dropped into the student’s Completed Assignments folder.